diff options
author | Paresh Bhagat <p-bhagat@ti.com> | 2023-06-14 12:37:54 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-06-14 12:49:59 -0500 |
commit | 82695339888e0678d9e98b57b134f768983d073a (patch) | |
tree | bd8dc54e78382600488148b65c12f84ecc6d161e | |
parent | 4c5461c23708d9f235976f25acd95cd30114af7e (diff) | |
download | meta-ti-82695339888e0678d9e98b57b134f768983d073a.tar.gz |
ti-extras: Add support for extra kernel/u-boot features
There are some features that will either never be accepted into the
upstream kernel, or are not ready to be accepted. ti-extras allows for
controlling the kernel and u-boot repos, breanches, and srcrevs to gain
access to those features via the TI_EXTRAS variable in the local.conf
file.
Initial support for TI_EXTRAS=tie-jailhouse is being added by this
patch.
Signed-off-by: Paresh Bhagat <p-bhagat@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Acked-by: Paresh Bhagat <p-bhagat@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf | 1 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/am62xx-evm.conf | 1 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/include/ti-extras.inc | 4 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc | 12 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb | 7 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-kernel/linux/ti-extras.inc | 13 | ||||
-rw-r--r-- | meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb | 2 |
9 files changed, 40 insertions, 4 deletions
diff --git a/meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf b/meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf index 9889ae38..548369ca 100644 --- a/meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf +++ b/meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf | |||
@@ -3,6 +3,7 @@ | |||
3 | #@DESCRIPTION: Machine configuration for the TI AM62xx EVM (R5F core) | 3 | #@DESCRIPTION: Machine configuration for the TI AM62xx EVM (R5F core) |
4 | 4 | ||
5 | require conf/machine/include/k3r5.inc | 5 | require conf/machine/include/k3r5.inc |
6 | require conf/machine/include/ti-extras.inc | ||
6 | 7 | ||
7 | SYSFW_SOC = "am62x" | 8 | SYSFW_SOC = "am62x" |
8 | SYSFW_CONFIG = "evm" | 9 | SYSFW_CONFIG = "evm" |
diff --git a/meta-ti-bsp/conf/machine/am62xx-evm.conf b/meta-ti-bsp/conf/machine/am62xx-evm.conf index c4357be3..082a1ae7 100644 --- a/meta-ti-bsp/conf/machine/am62xx-evm.conf +++ b/meta-ti-bsp/conf/machine/am62xx-evm.conf | |||
@@ -3,6 +3,7 @@ | |||
3 | #@DESCRIPTION: Machine configuration for the TI AM62XX EVM | 3 | #@DESCRIPTION: Machine configuration for the TI AM62XX EVM |
4 | 4 | ||
5 | require conf/machine/include/am62xx.inc | 5 | require conf/machine/include/am62xx.inc |
6 | require conf/machine/include/ti-extras.inc | ||
6 | 7 | ||
7 | KERNEL_DEVICETREE_PREFIX = "ti/k3-am625" | 8 | KERNEL_DEVICETREE_PREFIX = "ti/k3-am625" |
8 | 9 | ||
diff --git a/meta-ti-bsp/conf/machine/include/ti-extras.inc b/meta-ti-bsp/conf/machine/include/ti-extras.inc new file mode 100644 index 00000000..4e62605c --- /dev/null +++ b/meta-ti-bsp/conf/machine/include/ti-extras.inc | |||
@@ -0,0 +1,4 @@ | |||
1 | # Add TI_EXTRAS to machine overrides so we get access to e.g. 'jailhouse' | ||
2 | |||
3 | TI_EXTRAS ??= "" | ||
4 | MACHINEOVERRIDES =. "${@ '${TI_EXTRAS}:' if d.getVar('TI_EXTRAS').startswith('tie-') else ''}" | ||
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc b/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc new file mode 100644 index 00000000..3a016c6c --- /dev/null +++ b/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc | |||
@@ -0,0 +1,12 @@ | |||
1 | |||
2 | # This will have priority over generic uboot path | ||
3 | |||
4 | COMPATIBLE_MACHINE = "am62xx" | ||
5 | |||
6 | BRANCH = "ti-u-boot-2023.04" | ||
7 | BRANCH:tie-jailhouse = "ti-u-boot-2023.04-jailhouse" | ||
8 | |||
9 | SRCREV = "010afc1fe7a1412f92363c8af69c848d76a53e42" | ||
10 | SRCREV:tie-jailhouse = "79615e1c99b9aa73948f811f5f866cff2e34dc37" | ||
11 | |||
12 | UBOOT_GIT_URI = "git://git.ti.com/git/processor-sdk/u-boot.git" | ||
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb index f4c5e88c..4bde0256 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb | |||
@@ -1,5 +1,7 @@ | |||
1 | require u-boot-ti.inc | 1 | require u-boot-ti.inc |
2 | 2 | ||
3 | include ${@ 'recipes-bsp/u-boot/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''} | ||
4 | |||
3 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1" | 5 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1" |
4 | 6 | ||
5 | PR = "r0" | 7 | PR = "r0" |
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc index 9a2c3181..d9a3a520 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -16,7 +16,7 @@ LICENSE = "GPL-2.0-or-later" | |||
16 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" | 16 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" |
17 | 17 | ||
18 | BRANCH ?= "master" | 18 | BRANCH ?= "master" |
19 | UBOOT_GIT_URI = "git://git.ti.com/git/ti-u-boot/ti-u-boot.git" | 19 | UBOOT_GIT_URI ?= "git://git.ti.com/git/ti-u-boot/ti-u-boot.git" |
20 | UBOOT_GIT_PROTOCOL = "https" | 20 | UBOOT_GIT_PROTOCOL = "https" |
21 | SRC_URI = "${UBOOT_GIT_URI};protocol=${UBOOT_GIT_PROTOCOL};branch=${BRANCH}" | 21 | SRC_URI = "${UBOOT_GIT_URI};protocol=${UBOOT_GIT_PROTOCOL};branch=${BRANCH}" |
22 | 22 | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb index 0b36575b..688b8690 100644 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb | |||
@@ -9,6 +9,7 @@ require recipes-kernel/linux/setup-defconfig.inc | |||
9 | require recipes-kernel/linux/kernel-rdepends.inc | 9 | require recipes-kernel/linux/kernel-rdepends.inc |
10 | require recipes-kernel/linux/ti-kernel.inc | 10 | require recipes-kernel/linux/ti-kernel.inc |
11 | include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} | 11 | include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} |
12 | include ${@ 'recipes-kernel/linux/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''} | ||
12 | 13 | ||
13 | DEPENDS += "gmp-native libmpc-native" | 14 | DEPENDS += "gmp-native libmpc-native" |
14 | 15 | ||
@@ -20,16 +21,16 @@ KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \ | |||
20 | 21 | ||
21 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |
22 | 23 | ||
23 | BRANCH = "ti-linux-6.1.y" | 24 | BRANCH ?= "ti-linux-6.1.y" |
24 | 25 | ||
25 | SRCREV = "7124dee9779a40c52c52331c3ba6ccc84f357380" | 26 | SRCREV ?= "7124dee9779a40c52c52331c3ba6ccc84f357380" |
26 | PV = "6.1.26+git${SRCPV}" | 27 | PV = "6.1.26+git${SRCPV}" |
27 | 28 | ||
28 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild | 29 | # Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild |
29 | MACHINE_KERNEL_PR:append = "b" | 30 | MACHINE_KERNEL_PR:append = "b" |
30 | PR = "${MACHINE_KERNEL_PR}" | 31 | PR = "${MACHINE_KERNEL_PR}" |
31 | 32 | ||
32 | KERNEL_GIT_URI = "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git" | 33 | KERNEL_GIT_URI ?= "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git" |
33 | KERNEL_GIT_PROTOCOL = "https" | 34 | KERNEL_GIT_PROTOCOL = "https" |
34 | SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \ | 35 | SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \ |
35 | file://defconfig" | 36 | file://defconfig" |
diff --git a/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc b/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc new file mode 100644 index 00000000..0848dd9f --- /dev/null +++ b/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc | |||
@@ -0,0 +1,13 @@ | |||
1 | |||
2 | # Use different commit, repo and branch for TI extras build | ||
3 | # This will have priority over generic rt path | ||
4 | |||
5 | COMPATIBLE_MACHINE = "am62xx" | ||
6 | |||
7 | BRANCH = "ti-linux-6.1.y" | ||
8 | BRANCH:tie-jailhouse = "ti-linux-6.1.y-jailhouse" | ||
9 | |||
10 | SRCREV = "30bcc25e7cb1b25667db88d61828728f0f0b5f4b" | ||
11 | SRCREV:tie-jailhouse = "0ed0dec2462b805b0188fe080895adc437871549" | ||
12 | |||
13 | KERNEL_GIT_URI = "git://git.ti.com/git/processor-sdk/linux.git" | ||
diff --git a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb index 05cc21b3..1c63b400 100644 --- a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb +++ b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb | |||
@@ -10,6 +10,8 @@ LIC_FILES_CHKSUM = " \ | |||
10 | file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \ | 10 | file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \ |
11 | " | 11 | " |
12 | 12 | ||
13 | COMPATIBLE_MACHINE = "am62xx" | ||
14 | |||
13 | TARGET_CC_ARCH += "${LDFLAGS}" | 15 | TARGET_CC_ARCH += "${LDFLAGS}" |
14 | 16 | ||
15 | PV = "0.12+git${SRCPV}" | 17 | PV = "0.12+git${SRCPV}" |