summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-01-20 01:40:46 +0000
committerRyan Eatmon <reatmon@ti.com>2023-01-24 12:51:24 -0600
commitf5653ce0ae0675449315a3350859f8fc2c93f530 (patch)
tree62ab1d6cd6070d51da60257866b14ae32399e406
parent7cd8114bb0f646225fd4cafc3c699a73caa6dc0e (diff)
downloadmeta-ti-f5653ce0ae0675449315a3350859f8fc2c93f530.tar.gz
conf: machine: Use new J7 SoC names over specific board names
Now that we have SoC names, we can avoid adding features based on the board name. We expect folks to create their own boards based on these SoCs, and so using the TI made EVM board name everywhere adds extra churn when adding a new board. Plus it is more correct for most of these features as they depend on the SoC, not on the EVM board. One other thing we do here is to not use the generic "j7" name, the current and future J7 devices are far to feature diverse to group at this level. Grouping like that will lead to the wrong things getting enabled as new J7 SoCs are added. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb3
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc5
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb2
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb39
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb6
-rw-r--r--meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb10
8 files changed, 34 insertions, 35 deletions
diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index 0e8ed897..e7aa9ef4 100644
--- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -27,8 +27,7 @@ ALTERNATIVE_TARGET[wave521c_codec_fw.bin] = "${nonarch_base_libdir}/firmware/cnm
27ALTERNATIVE_PRIORITY = "10" 27ALTERNATIVE_PRIORITY = "10"
28 28
29# Set up names for the firmwares 29# Set up names for the firmwares
30ALTERNATIVE_${PN}:j7 = "\ 30ALTERNATIVE_${PN} = "wave521c_codec_fw.bin"
31 wave521c_codec_fw.bin"
32 31
33do_install() { 32do_install() {
34 install -d ${D}${nonarch_base_libdir}/firmware/cnm 33 install -d ${D}${nonarch_base_libdir}/firmware/cnm
diff --git a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
index 7727e9af..bd103198 100644
--- a/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-img-encode-decode/vxd-dec-fw_git.bb
@@ -9,7 +9,7 @@ PR = "${INC_PR}.0"
9 9
10CLEANBROKEN = "1" 10CLEANBROKEN = "1"
11 11
12COMPATIBLE_MACHINE = "j7" 12COMPATIBLE_MACHINE = "j721e"
13 13
14PACKAGE_ARCH = "${MACHINE_ARCH}" 14PACKAGE_ARCH = "${MACHINE_ARCH}"
15 15
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
index d87dcbe1..5f2ca279 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
@@ -32,7 +32,10 @@ PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/b
32PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE},,ti-rtos-firmware" 32PACKAGECONFIG[dm] = "DM=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/pdk-ipc/${DM_FIRMWARE},,ti-rtos-firmware"
33 33
34PACKAGECONFIG:append:aarch64 = " atf optee" 34PACKAGECONFIG:append:aarch64 = " atf optee"
35PACKAGECONFIG:append:j7 = " dm" 35PACKAGECONFIG:append:j721e = " dm"
36PACKAGECONFIG:append:j7200 = " dm"
37PACKAGECONFIG:append:j721s2 = " dm"
38PACKAGECONFIG:append:j784s4 = " dm"
36PACKAGECONFIG:append:am62xx = " dm" 39PACKAGECONFIG:append:am62xx = " dm"
37 40
38COMPATIBLE_MACHINE = "(ti-soc)" 41COMPATIBLE_MACHINE = "(ti-soc)"
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index 61dcbcd8..808a4766 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -25,7 +25,7 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cadence-mhdp-fw"
25RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw" 25RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cadence-mhdp-fw"
26 26
27# Add run-time dependency for Video Decoding firmware to the rootfs 27# Add run-time dependency for Video Decoding firmware to the rootfs
28RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j7 = " vxd-dec-fw" 28RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " vxd-dec-fw"
29 29
30# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs 30# Add run-time dependency for Chips&Media Wave521 firmware to the rootfs
31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" 31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw"
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
index 462d26f1..4c23a28c 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb
@@ -43,4 +43,4 @@ module_conf_rpmsg_client_sample = "blacklist rpmsg_client_sample"
43module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus" 43module_conf_ti_k3_r5_remoteproc = "softdep ti_k3_r5_remoteproc pre: virtio_rpmsg_bus"
44module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus" 44module_conf_ti_k3_dsp_remoteproc = "softdep ti_k3_dsp_remoteproc pre: virtio_rpmsg_bus"
45KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc" 45KERNEL_MODULE_PROBECONF += "rpmsg_client_sample ti_k3_r5_remoteproc ti_k3_dsp_remoteproc"
46KERNEL_MODULE_AUTOLOAD:append:j7 = " rpmsg_kdrv_switch" 46KERNEL_MODULE_AUTOLOAD:append:j721e = " rpmsg_kdrv_switch"
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 0447bafe..9a6da088 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -13,13 +13,10 @@ inherit deploy
13inherit update-alternatives 13inherit update-alternatives
14 14
15PLAT_SFX = "" 15PLAT_SFX = ""
16PLAT_SFX:j7 = "j721e" 16PLAT_SFX:j721e = "j721e"
17PLAT_SFX:j721e-hs-evm = "j721e" 17PLAT_SFX:j7200 = "j7200"
18PLAT_SFX:j7200-evm = "j7200" 18PLAT_SFX:j721s2 = "j721s2"
19PLAT_SFX:j7200-hs-evm = "j7200" 19PLAT_SFX:j784s4 = "j784s4"
20PLAT_SFX:j721s2-evm = "j721s2"
21PLAT_SFX:j721s2-hs-evm = "j721s2"
22PLAT_SFX:j784s4-evm = "j784s4"
23PLAT_SFX:am65xx = "am65xx" 20PLAT_SFX:am65xx = "am65xx"
24PLAT_SFX:am64xx = "am64xx" 21PLAT_SFX:am64xx = "am64xx"
25PLAT_SFX:am62xx = "am62xx" 22PLAT_SFX:am62xx = "am62xx"
@@ -50,7 +47,7 @@ LEGACY_DM_FW_DIR = "${D}${nonarch_base_libdir}/firmware/pdk-ipc/"
50 47
51DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f" 48DM_FIRMWARE = "ipc_echo_testb_mcu1_0_release_strip.xer5f"
52 49
53# J7 HS support 50# J721e HS support
54do_install:prepend:j721e-hs-evm() { 51do_install:prepend:j721e-hs-evm() {
55 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 52 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
56 ( cd ${RTOS_DM_FW_DIR}; \ 53 ( cd ${RTOS_DM_FW_DIR}; \
@@ -81,7 +78,7 @@ do_install:prepend:j721e-hs-evm() {
81 ) 78 )
82} 79}
83 80
84# J7 HS support 81# J7200 HS support
85do_install:prepend:j7200-hs-evm() { 82do_install:prepend:j7200-hs-evm() {
86 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 83 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
87 ( cd ${RTOS_DM_FW_DIR}; \ 84 ( cd ${RTOS_DM_FW_DIR}; \
@@ -102,7 +99,7 @@ do_install:prepend:j7200-hs-evm() {
102 ) 99 )
103} 100}
104 101
105# J7 HS support 102# J721s2 HS support
106do_install:prepend:j721s2-hs-evm() { 103do_install:prepend:j721s2-hs-evm() {
107 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} 104 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
108 ( cd ${RTOS_DM_FW_DIR}; \ 105 ( cd ${RTOS_DM_FW_DIR}; \
@@ -149,7 +146,7 @@ do_install() {
149 : 146 :
150} 147}
151 148
152do_install:j7() { 149do_install:j721e() {
153 install -d ${LEGACY_IPC_FW_DIR} 150 install -d ${LEGACY_IPC_FW_DIR}
154 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR} 151 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
155 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} 152 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
@@ -335,7 +332,7 @@ ALTERNATIVE:${PN}:j721e-hs-evm = "\
335 j7-c71_0-fw-sec \ 332 j7-c71_0-fw-sec \
336 " 333 "
337 334
338ALTERNATIVE:${PN}:j7 = "\ 335ALTERNATIVE:${PN}:j721e-evm = "\
339 j7-mcu-r5f0_0-fw \ 336 j7-mcu-r5f0_0-fw \
340 j7-mcu-r5f0_1-fw \ 337 j7-mcu-r5f0_1-fw \
341 j7-main-r5f0_0-fw \ 338 j7-main-r5f0_0-fw \
@@ -420,15 +417,15 @@ TARGET_MCU_M4FSS0_0:am64xx = "am64-mcu-m4f0_0-fw"
420TARGET_MAIN_R5FSS0_0:am62xx = "am62-main-r5f0_0-fw" 417TARGET_MAIN_R5FSS0_0:am62xx = "am62-main-r5f0_0-fw"
421TARGET_MCU_M4FSS0_0:am62xx = "am62-mcu-m4f0_0-fw" 418TARGET_MCU_M4FSS0_0:am62xx = "am62-mcu-m4f0_0-fw"
422 419
423TARGET_MCU_R5FSS0_0:j7 = "j7-mcu-r5f0_0-fw" 420TARGET_MCU_R5FSS0_0:j721e = "j7-mcu-r5f0_0-fw"
424TARGET_MCU_R5FSS0_1:j7 = "j7-mcu-r5f0_1-fw" 421TARGET_MCU_R5FSS0_1:j721e = "j7-mcu-r5f0_1-fw"
425TARGET_MAIN_R5FSS0_0:j7 = "j7-main-r5f0_0-fw" 422TARGET_MAIN_R5FSS0_0:j721e = "j7-main-r5f0_0-fw"
426TARGET_MAIN_R5FSS0_1:j7 = "j7-main-r5f0_1-fw" 423TARGET_MAIN_R5FSS0_1:j721e = "j7-main-r5f0_1-fw"
427TARGET_MAIN_R5FSS1_0:j7 = "j7-main-r5f1_0-fw" 424TARGET_MAIN_R5FSS1_0:j721e = "j7-main-r5f1_0-fw"
428TARGET_MAIN_R5FSS1_1:j7 = "j7-main-r5f1_1-fw" 425TARGET_MAIN_R5FSS1_1:j721e = "j7-main-r5f1_1-fw"
429TARGET_C66_0:j7 = "j7-c66_0-fw" 426TARGET_C66_0:j721e = "j7-c66_0-fw"
430TARGET_C66_1:j7 = "j7-c66_1-fw" 427TARGET_C66_1:j721e = "j7-c66_1-fw"
431TARGET_C7X_0:j7 = "j7-c71_0-fw" 428TARGET_C7X_0:j721e = "j7-c71_0-fw"
432 429
433TARGET_MAIN_R5FSS0_0_SIGNED:j721e-hs-evm = "j7-main-r5f0_0-fw-sec" 430TARGET_MAIN_R5FSS0_0_SIGNED:j721e-hs-evm = "j7-main-r5f0_0-fw-sec"
434TARGET_MAIN_R5FSS0_1_SIGNED:j721e-hs-evm = "j7-main-r5f0_1-fw-sec" 431TARGET_MAIN_R5FSS0_1_SIGNED:j721e-hs-evm = "j7-main-r5f0_1-fw-sec"
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb
index be1ff013..ff715ce0 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-metadata.bb
@@ -1,7 +1,7 @@
1LICENSE = "BSD-3-Clause" 1LICENSE = "BSD-3-Clause"
2LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9" 2LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
3 3
4COMPATIBLE_MACHINE = "ti-soc" 4COMPATIBLE_MACHINE = "j721e|j7200|am65xx|am64xx"
5 5
6PACKAGE_ARCH = "${MACHINE_ARCH}" 6PACKAGE_ARCH = "${MACHINE_ARCH}"
7 7
@@ -10,8 +10,8 @@ INHIBIT_DEFAULT_DEPS = "1"
10inherit nopackages deploy 10inherit nopackages deploy
11 11
12PLAT_SFX = "" 12PLAT_SFX = ""
13PLAT_SFX:j7 = "/j721e" 13PLAT_SFX:j721e = "/j721e"
14PLAT_SFX:j7200-evm = "/j7200" 14PLAT_SFX:j7200 = "/j7200"
15PLAT_SFX:am65xx = "/am65xx" 15PLAT_SFX:am65xx = "/am65xx"
16PLAT_SFX:am64xx = "/am64x" 16PLAT_SFX:am64xx = "/am64x"
17 17
diff --git a/meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb b/meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb
index cb2f8cc2..e3b5290a 100644
--- a/meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb
+++ b/meta-ti-extras/recipes-bsp/pru/pru-icss_git.bb
@@ -15,7 +15,7 @@ PR = "r0"
15 15
16require recipes-ti/includes/ti-paths.inc 16require recipes-ti/includes/ti-paths.inc
17 17
18COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|k3" 18COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|am62xx|am64xx|am65xx|j721e"
19PACKAGE_ARCH = "${MACHINE_ARCH}" 19PACKAGE_ARCH = "${MACHINE_ARCH}"
20 20
21PACKAGES:prepend = " \ 21PACKAGES:prepend = " \
@@ -43,7 +43,7 @@ PLATFORM:omap-a15 = "am572x"
43PLATFORM:am62xx = "am62x" 43PLATFORM:am62xx = "am62x"
44PLATFORM:am64xx = "am64x" 44PLATFORM:am64xx = "am64x"
45PLATFORM:am65xx = "am65x" 45PLATFORM:am65xx = "am65x"
46PLATFORM:j7 = "j721e" 46PLATFORM:j721e = "j721e"
47 47
48do_compile() { 48do_compile() {
49 for dir in ${SUBDIRS} 49 for dir in ${SUBDIRS}
@@ -155,7 +155,7 @@ do_install:append:am65xx() {
155 done 155 done
156} 156}
157 157
158do_install:append:j7() { 158do_install:append:j721e() {
159 for i in 0 1 159 for i in 0 1
160 do 160 do
161 install -m 644 ${S}/examples/${PLATFORM}/PRU_Halt/gen/PRU${i}/PRU_Halt_${i}.out \ 161 install -m 644 ${S}/examples/${PLATFORM}/PRU_Halt/gen/PRU${i}/PRU_Halt_${i}.out \
@@ -189,7 +189,7 @@ PRU_ICSS_ALTERNATIVES:omap-a15 = "am57xx-pru1_0-fw am57xx-pru1_1-fw am57xx-pru2_
189PRU_ICSS_ALTERNATIVES:am62xx = "am62x-pru0-fw am62x-pru1-fw" 189PRU_ICSS_ALTERNATIVES:am62xx = "am62x-pru0-fw am62x-pru1-fw"
190PRU_ICSS_ALTERNATIVES:am64xx = "am64x-pru0_0-fw am64x-pru0_1-fw am64x-pru1_0-fw am64x-pru1_1-fw am64x-rtu0_0-fw am64x-rtu0_1-fw am64x-rtu1_0-fw am64x-rtu1_1-fw" 190PRU_ICSS_ALTERNATIVES:am64xx = "am64x-pru0_0-fw am64x-pru0_1-fw am64x-pru1_0-fw am64x-pru1_1-fw am64x-rtu0_0-fw am64x-rtu0_1-fw am64x-rtu1_0-fw am64x-rtu1_1-fw"
191PRU_ICSS_ALTERNATIVES:am65xx = "am65x-pru0_0-fw am65x-pru0_1-fw am65x-pru1_0-fw am65x-pru1_1-fw am65x-pru2_0-fw am65x-pru2_1-fw am65x-rtu0_0-fw am65x-rtu0_1-fw am65x-rtu1_0-fw am65x-rtu1_1-fw am65x-rtu2_0-fw am65x-rtu2_1-fw" 191PRU_ICSS_ALTERNATIVES:am65xx = "am65x-pru0_0-fw am65x-pru0_1-fw am65x-pru1_0-fw am65x-pru1_1-fw am65x-pru2_0-fw am65x-pru2_1-fw am65x-rtu0_0-fw am65x-rtu0_1-fw am65x-rtu1_0-fw am65x-rtu1_1-fw am65x-rtu2_0-fw am65x-rtu2_1-fw"
192PRU_ICSS_ALTERNATIVES:j7 = "j7-pru0_0-fw j7-pru0_1-fw j7-pru1_0-fw j7-pru1_1-fw j7-rtu0_0-fw j7-rtu0_1-fw j7-rtu1_0-fw j7-rtu1_1-fw" 192PRU_ICSS_ALTERNATIVES:j721e = "j7-pru0_0-fw j7-pru0_1-fw j7-pru1_0-fw j7-pru1_1-fw j7-rtu0_0-fw j7-rtu0_1-fw j7-rtu1_0-fw j7-rtu1_1-fw"
193 193
194# Set up link names for the firmwares 194# Set up link names for the firmwares
195ALTERNATIVE_LINK_NAME[am335x-pru0-fw] = "${nonarch_base_libdir}/firmware/am335x-pru0-fw" 195ALTERNATIVE_LINK_NAME[am335x-pru0-fw] = "${nonarch_base_libdir}/firmware/am335x-pru0-fw"
@@ -259,7 +259,7 @@ ALTERNATIVE:pru-icss-halt = "${PRU_ICSS_ALTERNATIVES}"
259# Only Halt firmware images are supported for the Tx_PRU cores 259# Only Halt firmware images are supported for the Tx_PRU cores
260ALTERNATIVE:pru-icss-halt:append:am64xx = " am64x-txpru0_0-fw am64x-txpru0_1-fw am64x-txpru1_0-fw am64x-txpru1_1-fw" 260ALTERNATIVE:pru-icss-halt:append:am64xx = " am64x-txpru0_0-fw am64x-txpru0_1-fw am64x-txpru1_0-fw am64x-txpru1_1-fw"
261ALTERNATIVE:pru-icss-halt:append:am65xx = " am65x-txpru0_0-fw am65x-txpru0_1-fw am65x-txpru1_0-fw am65x-txpru1_1-fw am65x-txpru2_0-fw am65x-txpru2_1-fw" 261ALTERNATIVE:pru-icss-halt:append:am65xx = " am65x-txpru0_0-fw am65x-txpru0_1-fw am65x-txpru1_0-fw am65x-txpru1_1-fw am65x-txpru2_0-fw am65x-txpru2_1-fw"
262ALTERNATIVE:pru-icss-halt:append:j7 = " j7-txpru0_0-fw j7-txpru0_1-fw j7-txpru1_0-fw j7-txpru1_1-fw" 262ALTERNATIVE:pru-icss-halt:append:j721e = " j7-txpru0_0-fw j7-txpru0_1-fw j7-txpru1_0-fw j7-txpru1_1-fw"
263 263
264ALTERNATIVE_TARGET_pru-icss-halt[am335x-pru0-fw] = "${nonarch_base_libdir}/firmware/pru/PRU_Halt.out" 264ALTERNATIVE_TARGET_pru-icss-halt[am335x-pru0-fw] = "${nonarch_base_libdir}/firmware/pru/PRU_Halt.out"
265ALTERNATIVE_TARGET_pru-icss-halt[am335x-pru1-fw] = "${nonarch_base_libdir}/firmware/pru/PRU_Halt.out" 265ALTERNATIVE_TARGET_pru-icss-halt[am335x-pru1-fw] = "${nonarch_base_libdir}/firmware/pru/PRU_Halt.out"