summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChirag Shilwant <c-shilwant@ti.com>2023-03-20 04:12:09 +0000
committerRyan Eatmon <reatmon@ti.com>2023-03-20 16:45:07 -0500
commit98721c52da7282859becd02da0c122477598c28c (patch)
tree217d92be9edccdb2777223a1e5ddd5fcb53f3629
parent053002fbe21d850dbb5e2c8372d692aa4e8a5afd (diff)
downloadmeta-ti-98721c52da7282859becd02da0c122477598c28c.tar.gz
am62xx-lp-evm: Add AM62x LP HS-FS evm configuration
Lets add the basic AM62x LP HS-FS configuration - Add machine conf for AM62x LP HS-FS. - The wic images will boot on AM62x LP HS-FS devices by default. - The sysfw image for HS-SE will be packaged in the wic image as tiboot3-am62x-hs-evm.bin. - Add ti-sci-firmware overrides. Signed-off-by: Chirag Shilwant <c-shilwant@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf14
-rw-r--r--meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf7
-rw-r--r--meta-ti-bsp/conf/machine/include/am62xx-lp.inc7
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb1
4 files changed, 28 insertions, 1 deletions
diff --git a/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf b/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf
new file mode 100644
index 00000000..9026b67c
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf
@@ -0,0 +1,14 @@
1#@TYPE: Machine
2#@NAME: AM62xx LPSK HS-FS EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62xx LP HS-FS EVM (R5F core)
4
5# Booting HS-FS requires different SYSFW, the rest is handled at runtime
6
7require conf/machine/include/k3r5.inc
8SOC_FAMILY:append = ":k3r5-hs-fs"
9
10SYSFW_SOC = "am62x"
11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs-fs"
13
14UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
diff --git a/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf b/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
index 11e70342..c126de0f 100644
--- a/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
+++ b/meta-ti-bsp/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
@@ -11,4 +11,11 @@ SYSFW_SOC = "am62x"
11SYSFW_CONFIG = "evm" 11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs" 12SYSFW_SUFFIX = "hs"
13 13
14SYSFW_TIBOOT3_SYMLINK = ""
15
14UBOOT_MACHINE = "am62x_lpsk_r5_defconfig" 16UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
17
18SPL_BINARY = ""
19UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
20UBOOT_IMAGE = "u-boot-r5spl-hs-se-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
21UBOOT_SYMLINK = "u-boot-r5spl-hs-se.${UBOOT_SUFFIX}"
diff --git a/meta-ti-bsp/conf/machine/include/am62xx-lp.inc b/meta-ti-bsp/conf/machine/include/am62xx-lp.inc
index df113003..d37d4673 100644
--- a/meta-ti-bsp/conf/machine/include/am62xx-lp.inc
+++ b/meta-ti-bsp/conf/machine/include/am62xx-lp.inc
@@ -8,8 +8,13 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
8 8
9TFA_K3_SYSTEM_SUSPEND = "1" 9TFA_K3_SYSTEM_SUSPEND = "1"
10 10
11# Default tiboot3.bin on AM62x LP is for HS-SE 11# Default tiboot3.bin on AM62x LP is for HS-FS
12BBMULTICONFIG = "k3r5-hs-fs"
13do_image_wic[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy"
14
15# Since default tiboot3.bin on AM62x LP is for HS-FS, add a version for HS-SE
12BBMULTICONFIG += "k3r5-hs-se" 16BBMULTICONFIG += "k3r5-hs-se"
17IMAGE_BOOT_FILES += "tiboot3-am62x-hs-evm.bin"
13do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" 18do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
14 19
15TFA_BOARD = "lite" 20TFA_BOARD = "lite"
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 8004c227..75b9f8a6 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -42,6 +42,7 @@ SYSFW_PREFIX:am62xx-evm-k3r5-hs-se = "fs"
42SYSFW_PREFIX:am62xx-evm-k3r5-hs-fs = "fs" 42SYSFW_PREFIX:am62xx-evm-k3r5-hs-fs = "fs"
43SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs" 43SYSFW_PREFIX:am62xx-lp-evm-k3r5 = "fs"
44SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" 44SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs"
45SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs"
45SYSFW_PREFIX:am62axx-evm-k3r5 = "fs" 46SYSFW_PREFIX:am62axx-evm-k3r5 = "fs"
46 47
47SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" 48SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"