diff options
author | Denys Dmytriyenko <denys@ti.com> | 2019-05-09 10:14:54 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2019-05-09 12:49:55 +0000 |
commit | b98c7daf0b3e000e7b99594e303a752573ffa108 (patch) | |
tree | 2111a7b38ad8602be252a615e40bcfe8068411bf | |
parent | 344792b5182c27cac7fbb07843acf1120c541b8b (diff) | |
download | meta-ti-b98c7daf0b3e000e7b99594e303a752573ffa108.tar.gz |
recipes: convert existing uses of am65xx-evm to am65xx SOC family
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/pru/pru-icss_git.bb | 6 | ||||
-rw-r--r-- | recipes-bsp/sciclient/sciclient-rtos_git.bb | 6 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-common.inc | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-examples_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 6 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos_git.bb | 8 |
6 files changed, 15 insertions, 15 deletions
diff --git a/recipes-bsp/pru/pru-icss_git.bb b/recipes-bsp/pru/pru-icss_git.bb index 94522f65..a36bce05 100644 --- a/recipes-bsp/pru/pru-icss_git.bb +++ b/recipes-bsp/pru/pru-icss_git.bb | |||
@@ -40,7 +40,7 @@ PLATFORM_ti33x = "am335x" | |||
40 | PLATFORM_ti43x = "am437x" | 40 | PLATFORM_ti43x = "am437x" |
41 | PLATFORM_omap-a15 = "am572x" | 41 | PLATFORM_omap-a15 = "am572x" |
42 | PLATFORM_k2g = "k2g" | 42 | PLATFORM_k2g = "k2g" |
43 | PLATFORM_am65xx-evm = "am65x" | 43 | PLATFORM_am65xx = "am65x" |
44 | 44 | ||
45 | do_compile() { | 45 | do_compile() { |
46 | for dir in ${SUBDIRS} | 46 | for dir in ${SUBDIRS} |
@@ -102,7 +102,7 @@ do_install_append_k2g() { | |||
102 | done | 102 | done |
103 | } | 103 | } |
104 | 104 | ||
105 | do_install_append_am65xx-evm() { | 105 | do_install_append_am65xx() { |
106 | for i in 0 1 | 106 | for i in 0 1 |
107 | do | 107 | do |
108 | install -m 644 ${S}/examples/${PLATFORM}/PRU_Halt/gen/PRU${i}/PRU_Halt_${i}.out \ | 108 | install -m 644 ${S}/examples/${PLATFORM}/PRU_Halt/gen/PRU${i}/PRU_Halt_${i}.out \ |
@@ -131,7 +131,7 @@ PRU_ICSS_ALTERNATIVES_ti33x = "am335x-pru0-fw am335x-pru1-fw" | |||
131 | PRU_ICSS_ALTERNATIVES_ti43x = "am437x-pru0_0-fw am437x-pru0_1-fw am437x-pru1_0-fw am437x-pru1_1-fw" | 131 | PRU_ICSS_ALTERNATIVES_ti43x = "am437x-pru0_0-fw am437x-pru0_1-fw am437x-pru1_0-fw am437x-pru1_1-fw" |
132 | PRU_ICSS_ALTERNATIVES_omap-a15 = "am57xx-pru1_0-fw am57xx-pru1_1-fw am57xx-pru2_0-fw am57xx-pru2_1-fw" | 132 | PRU_ICSS_ALTERNATIVES_omap-a15 = "am57xx-pru1_0-fw am57xx-pru1_1-fw am57xx-pru2_0-fw am57xx-pru2_1-fw" |
133 | PRU_ICSS_ALTERNATIVES_k2g = "k2g-pru0_0-fw k2g-pru0_1-fw k2g-pru1_0-fw k2g-pru1_1-fw" | 133 | PRU_ICSS_ALTERNATIVES_k2g = "k2g-pru0_0-fw k2g-pru0_1-fw k2g-pru1_0-fw k2g-pru1_1-fw" |
134 | PRU_ICSS_ALTERNATIVES_am65xx-evm = "am65x-pru0_0-fw am65x-pru0_1-fw am65x-pru1_0-fw am65x-pru1_1-fw am65x-pru2_0-fw am65x-pru2_1-fw am65x-rtu0_0-fw am65x-rtu0_1-fw am65x-rtu1_0-fw am65x-rtu1_1-fw am65x-rtu2_0-fw am65x-rtu2_1-fw" | 134 | PRU_ICSS_ALTERNATIVES_am65xx = "am65x-pru0_0-fw am65x-pru0_1-fw am65x-pru1_0-fw am65x-pru1_1-fw am65x-pru2_0-fw am65x-pru2_1-fw am65x-rtu0_0-fw am65x-rtu0_1-fw am65x-rtu1_0-fw am65x-rtu1_1-fw am65x-rtu2_0-fw am65x-rtu2_1-fw" |
135 | 135 | ||
136 | # Set up link names for the firmwares | 136 | # Set up link names for the firmwares |
137 | ALTERNATIVE_LINK_NAME[am335x-pru0-fw] = "/lib/firmware/am335x-pru0-fw" | 137 | ALTERNATIVE_LINK_NAME[am335x-pru0-fw] = "/lib/firmware/am335x-pru0-fw" |
diff --git a/recipes-bsp/sciclient/sciclient-rtos_git.bb b/recipes-bsp/sciclient/sciclient-rtos_git.bb index 2de94d02..e1455993 100644 --- a/recipes-bsp/sciclient/sciclient-rtos_git.bb +++ b/recipes-bsp/sciclient/sciclient-rtos_git.bb | |||
@@ -36,9 +36,9 @@ export PDK_SCICLIENT_ROOT_PATH = "${SCICLIENT_PACKAGE_BASE}/package/all/pdk_/pac | |||
36 | #export PDK_SCICLIENT_ROOT_PATH ="${WORKDIR}/build" | 36 | #export PDK_SCICLIENT_ROOT_PATH ="${WORKDIR}/build" |
37 | #export DEST_ROOT="${S}" | 37 | #export DEST_ROOT="${S}" |
38 | 38 | ||
39 | LIMSOCS_am65xx-evm = "am65xx" | 39 | LIMSOCS_am65xx = "am65xx" |
40 | LIMBOARDS_am65xx-evm = "am65xx_evm" | 40 | LIMBOARDS_am65xx = "am65xx_evm" |
41 | BOARD_PACKAGE_am65xx-evm = "am65xx_evm" | 41 | BOARD_PACKAGE_am65xx = "am65xx_evm" |
42 | 42 | ||
43 | # HTML doc link params | 43 | # HTML doc link params |
44 | PDK_COMP_LINK_TEXT = "SCICLIENT" | 44 | PDK_COMP_LINK_TEXT = "SCICLIENT" |
diff --git a/recipes-ti/ipc/ti-ipc-common.inc b/recipes-ti/ipc/ti-ipc-common.inc index 8401ea62..036e46d8 100644 --- a/recipes-ti/ipc/ti-ipc-common.inc +++ b/recipes-ti/ipc/ti-ipc-common.inc | |||
@@ -15,7 +15,7 @@ PLATFORM_k2g = "66AK2G" | |||
15 | PLATFORM_omapl138 = "OMAPL138" | 15 | PLATFORM_omapl138 = "OMAPL138" |
16 | PLATFORM_c667x-evm = "C6678" | 16 | PLATFORM_c667x-evm = "C6678" |
17 | PLATFORM_c665x-evm = "C6678" | 17 | PLATFORM_c665x-evm = "C6678" |
18 | PLATFORM_am65xx-evm = "AM65XX" | 18 | PLATFORM_am65xx = "AM65XX" |
19 | 19 | ||
20 | ALT_PLATFORM_k2hk = "TCI6636" | 20 | ALT_PLATFORM_k2hk = "TCI6636" |
21 | ALT_PLATFORM_am57xx-evm = "AM572X AM571X" | 21 | ALT_PLATFORM_am57xx-evm = "AM572X AM571X" |
diff --git a/recipes-ti/ipc/ti-ipc-examples_git.bb b/recipes-ti/ipc/ti-ipc-examples_git.bb index d8733aeb..43e45e64 100644 --- a/recipes-ti/ipc/ti-ipc-examples_git.bb +++ b/recipes-ti/ipc/ti-ipc-examples_git.bb | |||
@@ -3,7 +3,7 @@ require ti-ipc-examples.inc | |||
3 | 3 | ||
4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" | 4 | DEPENDS = "ti-ipc ti-xdctools-native ti-sysbios ti-ipc-rtos zip-native" |
5 | 5 | ||
6 | DEPENDS_append_am65xx-evm = " sciclient-rtos" | 6 | DEPENDS_append_am65xx = " sciclient-rtos" |
7 | 7 | ||
8 | do_compile_append() { | 8 | do_compile_append() { |
9 | 9 | ||
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index 9b7bccf3..dcd6309f 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -53,7 +53,7 @@ DEPENDS_append_omapl138 = " ti-cgt6x-native \ | |||
53 | DEPENDS_append_c66x = " ti-cgt6x-native \ | 53 | DEPENDS_append_c66x = " ti-cgt6x-native \ |
54 | " | 54 | " |
55 | 55 | ||
56 | DEPENDS_append_am65xx-evm = " ti-cgt-arm-native \ | 56 | DEPENDS_append_am65xx = " ti-cgt-arm-native \ |
57 | gcc-linaro-baremetal-aarch64-native" | 57 | gcc-linaro-baremetal-aarch64-native" |
58 | 58 | ||
59 | IPC_TARGETS = "" | 59 | IPC_TARGETS = "" |
@@ -79,7 +79,7 @@ IPC_TARGETS_c66x = " \ | |||
79 | ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ | 79 | ti.targets.elf.C66_big_endian="${STAGING_DIR_NATIVE}/usr/share/ti/cgt-c6x" \ |
80 | " | 80 | " |
81 | 81 | ||
82 | IPC_TARGETS_am65xx-evm = "\ | 82 | IPC_TARGETS_am65xx = "\ |
83 | gnu.targets.arm.A53F="${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN}" \ | 83 | gnu.targets.arm.A53F="${GCC_LINARO_BAREMETAL_AARCH64_TOOLCHAIN}" \ |
84 | ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \ | 84 | ti.targets.arm.elf.R5F="${M4_TOOLCHAIN_INSTALL_DIR}" \ |
85 | " | 85 | " |
@@ -92,5 +92,5 @@ EXTRA_OEMAKE = "\ | |||
92 | JOBS="--jobs=${BB_NUMBER_THREADS}" \ | 92 | JOBS="--jobs=${BB_NUMBER_THREADS}" \ |
93 | JAVA_TOOL_OPTIONS=-Xss2560k \ | 93 | JAVA_TOOL_OPTIONS=-Xss2560k \ |
94 | " | 94 | " |
95 | EXTRA_OEMAKE_append_am65xx-evm = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}" | 95 | EXTRA_OEMAKE_append_am65xx = " PDK_INSTALL_DIR=${PDK_INSTALL_DIR}" |
96 | 96 | ||
diff --git a/recipes-ti/ipc/ti-ipc-rtos_git.bb b/recipes-ti/ipc/ti-ipc-rtos_git.bb index 7f1cae0f..4c0e71e6 100644 --- a/recipes-ti/ipc/ti-ipc-rtos_git.bb +++ b/recipes-ti/ipc/ti-ipc-rtos_git.bb | |||
@@ -3,7 +3,7 @@ require ti-ipc-common.inc | |||
3 | require ti-ipc-rtos.inc | 3 | require ti-ipc-rtos.inc |
4 | 4 | ||
5 | DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" | 5 | DEPENDS = "ti-xdctools-native ti-sysbios doxygen-native zip-native" |
6 | DEPENDS_append_am65xx-evm = " sciclient-rtos" | 6 | DEPENDS_append_am65xx = " sciclient-rtos" |
7 | 7 | ||
8 | PACKAGES =+ "${PN}-fw" | 8 | PACKAGES =+ "${PN}-fw" |
9 | FILES_${PN}-fw = "${base_libdir}/firmware/*" | 9 | FILES_${PN}-fw = "${base_libdir}/firmware/*" |
@@ -62,7 +62,7 @@ do_compile() { | |||
62 | fi | 62 | fi |
63 | } | 63 | } |
64 | 64 | ||
65 | do_install_prepend_am65xx-evm () { | 65 | do_install_prepend_am65xx () { |
66 | # Trim directory name | 66 | # Trim directory name |
67 | mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F0 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F0 | 67 | mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F0 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F0 |
68 | mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F1 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F1 | 68 | mv ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_false_R5F1 ${S}/packages/ti/ipc/tests/bin/ti_platforms_cortexR_AM65X_R5F1 |
@@ -130,12 +130,12 @@ pkg_postrm_${PN}-fw_omapl138 () { | |||
130 | update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674 | 130 | update-alternatives --remove rproc-dsp-fw ipc/ti_platforms_evmOMAPL138_DSP/messageq_single.xe674 |
131 | } | 131 | } |
132 | 132 | ||
133 | pkg_postinst_${PN}-fw_am65xx-evm () { | 133 | pkg_postinst_${PN}-fw_am65xx () { |
134 | update-alternatives --install /lib/firmware/am65x-mcu-r5f0_0-fw am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} | 134 | update-alternatives --install /lib/firmware/am65x-mcu-r5f0_0-fw am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} |
135 | update-alternatives --install /lib/firmware/am65x-mcu-r5f0_1-fw am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} | 135 | update-alternatives --install /lib/firmware/am65x-mcu-r5f0_1-fw am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f ${ALTERNATIVE_PRIORITY} |
136 | } | 136 | } |
137 | 137 | ||
138 | pkg_postrm_${PN}-fw_am65xx-evm () { | 138 | pkg_postrm_${PN}-fw_am65xx () { |
139 | update-alternatives --remove am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f | 139 | update-alternatives --remove am65x-mcu-r5f0_0-fw ipc/ti_platforms_cortexR_AM65X_R5F0/messageq_single.xer5f |
140 | update-alternatives --remove am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f | 140 | update-alternatives --remove am65x-mcu-r5f0_1-fw ipc/ti_platforms_cortexR_AM65X_R5F1/messageq_single.xer5f |
141 | } | 141 | } |