summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChirag Shilwant <c-shilwant@ti.com>2023-09-11 14:20:48 +0530
committerRyan Eatmon <reatmon@ti.com>2023-10-26 17:40:47 -0500
commit3790f40faafed46297aaea48e39566b04ddbb106 (patch)
tree2e319b8d09bc6cf0897bf86138acd42edc16a7a2
parent242846833a9f1b05b95fb9335ed01668bc0eef7e (diff)
downloadmeta-ti-3790f40faafed46297aaea48e39566b04ddbb106.tar.gz
meta-ti-bsp: Add Support for am62pxx-evm
- Add A53 and R5 machine configurations for am62pxx-evm. - Add firmware overrides. - Add u-boot overrides. - Add cnm-wave support. Signed-off-by: Chirag Shilwant <c-shilwant@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Brandon Brnich <b-brnich@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf11
-rw-r--r--meta-ti-bsp/conf/machine/am62pxx-evm.conf13
-rw-r--r--meta-ti-bsp/conf/machine/include/am62pxx.inc19
-rw-r--r--meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb5
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc2
-rw-r--r--meta-ti-bsp/recipes-security/optee/optee-os-ti.inc1
-rw-r--r--meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb19
9 files changed, 73 insertions, 1 deletions
diff --git a/meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf b/meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf
new file mode 100644
index 00000000..33254bf2
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62pxx-evm-k3r5.conf
@@ -0,0 +1,11 @@
1#@TYPE: Machine
2#@NAME: AM62PX EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62Px EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am62px"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "hs-fs"
10
11UBOOT_MACHINE = "am62px_evm_r5_defconfig"
diff --git a/meta-ti-bsp/conf/machine/am62pxx-evm.conf b/meta-ti-bsp/conf/machine/am62pxx-evm.conf
new file mode 100644
index 00000000..c0c62592
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/am62pxx-evm.conf
@@ -0,0 +1,13 @@
1#@TYPE: Machine
2#@NAME: AM62PX EVM
3#@DESCRIPTION: Machine configuration for the TI AM62PX EVM
4
5require conf/machine/include/am62pxx.inc
6
7KERNEL_DEVICETREE_PREFIX = "ti/k3-am62p5"
8
9KERNEL_DEVICETREE = " \
10 ti/k3-am62p5-sk.dtb \
11"
12
13UBOOT_MACHINE = "am62px_evm_a53_defconfig"
diff --git a/meta-ti-bsp/conf/machine/include/am62pxx.inc b/meta-ti-bsp/conf/machine/include/am62pxx.inc
new file mode 100644
index 00000000..d61ad62b
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/include/am62pxx.inc
@@ -0,0 +1,19 @@
1require conf/machine/include/k3.inc
2SOC_FAMILY:append = ":am62pxx"
3
4MACHINE_FEATURES += "screen gpu"
5
6require conf/machine/include/mesa-pvr.inc
7PREFERRED_PROVIDER_virtual/gpudriver ?= ""
8
9# Default tiboot3.bin on AM62Px is for HS-FS
10IMAGE_BOOT_FILES += "tiboot3-am62px-hs-fs-evm.bin"
11
12TFA_BOARD = "lite"
13TFA_K3_SYSTEM_SUSPEND = "1"
14
15OPTEEMACHINE = "k3-am62px"
16
17MACHINE_ESSENTIAL_EXTRA_RRECOMMENDS += "cnm-wave-fw"
18
19SERIAL_CONSOLES = "115200;ttyS2"
diff --git a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
index a667d335..e35decee 100644
--- a/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/cnm-wave-fw/cnm-wave-fw_git.bb
@@ -13,7 +13,7 @@ PR = "${INC_PR}.1"
13 13
14CLEANBROKEN = "1" 14CLEANBROKEN = "1"
15 15
16COMPATIBLE_MACHINE = "j721s2|j784s4|am62axx" 16COMPATIBLE_MACHINE = "j721s2|j784s4|am62axx|am62pxx"
17 17
18PACKAGE_ARCH = "${MACHINE_ARCH}" 18PACKAGE_ARCH = "${MACHINE_ARCH}"
19 19
diff --git a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
index 49638ee9..8a52a800 100644
--- a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
@@ -31,6 +31,7 @@ PLAT_SFX:am65xx = "am65xx"
31PLAT_SFX:am64xx = "am64xx" 31PLAT_SFX:am64xx = "am64xx"
32PLAT_SFX:am62xx = "am62xx" 32PLAT_SFX:am62xx = "am62xx"
33PLAT_SFX:am62axx = "am62axx" 33PLAT_SFX:am62axx = "am62axx"
34PLAT_SFX:am62pxx = "am62pxx"
34 35
35DM_FW_DIR = "ti-dm/${PLAT_SFX}" 36DM_FW_DIR = "ti-dm/${PLAT_SFX}"
36 37
@@ -47,6 +48,7 @@ DM_FW_LIST:am65xx = ""
47DM_FW_LIST:am64xx = "" 48DM_FW_LIST:am64xx = ""
48DM_FW_LIST:am62xx = "${DM_FIRMWARE}" 49DM_FW_LIST:am62xx = "${DM_FIRMWARE}"
49DM_FW_LIST:am62axx = "${DM_FIRMWARE}" 50DM_FW_LIST:am62axx = "${DM_FIRMWARE}"
51DM_FW_LIST:am62pxx = "${DM_FIRMWARE}"
50 52
51do_install() { 53do_install() {
52 # Sign the firmware 54 # Sign the firmware
@@ -77,6 +79,7 @@ do_deploy() {
77 79
78# Set up names for the firmwares 80# Set up names for the firmwares
79ALTERNATIVE:${PN}:am62xx = "am62-main-r5f0_0-fw" 81ALTERNATIVE:${PN}:am62xx = "am62-main-r5f0_0-fw"
82ALTERNATIVE:${PN}:am62pxx = "am62p-main-r5f0_0-fw"
80ALTERNATIVE:${PN}:am62axx = "am62a-main-r5f0_0-fw" 83ALTERNATIVE:${PN}:am62axx = "am62a-main-r5f0_0-fw"
81ALTERNATIVE:${PN}:j721e = "j7-mcu-r5f0_0-fw" 84ALTERNATIVE:${PN}:j721e = "j7-mcu-r5f0_0-fw"
82ALTERNATIVE:${PN}:j7200 = "j7200-mcu-r5f0_0-fw" 85ALTERNATIVE:${PN}:j7200 = "j7200-mcu-r5f0_0-fw"
@@ -85,6 +88,7 @@ ALTERNATIVE:${PN}:j784s4 = "j784s4-mcu-r5f0_0-fw"
85 88
86# Set up link names for the firmwares 89# Set up link names for the firmwares
87ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw" 90ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw"
91ALTERNATIVE_LINK_NAME[am62p-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62p-main-r5f0_0-fw"
88ALTERNATIVE_LINK_NAME[am62a-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62a-main-r5f0_0-fw" 92ALTERNATIVE_LINK_NAME[am62a-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62a-main-r5f0_0-fw"
89ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_0-fw" 93ALTERNATIVE_LINK_NAME[j7-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7-mcu-r5f0_0-fw"
90ALTERNATIVE_LINK_NAME[j7200-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7200-mcu-r5f0_0-fw" 94ALTERNATIVE_LINK_NAME[j7200-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j7200-mcu-r5f0_0-fw"
@@ -93,6 +97,7 @@ ALTERNATIVE_LINK_NAME[j784s4-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/j
93 97
94# Create the firmware alternatives 98# Create the firmware alternatives
95ALTERNATIVE_TARGET[am62-main-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}" 99ALTERNATIVE_TARGET[am62-main-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}"
100ALTERNATIVE_TARGET[am62p-main-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}"
96ALTERNATIVE_TARGET[am62a-main-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}" 101ALTERNATIVE_TARGET[am62a-main-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}"
97ALTERNATIVE_TARGET[j7-mcu-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}" 102ALTERNATIVE_TARGET[j7-mcu-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}"
98ALTERNATIVE_TARGET[j7200-mcu-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}" 103ALTERNATIVE_TARGET[j7200-mcu-r5f0_0-fw] = "${INSTALL_DM_FW_DIR}/${DM_FIRMWARE}"
diff --git a/meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb b/meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb
index e1d442d3..b343d268 100644
--- a/meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-eth-fw/ti-eth-fw.bb
@@ -30,6 +30,7 @@ PLAT_SFX:j784s4 = "j784s4"
30PLAT_SFX:am65xx = "am65xx" 30PLAT_SFX:am65xx = "am65xx"
31PLAT_SFX:am64xx = "am64xx" 31PLAT_SFX:am64xx = "am64xx"
32PLAT_SFX:am62xx = "am62xx" 32PLAT_SFX:am62xx = "am62xx"
33PLAT_SFX:am62pxx = "am62pxx"
33PLAT_SFX:am62axx = "am62axx" 34PLAT_SFX:am62axx = "am62axx"
34 35
35ETH_FW_DIR = "ti-eth/${PLAT_SFX}" 36ETH_FW_DIR = "ti-eth/${PLAT_SFX}"
@@ -46,6 +47,7 @@ ETH_FW_LIST:j784s4 = "${ETH_FW}"
46ETH_FW_LIST:am65xx = "" 47ETH_FW_LIST:am65xx = ""
47ETH_FW_LIST:am64xx = "" 48ETH_FW_LIST:am64xx = ""
48ETH_FW_LIST:am62xx = "" 49ETH_FW_LIST:am62xx = ""
50ETH_FW_LIST:am62pxx = ""
49ETH_FW_LIST:am62axx = "" 51ETH_FW_LIST:am62axx = ""
50 52
51do_install() { 53do_install() {
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
index 80e0e8df..2f15c4fb 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
@@ -44,6 +44,7 @@ PLAT_SFX:am65xx = "am65xx"
44PLAT_SFX:am64xx = "am64xx" 44PLAT_SFX:am64xx = "am64xx"
45PLAT_SFX:am62xx = "am62xx" 45PLAT_SFX:am62xx = "am62xx"
46PLAT_SFX:am62axx = "am62axx" 46PLAT_SFX:am62axx = "am62axx"
47PLAT_SFX:am62pxx = "am62pxx"
47 48
48PACKAGECONFIG[atf] = "BL31=${STAGING_DIR_HOST}/firmware/bl31.bin,,trusted-firmware-a" 49PACKAGECONFIG[atf] = "BL31=${STAGING_DIR_HOST}/firmware/bl31.bin,,trusted-firmware-a"
49PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/bl32.bin,,optee-os" 50PACKAGECONFIG[optee] = "TEE=${STAGING_DIR_HOST}${nonarch_base_libdir}/firmware/bl32.bin,,optee-os"
@@ -56,6 +57,7 @@ PACKAGECONFIG:append:j721s2 = " dm"
56PACKAGECONFIG:append:j784s4 = " dm" 57PACKAGECONFIG:append:j784s4 = " dm"
57PACKAGECONFIG:append:am62xx = " dm" 58PACKAGECONFIG:append:am62xx = " dm"
58PACKAGECONFIG:append:am62axx = " dm" 59PACKAGECONFIG:append:am62axx = " dm"
60PACKAGECONFIG:append:am62pxx = " dm"
59 61
60COMPATIBLE_MACHINE = "(ti-soc)" 62COMPATIBLE_MACHINE = "(ti-soc)"
61 63
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc b/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc
index 19386295..21b28474 100644
--- a/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc
+++ b/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc
@@ -7,6 +7,7 @@ inherit ti-secdev
7EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" 7EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
8 8
9EXTRA_OEMAKE:append:am62xx = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1" 9EXTRA_OEMAKE:append:am62xx = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
10EXTRA_OEMAKE:append:am62pxx = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
10EXTRA_OEMAKE:append:am62axx = " CFG_TEE_CORE_LOG_LEVEL=1" 11EXTRA_OEMAKE:append:am62axx = " CFG_TEE_CORE_LOG_LEVEL=1"
11 12
12do_compile:append:k3() { 13do_compile:append:k3() {
diff --git a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 751b10d6..3e2e2ada 100644
--- a/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/meta-ti-bsp/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -21,6 +21,7 @@ PLAT_SFX:am65xx = "am65xx"
21PLAT_SFX:am64xx = "am64xx" 21PLAT_SFX:am64xx = "am64xx"
22PLAT_SFX:am62xx = "am62xx" 22PLAT_SFX:am62xx = "am62xx"
23PLAT_SFX:am62axx = "am62axx" 23PLAT_SFX:am62axx = "am62axx"
24PLAT_SFX:am62pxx = "am62pxx"
24 25
25FILESEXTRAPATHS:prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:" 26FILESEXTRAPATHS:prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:"
26require recipes-bsp/ti-linux-fw/ti-linux-fw.inc 27require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
@@ -56,6 +57,7 @@ IPC_FW_LIST = ""
56IPC_FW_LIST:am65xx = "${MCU_1_0_FW} ${MCU_1_1_FW}" 57IPC_FW_LIST:am65xx = "${MCU_1_0_FW} ${MCU_1_1_FW}"
57IPC_FW_LIST:am64xx = "${MCU_1_0_FW} ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW}" 58IPC_FW_LIST:am64xx = "${MCU_1_0_FW} ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW}"
58IPC_FW_LIST:am62xx = " ${MCU_2_0_FW}" 59IPC_FW_LIST:am62xx = " ${MCU_2_0_FW}"
60IPC_FW_LIST:am62pxx = " ${MCU_2_0_FW}"
59IPC_FW_LIST:am62axx = " ${MCU_2_0_FW} ${C7X_1_FW}" 61IPC_FW_LIST:am62axx = " ${MCU_2_0_FW} ${C7X_1_FW}"
60IPC_FW_LIST:j721e = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C66_1_FW} ${C66_2_FW} ${C7X_1_FW}" 62IPC_FW_LIST:j721e = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW} ${MCU_3_0_FW} ${MCU_3_1_FW} ${C66_1_FW} ${C66_2_FW} ${C7X_1_FW}"
61IPC_FW_LIST:j7200 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW}" 63IPC_FW_LIST:j7200 = " ${MCU_1_1_FW} ${MCU_2_0_FW} ${MCU_2_1_FW}"
@@ -80,6 +82,13 @@ do_install:prepend:am62xx() {
80 ) 82 )
81} 83}
82 84
85# Update the am62pxx ipc binaries to be consistent with other platforms
86do_install:prepend:am62pxx() {
87 ( cd ${S}/${IPC_FW_DIR}; \
88 ln -sf am62p-mcu-r5f0_0-fw ${MCU_2_0_FW}; \
89 )
90}
91
83# Update the am62axx ipc binaries to be consistent with other platforms 92# Update the am62axx ipc binaries to be consistent with other platforms
84do_install:prepend:am62axx() { 93do_install:prepend:am62axx() {
85 ( cd ${S}/${IPC_FW_DIR}; \ 94 ( cd ${S}/${IPC_FW_DIR}; \
@@ -122,6 +131,10 @@ ALTERNATIVE:${PN}:am62xx = "\
122 am62-main-r5f0_0-fw am62-main-r5f0_0-fw-sec \ 131 am62-main-r5f0_0-fw am62-main-r5f0_0-fw-sec \
123 " 132 "
124 133
134ALTERNATIVE:${PN}:am62pxx = "\
135 am62p-mcu-r5f0_0-fw am62p-mcu-r5f0_0-fw-sec \
136 "
137
125ALTERNATIVE:${PN}:am62axx = "\ 138ALTERNATIVE:${PN}:am62axx = "\
126 am62a-mcu-r5f0_0-fw am62a-mcu-r5f0_0-fw-sec \ 139 am62a-mcu-r5f0_0-fw am62a-mcu-r5f0_0-fw-sec \
127 am62a-c71_0-fw am62a-c71_0-fw-sec \ 140 am62a-c71_0-fw am62a-c71_0-fw-sec \
@@ -191,6 +204,9 @@ ALTERNATIVE_LINK_NAME[am62-mcu-m4f0_0-fw-sec] = "${nonarch_base_libdir}/firmware
191ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw" 204ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw"
192ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw-sec] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw-sec" 205ALTERNATIVE_LINK_NAME[am62-main-r5f0_0-fw-sec] = "${nonarch_base_libdir}/firmware/am62-main-r5f0_0-fw-sec"
193 206
207ALTERNATIVE_LINK_NAME[am62p-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62p-mcu-r5f0_0-fw"
208ALTERNATIVE_LINK_NAME[am62p-mcu-r5f0_0-fw-sec] = "${nonarch_base_libdir}/firmware/am62p-mcu-r5f0_0-fw-sec"
209
194ALTERNATIVE_LINK_NAME[am62a-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62a-mcu-r5f0_0-fw" 210ALTERNATIVE_LINK_NAME[am62a-mcu-r5f0_0-fw] = "${nonarch_base_libdir}/firmware/am62a-mcu-r5f0_0-fw"
195ALTERNATIVE_LINK_NAME[am62a-mcu-r5f0_0-fw-sec] = "${nonarch_base_libdir}/firmware/am62a-mcu-r5f0_0-fw-sec" 211ALTERNATIVE_LINK_NAME[am62a-mcu-r5f0_0-fw-sec] = "${nonarch_base_libdir}/firmware/am62a-mcu-r5f0_0-fw-sec"
196ALTERNATIVE_LINK_NAME[am62a-c71_0-fw] = "${nonarch_base_libdir}/firmware/am62a-c71_0-fw" 212ALTERNATIVE_LINK_NAME[am62a-c71_0-fw] = "${nonarch_base_libdir}/firmware/am62a-c71_0-fw"
@@ -281,6 +297,9 @@ ALTERNATIVE_TARGET[am62-mcu-m4f0_0-fw-sec] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW
281ALTERNATIVE_TARGET[am62-main-r5f0_0-fw] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}" 297ALTERNATIVE_TARGET[am62-main-r5f0_0-fw] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}"
282ALTERNATIVE_TARGET[am62-main-r5f0_0-fw-sec] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}.signed" 298ALTERNATIVE_TARGET[am62-main-r5f0_0-fw-sec] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}.signed"
283 299
300ALTERNATIVE_TARGET[am62p-mcu-r5f0_0-fw] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}"
301ALTERNATIVE_TARGET[am62p-mcu-r5f0_0-fw-sec] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}.signed"
302
284ALTERNATIVE_TARGET[am62a-mcu-r5f0_0-fw] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}" 303ALTERNATIVE_TARGET[am62a-mcu-r5f0_0-fw] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}"
285ALTERNATIVE_TARGET[am62a-mcu-r5f0_0-fw-sec] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}.signed" 304ALTERNATIVE_TARGET[am62a-mcu-r5f0_0-fw-sec] = "${INSTALL_IPC_FW_DIR}/${MCU_2_0_FW}.signed"
286ALTERNATIVE_TARGET[am62a-c71_0-fw] = "${INSTALL_IPC_FW_DIR}/${C7X_1_FW}" 305ALTERNATIVE_TARGET[am62a-c71_0-fw] = "${INSTALL_IPC_FW_DIR}/${C7X_1_FW}"