summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAniket Limaye <a-limaye@ti.com>2023-10-04 12:04:29 +0530
committerRyan Eatmon <reatmon@ti.com>2023-10-05 12:08:25 -0500
commit01bd31052e132b43e1445f1fb0fc91920728c7cd (patch)
tree8e8d2f6ee5ef439008a29e833c63eb7a29fac2b5
parent30be88f43c3faf51ddb5f525c1fa75ad60622cf7 (diff)
downloadmeta-ti-01bd31052e132b43e1445f1fb0fc91920728c7cd.tar.gz
ti-sci-fw: Deploy the fw binaries to the deploy directory
Deploy the sysfw binaries to the DEPLOYDIR, to be picked up by the tisdk-core-bundle... for the prebuilt binaries directory Signed-off-by: Aniket Limaye <a-limaye@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index ab9356b6..801c8768 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -1,5 +1,7 @@
1SUMMARY = "TI SYSFW/TIFS Firmware" 1SUMMARY = "TI SYSFW/TIFS Firmware"
2 2
3inherit deploy
4
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc 5require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4 6
5COMPATIBLE_MACHINE = "k3r5" 7COMPATIBLE_MACHINE = "k3r5"
@@ -23,3 +25,12 @@ do_install() {
23} 25}
24 26
25FILES:${PN} = "${nonarch_base_libdir}/firmware" 27FILES:${PN} = "${nonarch_base_libdir}/firmware"
28
29do_deploy() {
30 install -d ${DEPLOYDIR}/ti-sysfw
31 install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${DEPLOYDIR}/ti-sysfw
32 install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${DEPLOYDIR}/ti-sysfw
33 install -m 644 ${S}/ti-sysfw/ti-fs-stub-firmware-* ${DEPLOYDIR}/ti-sysfw
34}
35
36addtask deploy before do_build after do_compile