summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony J. Martinez <anthony@ajmartinez.com>2023-09-13 16:45:05 +0000
committerRyan Eatmon <reatmon@ti.com>2023-09-26 15:26:18 -0500
commit41a3acf1daf8ba708bc2d3bc6fb5806f29fa016e (patch)
tree161ed79cc0e4b4f3d8b032cd6c59cf0b67e55975
parent716c4cc65e4ffa44f45af795485742e069d548eb (diff)
downloadmeta-ti-41a3acf1daf8ba708bc2d3bc6fb5806f29fa016e.tar.gz
linux-bb.org: update to 5.10.168 for armv7a targets
Updates SRCREV, PV, and BRANCH for armv7a targets and fixes failure to mount /boot when using poky with systemd. The kernel selected supports VFAT without initramfs as noted here - https://lists.yoctoproject.org/g/meta-ti/message/16913 Removes defconfig patch setting LZMA, as the new kernel already defaults to LZ4. Tested by running `bitbake core-image-base` with this patchset, and then booting a pair of Beaglebone Black devices from the resulting image. Prior to the change, systemd boots to a maintenance mode having failed to mount /boot. After the change, the system boots normally and /boot is mounted. Suggested-by: Robert Nelson <robertcnelson@gmail.com> Signed-off-by: Anthony J. Martinez <anthony@ajmartinez.com> Reviewed-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-bb.org/0001-defconfig-switch-default-kernel-compression-to-LZMA.patch29
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb10
2 files changed, 4 insertions, 35 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/0001-defconfig-switch-default-kernel-compression-to-LZMA.patch b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/0001-defconfig-switch-default-kernel-compression-to-LZMA.patch
deleted file mode 100644
index 54dc8c91..00000000
--- a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/0001-defconfig-switch-default-kernel-compression-to-LZMA.patch
+++ /dev/null
@@ -1,29 +0,0 @@
1From 0ccadc7a676341bbd66eb176308c7c59931e9dd2 Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@konsulko.com>
3Date: Fri, 7 Apr 2023 01:44:56 +0000
4Subject: [PATCH] defconfig: switch default kernel compression to LZMA
5
6LZO compression and lzop tool haven't been maintained for long time and have
7been removed in recent versions of OE-Core, even though Debian may still use
8them. Switch to LZMA compression that is used by default in TI kernel config.
9
10Upstream-Status: Inappropriate [OE-specific]
11
12Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
13---
14 arch/arm/configs/bb.org_defconfig | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/arch/arm/configs/bb.org_defconfig b/arch/arm/configs/bb.org_defconfig
18index 6bf0fb860683..7c035735172d 100644
19--- a/arch/arm/configs/bb.org_defconfig
20+++ b/arch/arm/configs/bb.org_defconfig
21@@ -1,5 +1,5 @@
22 # CONFIG_LOCALVERSION_AUTO is not set
23-CONFIG_KERNEL_LZO=y
24+CONFIG_KERNEL_LZMA=y
25 CONFIG_SYSVIPC=y
26 CONFIG_POSIX_MQUEUE=y
27 CONFIG_NO_HZ_IDLE=y
28--
292.25.1
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
index e134fb84..f4c1775d 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
@@ -16,10 +16,10 @@ KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} ${EXTRA_DTC_ARGS}"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19# 5.10.162 version for 32-bit 19# 5.10.168 version for 32-bit
20SRCREV:armv7a = "982fde4eb381f98ec8be946e8d33dd0c9f9416ab" 20SRCREV:armv7a = "a943fc1987e1b8057b0b5219ecd3c5a85285d62a"
21PV:armv7a = "5.10.162+git${SRCPV}" 21PV:armv7a = "5.10.168+git${SRCPV}"
22BRANCH:armv7a = "v5.10.162-ti-r59" 22BRANCH:armv7a = "v5.10.168-ti-r70"
23 23
24# 5.10.162 version for 64-bit 24# 5.10.162 version for 64-bit
25SRCREV:aarch64 = "a2f5d5746b6c389e58d20fda0a0fa88403da428b" 25SRCREV:aarch64 = "a2f5d5746b6c389e58d20fda0a0fa88403da428b"
@@ -30,5 +30,3 @@ SRC_URI = " \
30 git://github.com/beagleboard/linux.git;protocol=https;branch=${BRANCH} \ 30 git://github.com/beagleboard/linux.git;protocol=https;branch=${BRANCH} \
31 file://defconfig \ 31 file://defconfig \
32" 32"
33
34SRC_URI:append:armv7a = " file://0001-defconfig-switch-default-kernel-compression-to-LZMA.patch"