summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2023-06-15 15:18:49 -0500
committerRyan Eatmon <reatmon@ti.com>2023-06-15 15:31:23 -0500
commitc23cd182375ff248046e153c5c0a95418e4a8bae (patch)
tree68285f60ab1fdaf95094f721fc78c6171fafff49
parent3e3b625c8100ebaedd749acf9cb48d18f04b9c6a (diff)
downloadmeta-ti-c23cd182375ff248046e153c5c0a95418e4a8bae.tar.gz
ti-sci-fw: Include the TIFS LPM stub with the rest of SYSFW
This firmware is shipped with the rest of ti-sysfw blobs, it shares the same versions too and so should be simply bundled with the same. This stub is also built into U-Boot and not loaded during kernel runtime anymore, so remove the RDEPENDS in kernel. Signed-off-by: Andrew Davis <afd@ti.com> Reviewed-by: Praneeth Bajjuri <praneeth@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc1
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb1
-rw-r--r--meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb23
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc4
4 files changed, 1 insertions, 28 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc b/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
index 8e1b68c4..a3d43fd1 100644
--- a/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
+++ b/meta-ti-bsp/recipes-bsp/ti-linux-fw/ti-linux-fw.inc
@@ -14,7 +14,6 @@ GOODIX_FW_VERSION = "1.0.0.0"
14CADENCE_MHDP_FW_VERSION = "2.1.0" 14CADENCE_MHDP_FW_VERSION = "2.1.0"
15IMG_DEC_FW_VERSION = "1.0" 15IMG_DEC_FW_VERSION = "1.0"
16CNM_WAVE521_FW_VERSION = "1.0.00" 16CNM_WAVE521_FW_VERSION = "1.0.00"
17TIFS_LPM_STUB_FW_VERSION = "08.06.04"
18TI_DM_FW_VERSION = "08.06.04" 17TI_DM_FW_VERSION = "08.06.04"
19TI_SYSFW_VERSION = "08.06.04" 18TI_SYSFW_VERSION = "08.06.04"
20 19
diff --git a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 6a4c03f9..5ad1e688 100644
--- a/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -18,6 +18,7 @@ do_install() {
18 install -d ${D}${nonarch_base_libdir}/firmware/ti-sysfw 18 install -d ${D}${nonarch_base_libdir}/firmware/ti-sysfw
19 install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw 19 install -m 644 ${S}/ti-sysfw/ti-sci-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw
20 install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw 20 install -m 644 ${S}/ti-sysfw/ti-fs-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw
21 install -m 644 ${S}/ti-sysfw/ti-fs-stub-firmware-* ${D}${nonarch_base_libdir}/firmware/ti-sysfw
21} 22}
22 23
23FILES:${PN} = "${nonarch_base_libdir}/firmware" 24FILES:${PN} = "${nonarch_base_libdir}/firmware"
diff --git a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
deleted file mode 100644
index 2db761ba..00000000
--- a/meta-ti-bsp/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "TI Foundational security Low Power Management Stub"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${TIFS_LPM_STUB_FW_VERSION}"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am62xx|am62axx"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = "ti-fs-stub-firmware-am62x-gp-signed.bin"
17
18do_install() {
19 install -d ${D}${nonarch_base_libdir}/firmware/ti-sysfw/
20 install -m 0644 ${S}/ti-sysfw/${TARGET} ${D}${nonarch_base_libdir}/firmware/ti-sysfw/${TARGET}
21}
22
23FILES:${PN} = "${nonarch_base_libdir}/firmware"
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index 69796915..18984e80 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -31,7 +31,3 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " vxd-dec-fw"
31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw" 31RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721s2 = " cnm-wave-fw"
32RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cnm-wave-fw" 32RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j784s4 = " cnm-wave-fw"
33RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62axx = " cnm-wave-fw" 33RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62axx = " cnm-wave-fw"
34
35# Add run-time dependency for TIFS Low Power Module stub
36RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62xx = " tifs-lpm-stub"
37RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am62axx = " tifs-lpm-stub"