summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-06-06 14:35:25 -0500
committerRyan Eatmon <reatmon@ti.com>2023-06-09 07:54:38 -0500
commit732a15cae061211a0fb2dec751a49cd22d073bfe (patch)
tree4abfb54ffee58a265fe0b867f2a2f690e140c7f8
parente301fd9be26a2f4b07a771b899ffd96eace283c0 (diff)
downloadmeta-ti-732a15cae061211a0fb2dec751a49cd22d073bfe.tar.gz
ti-img-rogue-umlibs: drop the api specific dev packages
Well, flew a bit too close to the sun on that last patch. Apparently there are a few hidden runtime dependencies on the API devlinks that make things like EGL upset when they aren't present. We may circle back to this at some point but for now we're fine shipping the devlinks in the base API packages as these links don't step on any other package. Fixes: 1899f5ea (ti-img-rogue-umlibs: bump version and explicitly package, 2023-06-01) Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb30
1 files changed, 11 insertions, 19 deletions
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
index 26090038..b166736c 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
@@ -36,11 +36,11 @@ do_install:append() {
36} 36}
37 37
38PACKAGES = " \ 38PACKAGES = " \
39 libgles1-rogue libgles1-rogue-dev \ 39 libgles1-rogue \
40 libgles2-rogue libgles2-rogue-dev \ 40 libgles2-rogue \
41 libgles3-rogue libgles3-rogue-dev \ 41 libgles3-rogue \
42 libvk-rogue libvk-rogue-dev \ 42 libvk-rogue \
43 libopencl-rogue libopencl-rogue-dev \ 43 libopencl-rogue \
44 libopencl-rogue-tools \ 44 libopencl-rogue-tools \
45 ${PN}-tools \ 45 ${PN}-tools \
46 ${PN}-firmware \ 46 ${PN}-firmware \
@@ -64,34 +64,26 @@ python __anonymous() {
64 mlprefix = d.getVar("MLPREFIX") 64 mlprefix = d.getVar("MLPREFIX")
65 pkgs = " " + " ".join(mlprefix + x + suffix for x in p[1:]) 65 pkgs = " " + " ".join(mlprefix + x + suffix for x in p[1:])
66 d.setVar("DEBIAN_NOAUTONAME:" + fullp, "1") 66 d.setVar("DEBIAN_NOAUTONAME:" + fullp, "1")
67 d.setVar("INSANE_SKIP:" + fullp, "dev-so")
67 d.appendVar("RRECOMMENDS:" + fullp, " ${MLPREFIX}ti-img-rogue-umlibs" + suffix) 68 d.appendVar("RRECOMMENDS:" + fullp, " ${MLPREFIX}ti-img-rogue-umlibs" + suffix)
68
69 # For -dev, the first element is both the Debian and original name
70 fullp = mlprefix + p[1] + "-rogue-dev" + suffix
71 pkgs = " " + mlprefix + p[1] + "-dev" + suffix
72 d.setVar("DEBIAN_NOAUTONAME:" + fullp, "1")
73} 69}
74 70
75# gles specific shared objects 71# gles specific shared objects
76FILES:libgles1-rogue = "${libdir}/libGLESv1*.so.*" 72FILES:libgles1-rogue = "${libdir}/libGLESv1*.so*"
77FILES:libgles1-rogue-dev = "${libdir}/libGLESv1*.so" 73FILES:libgles2-rogue = "${libdir}/libGLESv2*.so*"
78FILES:libgles2-rogue = "${libdir}/libGLESv2*.so.*"
79FILES:libgles2-rogue-dev = "${libdir}/libGLESv2*.so"
80RDEPENDS:libgles1-rogue += "mesa-megadriver" 74RDEPENDS:libgles1-rogue += "mesa-megadriver"
81RDEPENDS:libgles2-rogue += "mesa-megadriver" 75RDEPENDS:libgles2-rogue += "mesa-megadriver"
82RDEPENDS:libgles3-rogue-dev += "libgles2-rogue-dev"
83 76
84# vulkan specific shared objects and configs 77# vulkan specific shared objects and configs
85FILES:libvk-rogue = "${libdir}/libVK_IMG.so.* ${datadir}/vulkan" 78FILES:libvk-rogue = "${libdir}/libVK_IMG.so* ${datadir}/vulkan"
86FILES:libvk-rogue-dev = "${libdir}/libVK_IMG.so"
87RDEPENDS:libvk-rogue += "vulkan-loader libx11-xcb wayland libdrm" 79RDEPENDS:libvk-rogue += "vulkan-loader libx11-xcb wayland libdrm"
88 80
89# opencl specific shared objects and configs 81# opencl specific shared objects and configs
90FILES:libopencl-rogue = "${libdir}/libPVROCL.so.* ${sysconfdir}/OpenCL" 82FILES:libopencl-rogue = "${libdir}/libPVROCL.so* ${sysconfdir}/OpenCL"
91FILES:libopencl-rogue-dev = "${libdir}/libPVROCL.so"
92RDEPENDS:libopencl-rogue += "opencl-icd-loader" 83RDEPENDS:libopencl-rogue += "opencl-icd-loader"
93RRECOMMENDS:libopencl-rogue += "libopencl-rogue-tools" 84RRECOMMENDS:libopencl-rogue += "libopencl-rogue-tools"
94FILES:libopencl-rogue-tools += "${bindir}/ocl*" 85FILES:libopencl-rogue-tools += "${bindir}/ocl*"
86DEBIAN_NOAUTONAME:libopencl-rogue-tools = "1"
95 87
96# optional tools and tests 88# optional tools and tests
97FILES:${PN}-tools = "${bindir}/" 89FILES:${PN}-tools = "${bindir}/"