summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-06-22 17:37:49 -0500
committerRyan Eatmon <reatmon@ti.com>2023-06-23 10:52:24 -0500
commit6352c729755583c4bac5961f8b821c075c03512f (patch)
treeb62a8a3b59474877fe875a15b66a793e352963d4
parentb86456651b1b9ce1e0612f9892387ec54b4f5759 (diff)
downloadmeta-ti-6352c729755583c4bac5961f8b821c075c03512f.tar.gz
ti-img-rogue-umlibs: use rrecommends for components
Use RRECOMMENDS for components. Apparently I made an resolvable dependency cycle that Yocto silently clipped. My best guess at the culprit was: mesa-megadriver (RR) -> rogue-km (RR) -> rogue-um (RD) -> libgles1-rogue (RD) -> mesa-megadriver That killed the ti-img-rogue-umlibs recipe during do_rootfs. The rogue GLES libs do depend on mesa-megadriver at runtime but I guess the UM components should only really recommend the rogue GLES components be present at runtime to make the cycle resolvable by opkg. Fixes: 1705f6d3 (ti-img-rogue-umlibs: make all components optional, 2023-06-21) Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb17
1 files changed, 6 insertions, 11 deletions
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
index c012859f..9f129c9d 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-img-rogue-umlibs_23.1.6404501.bb
@@ -33,9 +33,9 @@ PACKAGECONFIG ?= " \
33 ${@bb.utils.filter('DISTRO_FEATURES', 'opengl opencl', d)} \ 33 ${@bb.utils.filter('DISTRO_FEATURES', 'opengl opencl', d)} \
34" 34"
35 35
36PACKAGECONFIG[opengl] = ",,,${GLES_LIB_PACKAGES}" 36PACKAGECONFIG[opengl] = ",,,,${GLES_PACKAGES}"
37PACKAGECONFIG[vulkan] = ",,,${VULKAN_LIB_PACKAGES}" 37PACKAGECONFIG[vulkan] = ",,,,${VULKAN_PACKAGES}"
38PACKAGECONFIG[opencl] = ",,,${OPENCL_LIB_PACKAGES},libopencl-rogue-tools" 38PACKAGECONFIG[opencl] = ",,,,${OPENCL_PACKAGES}"
39 39
40def get_file_list(package_list_var, d): 40def get_file_list(package_list_var, d):
41 file_list = [] 41 file_list = []
@@ -72,14 +72,9 @@ do_install:append() {
72 fi 72 fi
73} 73}
74 74
75GLES_LIB_PACKAGES = "libgles1-rogue libgles2-rogue libgles3-rogue" 75GLES_PACKAGES = "libgles1-rogue libgles2-rogue libgles3-rogue"
76GLES_PACKAGES = "${GLES_LIB_PACKAGES}" 76VULKAN_PACKAGES = "libvk-rogue"
77 77OPENCL_PACKAGES = "libopencl-rogue libopencl-rogue-tools"
78VULKAN_LIB_PACKAGES = "libvk-rogue"
79VULKAN_PACKAGES = "${VULKAN_LIB_PACKAGES}"
80
81OPENCL_LIB_PACKAGES = "libopencl-rogue"
82OPENCL_PACKAGES = "${OPENCL_LIB_PACKAGES} libopencl-rogue-tools"
83 78
84PACKAGES = " \ 79PACKAGES = " \
85 ${@bb.utils.contains('PACKAGECONFIG', 'opengl', d.getVar('GLES_PACKAGES'), '', d)} \ 80 ${@bb.utils.contains('PACKAGECONFIG', 'opengl', d.getVar('GLES_PACKAGES'), '', d)} \