summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-04-27 16:07:45 -0500
committerRyan Eatmon <reatmon@ti.com>2023-05-02 17:33:49 -0500
commit16b50c8854e85f87bde01008270329984ae3d2e3 (patch)
tree28dd6d195dbdaf629031181d5b4da87d1664baab
parent050ac64a1e83da0c7eafff6a30002ce92900ffaf (diff)
downloadmeta-ti-16b50c8854e85f87bde01008270329984ae3d2e3.tar.gz
cairo: resolve opengl version
Cairo can either be built for use with OpenGL or OpenGLES. By default it assumes it can use OpenGL if X11 is provided as a distro feature. This assumption is not true when using the proprietary SGX / Rogue drivers. Vulkan libraries need some X libs at runtime now, so we need to manually override the PACKAGECONFIG for cairo to use OpenGLES. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/cairo/cairo_%.bbappend1
-rw-r--r--meta-ti-bsp/recipes-graphics/cairo/pvr-cairo.inc5
2 files changed, 6 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-graphics/cairo/cairo_%.bbappend b/meta-ti-bsp/recipes-graphics/cairo/cairo_%.bbappend
new file mode 100644
index 00000000..459d8d09
--- /dev/null
+++ b/meta-ti-bsp/recipes-graphics/cairo/cairo_%.bbappend
@@ -0,0 +1 @@
require ${@bb.utils.contains_any('PREFERRED_PROVIDER_virtual/gpudriver', 'ti-img-rogue-driver ti-sgx-ddk-km', 'pvr-cairo.inc', '', d)}
diff --git a/meta-ti-bsp/recipes-graphics/cairo/pvr-cairo.inc b/meta-ti-bsp/recipes-graphics/cairo/pvr-cairo.inc
new file mode 100644
index 00000000..b41f1a01
--- /dev/null
+++ b/meta-ti-bsp/recipes-graphics/cairo/pvr-cairo.inc
@@ -0,0 +1,5 @@
1# This is required since cairo expects the opengl distro feature to refer to
2# the desktop version of OpenGL. Imagination drivers only provide OpenGLES.
3
4PACKAGECONFIG:remove = "opengl"
5PACKAGECONFIG:append = " glesv2"