summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-04-14 11:58:57 -0500
committerRyan Eatmon <reatmon@ti.com>2023-04-14 14:34:01 -0500
commit16a8078a43eef297449a04d6861fd9811bfeb052 (patch)
tree15744009baf090005b701d9c3a530a17f9b9d035
parenta392b299fd0df3515a918aae147eb0ee424d6c1e (diff)
downloadmeta-ti-16a8078a43eef297449a04d6861fd9811bfeb052.tar.gz
mesa: locally overlay 22.3.5-specific patches from oe-core/master
Locally overlay verbatim copies of mesa 22.3.5 patches from oe-core/master, so the same codebase works in kirkstone and master. Also drop the old patches from 22.0 that were from the tip of oe-core/kirkstone previously. Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/files/0001-Revert-egl-wayland-deprecate-drm_handle_format-and-d.patch157
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/files/0001-freedreno-pm4-Use-unsigned-instead-of-uint-to-fix-mu.patch43
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/files/0001-futex.h-Define-__NR_futex-if-it-does-not-exist.patch34
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/files/0001-gbm-backend-fix-gbm-compile-without-dri.patch64
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch2
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch18
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/files/0001-util-format-Check-for-NEON-before-using-it.patch6
-rw-r--r--meta-ti-bsp/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch61
8 files changed, 120 insertions, 265 deletions
diff --git a/meta-ti-bsp/recipes-graphics/mesa/files/0001-Revert-egl-wayland-deprecate-drm_handle_format-and-d.patch b/meta-ti-bsp/recipes-graphics/mesa/files/0001-Revert-egl-wayland-deprecate-drm_handle_format-and-d.patch
deleted file mode 100644
index 03e4b422..00000000
--- a/meta-ti-bsp/recipes-graphics/mesa/files/0001-Revert-egl-wayland-deprecate-drm_handle_format-and-d.patch
+++ /dev/null
@@ -1,157 +0,0 @@
1From 7796c2c56c960ac55e49246f0349ac52539ada55 Mon Sep 17 00:00:00 2001
2From: Leandro Ribeiro <leandro.ribeiro@collabora.com>
3Date: Sun, 10 Apr 2022 22:54:36 -0300
4Subject: [PATCH] Revert "egl/wayland: deprecate drm_handle_format() and
5 drm_handle_capabilities()"
6
7Commit af1ee8e010441f8f2ed8c77065b159652a4ac9fe dropped support to
8wl_drm, as we thought that most compositors from active projects were
9already supporting zwp_linux_dmabuf_v1.
10
11But that's not true, so revert this commit in order to give these
12projects a longer transition period.
13
14Note that we didn't add back the support to GEM name API, and that was
15on purpose.
16
17Signed-off-by: Leandro Ribeiro <leandro.ribeiro@collabora.com>
18Reviewed-by: Simon Ser <contact@emersion.fr>
19Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/15822>
20
21Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
22Upstream-Status: Backport [https://gitlab.freedesktop.org/mesa/mesa/-/commit/c60fea8c228ae3f32e20d6b65c473d9f04871d20]
23---
24 src/egl/drivers/dri2/egl_dri2.h | 1 +
25 src/egl/drivers/dri2/platform_wayland.c | 59 +++++++++++++++++++------
26 2 files changed, 47 insertions(+), 13 deletions(-)
27
28diff --git a/src/egl/drivers/dri2/egl_dri2.h b/src/egl/drivers/dri2/egl_dri2.h
29index c466ff83c53..eecb32a53fd 100644
30--- a/src/egl/drivers/dri2/egl_dri2.h
31+++ b/src/egl/drivers/dri2/egl_dri2.h
32@@ -283,6 +283,7 @@ struct dri2_egl_display
33 struct zwp_linux_dmabuf_feedback_v1 *wl_dmabuf_feedback;
34 struct dmabuf_feedback_format_table format_table;
35 bool authenticated;
36+ uint32_t capabilities;
37 char *device_name;
38 #endif
39
40diff --git a/src/egl/drivers/dri2/platform_wayland.c b/src/egl/drivers/dri2/platform_wayland.c
41index 5ff83cce08a..843434376a7 100644
42--- a/src/egl/drivers/dri2/platform_wayland.c
43+++ b/src/egl/drivers/dri2/platform_wayland.c
44@@ -1343,7 +1343,7 @@ create_wl_buffer(struct dri2_egl_display *dri2_dpy,
45 struct dri2_egl_surface *dri2_surf,
46 __DRIimage *image)
47 {
48- struct wl_buffer *ret;
49+ struct wl_buffer *ret = NULL;
50 EGLBoolean query;
51 int width, height, fourcc, num_planes;
52 uint64_t modifier = DRM_FORMAT_MOD_INVALID;
53@@ -1447,11 +1447,28 @@ create_wl_buffer(struct dri2_egl_display *dri2_dpy,
54 ret = zwp_linux_buffer_params_v1_create_immed(params, width, height,
55 fourcc, 0);
56 zwp_linux_buffer_params_v1_destroy(params);
57+ } else {
58+ struct wl_drm *wl_drm =
59+ dri2_surf ? dri2_surf->wl_drm_wrapper : dri2_dpy->wl_drm;
60+ int fd = -1, stride;
61+
62+ if (num_planes > 1)
63+ return NULL;
64+
65+ query = dri2_dpy->image->queryImage(image, __DRI_IMAGE_ATTRIB_FD, &fd);
66+ query &= dri2_dpy->image->queryImage(image, __DRI_IMAGE_ATTRIB_STRIDE, &stride);
67+ if (!query) {
68+ if (fd >= 0)
69+ close(fd);
70+ return NULL;
71+ }
72
73- return ret;
74+ ret = wl_drm_create_prime_buffer(wl_drm, fd, width, height, fourcc, 0,
75+ stride, 0, 0, 0, 0);
76+ close(fd);
77 }
78
79- return NULL;
80+ return ret;
81 }
82
83 static EGLBoolean
84@@ -1698,16 +1715,21 @@ drm_handle_device(void *data, struct wl_drm *drm, const char *device)
85 static void
86 drm_handle_format(void *data, struct wl_drm *drm, uint32_t format)
87 {
88- /* deprecated, as compositors already support the dma-buf protocol extension
89- * and so we can rely on dmabuf_handle_modifier() to receive formats and
90- * modifiers */
91+ struct dri2_egl_display *dri2_dpy = data;
92+ int visual_idx = dri2_wl_visual_idx_from_fourcc(format);
93+
94+ if (visual_idx == -1)
95+ return;
96+
97+ BITSET_SET(dri2_dpy->formats.formats_bitmap, visual_idx);
98 }
99
100 static void
101 drm_handle_capabilities(void *data, struct wl_drm *drm, uint32_t value)
102 {
103- /* deprecated, as compositors already support the dma-buf protocol extension
104- * and so we can rely on it to create wl_buffer's */
105+ struct dri2_egl_display *dri2_dpy = data;
106+
107+ dri2_dpy->capabilities = value;
108 }
109
110 static void
111@@ -2075,13 +2097,12 @@ dri2_initialize_wayland_drm(_EGLDisplay *disp)
112 wl_registry_add_listener(dri2_dpy->wl_registry,
113 &registry_listener_drm, dri2_dpy);
114
115- /* The compositor must expose the dma-buf interface. */
116- if (roundtrip(dri2_dpy) < 0 || dri2_dpy->wl_dmabuf == NULL)
117+ if (roundtrip(dri2_dpy) < 0)
118 goto cleanup;
119
120 /* Get default dma-buf feedback */
121- if (zwp_linux_dmabuf_v1_get_version(dri2_dpy->wl_dmabuf) >=
122- ZWP_LINUX_DMABUF_V1_GET_DEFAULT_FEEDBACK_SINCE_VERSION) {
123+ if (dri2_dpy->wl_dmabuf && zwp_linux_dmabuf_v1_get_version(dri2_dpy->wl_dmabuf) >=
124+ ZWP_LINUX_DMABUF_V1_GET_DEFAULT_FEEDBACK_SINCE_VERSION) {
125 dmabuf_feedback_format_table_init(&dri2_dpy->format_table);
126 dri2_dpy->wl_dmabuf_feedback =
127 zwp_linux_dmabuf_v1_get_default_feedback(dri2_dpy->wl_dmabuf);
128@@ -2089,7 +2110,6 @@ dri2_initialize_wayland_drm(_EGLDisplay *disp)
129 &dmabuf_feedback_listener, dri2_dpy);
130 }
131
132- /* Receive events from the interfaces */
133 if (roundtrip(dri2_dpy) < 0)
134 goto cleanup;
135
136@@ -2176,6 +2196,19 @@ dri2_initialize_wayland_drm(_EGLDisplay *disp)
137
138 dri2_wl_setup_swap_interval(disp);
139
140+ if (dri2_dpy->wl_drm) {
141+ /* To use Prime, we must have _DRI_IMAGE v7 at least. createImageFromFds
142+ * support indicates that Prime export/import is supported by the driver.
143+ * We deprecated the support to GEM names API, so we bail out if the
144+ * driver does not suport Prime. */
145+ if (!(dri2_dpy->capabilities & WL_DRM_CAPABILITY_PRIME) ||
146+ (dri2_dpy->image->base.version < 7) ||
147+ (dri2_dpy->image->createImageFromFds == NULL)) {
148+ _eglLog(_EGL_WARNING, "wayland-egl: display does not support prime");
149+ goto cleanup;
150+ }
151+ }
152+
153 if (dri2_dpy->is_different_gpu &&
154 (dri2_dpy->image->base.version < 9 ||
155 dri2_dpy->image->blitImage == NULL)) {
156--
1572.35.1
diff --git a/meta-ti-bsp/recipes-graphics/mesa/files/0001-freedreno-pm4-Use-unsigned-instead-of-uint-to-fix-mu.patch b/meta-ti-bsp/recipes-graphics/mesa/files/0001-freedreno-pm4-Use-unsigned-instead-of-uint-to-fix-mu.patch
new file mode 100644
index 00000000..f0775176
--- /dev/null
+++ b/meta-ti-bsp/recipes-graphics/mesa/files/0001-freedreno-pm4-Use-unsigned-instead-of-uint-to-fix-mu.patch
@@ -0,0 +1,43 @@
1From 8a5de0b6cf1090d7f29f3974ec79c32776cf2745 Mon Sep 17 00:00:00 2001
2From: Jami Kettunen <jami.kettunen@protonmail.com>
3Date: Tue, 31 Aug 2021 00:15:58 +0300
4Subject: [PATCH] freedreno/pm4: Use unsigned instead of uint to fix musl build
5
6Upstream-Status: Backport
7
8Fixes the following error I noticed when building against aarch64 with
9musl libc:
10
11 In file included from ../src/freedreno/decode/crashdec.h:38,
12 from ../src/freedreno/decode/crashdec.c:40:
13 ../src/freedreno/common/freedreno_pm4.h:104:15: error: unknown type name 'uint'
14 104 | static inline uint
15 | ^~~~
16 ../src/freedreno/common/freedreno_pm4.h:105:25: error: unknown type name 'uint'; did you mean 'int'?
17 105 | pm4_calc_odd_parity_bit(uint val)
18 | ^~~~
19 | int
20
21Signed-off-by: Jami Kettunen <jami.kettunen@protonmail.com>
22Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/19665>
23---
24 src/freedreno/common/freedreno_pm4.h | 4 ++--
25 1 file changed, 2 insertions(+), 2 deletions(-)
26
27diff --git a/src/freedreno/common/freedreno_pm4.h b/src/freedreno/common/freedreno_pm4.h
28index 8f958953d693..091247e709a0 100644
29--- a/src/freedreno/common/freedreno_pm4.h
30+++ b/src/freedreno/common/freedreno_pm4.h
31@@ -105,8 +105,8 @@ pm4_pkt7_hdr(uint8_t opcode, uint16_t cnt)
32 #define cp_type3_opcode(pkt) (((pkt) >> 8) & 0xFF)
33 #define type3_pkt_size(pkt) ((((pkt) >> 16) & 0x3FFF) + 1)
34
35-static inline uint
36-pm4_calc_odd_parity_bit(uint val)
37+static inline unsigned
38+pm4_calc_odd_parity_bit(unsigned val)
39 {
40 return (0x9669 >> (0xf & ((val) ^ ((val) >> 4) ^ ((val) >> 8) ^
41 ((val) >> 12) ^ ((val) >> 16) ^ ((val) >> 20) ^
42--
432.39.2
diff --git a/meta-ti-bsp/recipes-graphics/mesa/files/0001-futex.h-Define-__NR_futex-if-it-does-not-exist.patch b/meta-ti-bsp/recipes-graphics/mesa/files/0001-futex.h-Define-__NR_futex-if-it-does-not-exist.patch
deleted file mode 100644
index 3f7a6340..00000000
--- a/meta-ti-bsp/recipes-graphics/mesa/files/0001-futex.h-Define-__NR_futex-if-it-does-not-exist.patch
+++ /dev/null
@@ -1,34 +0,0 @@
1From 253b042d2bf10e9abfa9cc508e0782aefd834145 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 16 Oct 2020 11:03:47 -0700
4Subject: [PATCH] futex.h: Define __NR_futex if it does not exist
5
6__NR_futex is not defines by newer architectures e.g. arc, riscv32 as
7they only have 64bit variant of time_t. Glibc defines SYS_futex interface based on
8__NR_futex, since this is used in applications, such applications start
9to fail to build for these newer architectures. This patch defines a
10fallback to alias __NR_futex to __NR_futex_tim64 so SYS_futex keeps
11working
12
13Upstream-Status: Pending
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15
16---
17 src/util/futex.h | 4 ++++
18 1 file changed, 4 insertions(+)
19
20diff --git a/src/util/futex.h b/src/util/futex.h
21index 43097f4..941b0ec 100644
22--- a/src/util/futex.h
23+++ b/src/util/futex.h
24@@ -34,6 +34,10 @@
25 #include <sys/syscall.h>
26 #include <sys/time.h>
27
28+#if !defined(SYS_futex) && defined(SYS_futex_time64)
29+# define SYS_futex SYS_futex_time64
30+#endif
31+
32 static inline long sys_futex(void *addr1, int op, int val1, const struct timespec *timeout, void *addr2, int val3)
33 {
34 return syscall(SYS_futex, addr1, op, val1, timeout, addr2, val3);
diff --git a/meta-ti-bsp/recipes-graphics/mesa/files/0001-gbm-backend-fix-gbm-compile-without-dri.patch b/meta-ti-bsp/recipes-graphics/mesa/files/0001-gbm-backend-fix-gbm-compile-without-dri.patch
new file mode 100644
index 00000000..289ff032
--- /dev/null
+++ b/meta-ti-bsp/recipes-graphics/mesa/files/0001-gbm-backend-fix-gbm-compile-without-dri.patch
@@ -0,0 +1,64 @@
1From 25946100e21cf2095bea334e8d7096798561d0b7 Mon Sep 17 00:00:00 2001
2From: Vincent Davis Jr <vince@underview.tech>
3Date: Wed, 28 Dec 2022 16:28:01 -0600
4Subject: [PATCH] gbm/backend: fix gbm compile without dri
5
6Upstream-Status: Backport
7
8https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/20447
9https://gitlab.freedesktop.org/mesa/mesa/-/commit/842ca284650f066e58706741a7d22d67b5088e60
10
11At mesa version 22.2.3 patch wasn't introduced until after.
12
13Commit introduces a fix that allows for gbm to be built with an empty
14backend. There are situation especially in a Yocto/OE cross compilation
15environment where you want to build with an empty backend. The particular
16situation is as such:
17
18The mesa-gl recipe is the preferred provider for virtual/libgbm, virtual/libgl,
19virtual/mesa, etc... But the x11 DISTRO_FEATURE in't included this leads to build
20errors such as:
21
22| /../../../ld: src/gbm/libgbm.so.1.0.0.p/main_backend.c.o: in function `find_backend':
23| backend.c:(.text.find_backend+0xa4): undefined reference to `gbm_dri_backend'
24| /../../../ld: src/gbm/libgbm.so.1.0.0.p/main_backend.c.o:(.data.rel.ro.builtin_backends+0x4):
25 undefined reference to `gbm_dri_backend'
26| collect2: error: ld returned 1 exit status
27
28Issue should be replicable by setting -Ddri3=disabled and -Dgbm=enabled
29
30Add fix to bypasses compilation issue by excluding gbm dri backend. If
31HAVE_DRI || HAVE_DRIX not specified.
32
33Acked-by: David Heidelberg <david.heidelberg@collabora.com>
34Signed-off-by: Vincent Davis Jr <vince@underview.tech>
35---
36 src/gbm/main/backend.c | 4 ++++
37 1 file changed, 4 insertions(+)
38
39diff --git a/src/gbm/main/backend.c b/src/gbm/main/backend.c
40index 974d0a76a4e..feee0703495 100644
41--- a/src/gbm/main/backend.c
42+++ b/src/gbm/main/backend.c
43@@ -42,7 +42,9 @@
44 #define ARRAY_SIZE(a) (sizeof(a)/sizeof((a)[0]))
45 #define VER_MIN(a, b) ((a) < (b) ? (a) : (b))
46
47+#if defined(HAVE_DRI) || defined(HAVE_DRI2) || defined(HAVE_DRI3)
48 extern const struct gbm_backend gbm_dri_backend;
49+#endif
50
51 struct gbm_backend_desc {
52 const char *name;
53@@ -51,7 +53,9 @@ struct gbm_backend_desc {
54 };
55
56 static const struct gbm_backend_desc builtin_backends[] = {
57+#if defined(HAVE_DRI) || defined(HAVE_DRI2) || defined(HAVE_DRI3)
58 { "dri", &gbm_dri_backend },
59+#endif
60 };
61
62 #define BACKEND_LIB_SUFFIX "_gbm"
63--
642.34.1
diff --git a/meta-ti-bsp/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch b/meta-ti-bsp/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch
index 5b98915c..35bd0ea1 100644
--- a/meta-ti-bsp/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch
+++ b/meta-ti-bsp/recipes-graphics/mesa/files/0001-meson-misdetects-64bit-atomics-on-mips-clang.patch
@@ -1,4 +1,4 @@
1From d34bdbd80e5a1f309d2ba280cdc66ff0ee0e5c43 Mon Sep 17 00:00:00 2001 1From 3ef37c63f03ad6f2af407de350486fdd25e9132a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Jan 2020 15:23:47 -0800 3Date: Mon, 13 Jan 2020 15:23:47 -0800
4Subject: [PATCH] meson misdetects 64bit atomics on mips/clang 4Subject: [PATCH] meson misdetects 64bit atomics on mips/clang
diff --git a/meta-ti-bsp/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch b/meta-ti-bsp/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
index 3d2c163b..f0c1de46 100644
--- a/meta-ti-bsp/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
+++ b/meta-ti-bsp/recipes-graphics/mesa/files/0001-meson.build-check-for-all-linux-host_os-combinations.patch
@@ -1,4 +1,4 @@
1From f9c597a2c517eb85c23cbeeb2e95c55794c74cda Mon Sep 17 00:00:00 2001 1From 3b4d6b89f644b43e507c08181fef06db4326f9da Mon Sep 17 00:00:00 2001
2From: Alistair Francis <alistair@alistair23.me> 2From: Alistair Francis <alistair@alistair23.me>
3Date: Thu, 14 Nov 2019 13:04:49 -0800 3Date: Thu, 14 Nov 2019 13:04:49 -0800
4Subject: [PATCH] meson.build: check for all linux host_os combinations 4Subject: [PATCH] meson.build: check for all linux host_os combinations
@@ -20,23 +20,23 @@ Signed-off-by: Alistair Francis <alistair@alistair23.me>
20 1 file changed, 2 insertions(+), 2 deletions(-) 20 1 file changed, 2 insertions(+), 2 deletions(-)
21 21
22diff --git a/meson.build b/meson.build 22diff --git a/meson.build b/meson.build
23index bca6b1f..70d06c0 100644 23index 172c64a..9b5294c 100644
24--- a/meson.build 24--- a/meson.build
25+++ b/meson.build 25+++ b/meson.build
26@@ -172,7 +172,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2 26@@ -173,7 +173,7 @@ with_any_opengl = with_opengl or with_gles1 or with_gles2
27 # Only build shared_glapi if at least one OpenGL API is enabled 27 # Only build shared_glapi if at least one OpenGL API is enabled
28 with_shared_glapi = with_shared_glapi and with_any_opengl 28 with_shared_glapi = with_shared_glapi and with_any_opengl
29 29
30-system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos'].contains(host_machine.system()) 30-system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android'].contains(host_machine.system())
31+system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'dragonfly'].contains(host_machine.system()) or host_machine.system().startswith('linux') 31+system_has_kms_drm = ['openbsd', 'netbsd', 'freebsd', 'gnu/kfreebsd', 'dragonfly', 'linux', 'sunos', 'android'].contains(host_machine.system()) or host_machine.system().startswith('linux')
32 32
33 dri_drivers = get_option('dri-drivers') 33 with_freedreno_kgsl = get_option('freedreno-kgsl')
34 if dri_drivers.length() != 0 34 if with_freedreno_kgsl
35@@ -1074,7 +1074,7 @@ if cc.compiles('__uint128_t foo(void) { return 0; }', 35@@ -1076,7 +1076,7 @@ if cc.has_function('reallocarray')
36 endif 36 endif
37 37
38 # TODO: this is very incomplete 38 # TODO: this is very incomplete
39-if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku'].contains(host_machine.system()) 39-if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku', 'android'].contains(host_machine.system())
40+if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku'].contains(host_machine.system()) or host_machine.system().startswith('linux') 40+if ['linux', 'cygwin', 'gnu', 'freebsd', 'gnu/kfreebsd', 'haiku'].contains(host_machine.system()) or host_machine.system().startswith('linux')
41 pre_args += '-D_GNU_SOURCE' 41 pre_args += '-D_GNU_SOURCE'
42 elif host_machine.system() == 'sunos' 42 elif host_machine.system() == 'sunos'
diff --git a/meta-ti-bsp/recipes-graphics/mesa/files/0001-util-format-Check-for-NEON-before-using-it.patch b/meta-ti-bsp/recipes-graphics/mesa/files/0001-util-format-Check-for-NEON-before-using-it.patch
index b3403bcd..6eea5ed8 100644
--- a/meta-ti-bsp/recipes-graphics/mesa/files/0001-util-format-Check-for-NEON-before-using-it.patch
+++ b/meta-ti-bsp/recipes-graphics/mesa/files/0001-util-format-Check-for-NEON-before-using-it.patch
@@ -1,4 +1,4 @@
1From fdb2face4eeac3c20eedcca7520f4e7014225fb4 Mon Sep 17 00:00:00 2001 1From f17e836ef9b1bbc6056790596420b699e48128c2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 2 Dec 2021 19:57:42 -0800 3Date: Thu, 2 Dec 2021 19:57:42 -0800
4Subject: [PATCH] util/format: Check for NEON before using it 4Subject: [PATCH] util/format: Check for NEON before using it
@@ -20,10 +20,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
20 2 files changed, 2 insertions(+), 2 deletions(-) 20 2 files changed, 2 insertions(+), 2 deletions(-)
21 21
22diff --git a/src/util/format/u_format.c b/src/util/format/u_format.c 22diff --git a/src/util/format/u_format.c b/src/util/format/u_format.c
23index 36c5e52..f0a0097 100644 23index c071250..0880984 100644
24--- a/src/util/format/u_format.c 24--- a/src/util/format/u_format.c
25+++ b/src/util/format/u_format.c 25+++ b/src/util/format/u_format.c
26@@ -1138,7 +1138,7 @@ static void 26@@ -1184,7 +1184,7 @@ static void
27 util_format_unpack_table_init(void) 27 util_format_unpack_table_init(void)
28 { 28 {
29 for (enum pipe_format format = PIPE_FORMAT_NONE; format < PIPE_FORMAT_COUNT; format++) { 29 for (enum pipe_format format = PIPE_FORMAT_NONE; format < PIPE_FORMAT_COUNT; format++) {
diff --git a/meta-ti-bsp/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch b/meta-ti-bsp/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
deleted file mode 100644
index 1b9c1ba3..00000000
--- a/meta-ti-bsp/recipes-graphics/mesa/files/0002-meson.build-make-TLS-ELF-optional.patch
+++ /dev/null
@@ -1,61 +0,0 @@
1From bf41fa026ae3d378e62fd83d03a6f5933b52ca04 Mon Sep 17 00:00:00 2001
2From: Alistair Francis <alistair@alistair23.me>
3Date: Thu, 14 Nov 2019 13:08:31 -0800
4Subject: [PATCH] meson.build: make TLS ELF optional
5
6USE_ELF_TLS has replaced GLX_USE_TLS so this patch is the original "make
7TLS GLX optional again" patch updated to the latest mesa.
8
9For details, see:
10https://gitlab.freedesktop.org/mesa/mesa/-/issues/966
11
12This prevents runtime segfault on musl:
13
14Traceback (most recent call last):
15 File "/home/pokybuild/yocto-worker/musl-qemux86/build/meta/lib/oeqa/core/decorator/__init__.py", line 36, in wrapped_f
16 return func(*args, **kwargs)
17 File "/home/pokybuild/yocto-worker/musl-qemux86/build/meta/lib/oeqa/runtime/cases/parselogs.py", line 378, in test_parselogs
18 self.assertEqual(errcount, 0, msg=self.msg)
19AssertionError: 1 != 0 : Log: /home/pokybuild/yocto-worker/musl-qemux86/build/build/tmp/work/qemux86-poky-linux-musl/core-image-sato-sdk/1.0-r0/target_logs/Xorg.0.log
20
21Upstream-Status: Inappropriate [configuration]
22---
23 meson.build | 7 +++++--
24 meson_options.txt | 6 ++++++
25 2 files changed, 11 insertions(+), 2 deletions(-)
26
27diff --git a/meson.build b/meson.build
28index 70d06c0..1441611 100644
29--- a/meson.build
30+++ b/meson.build
31@@ -490,8 +490,11 @@ foreach platform : _platforms
32 pre_args += '-DHAVE_@0@_PLATFORM'.format(platform.to_upper())
33 endforeach
34
35-use_elf_tls = true
36-pre_args += '-DUSE_ELF_TLS'
37+use_elf_tls = false
38+if get_option('elf-tls')
39+ use_elf_tls = true
40+ pre_args += '-DUSE_ELF_TLS'
41+endif
42
43 if with_platform_android and get_option('platform-sdk-version') >= 29
44 # By default the NDK compiler, at least, emits emutls references instead of
45diff --git a/meson_options.txt b/meson_options.txt
46index 1f6ef38..99cc5cb 100644
47--- a/meson_options.txt
48+++ b/meson_options.txt
49@@ -440,6 +440,12 @@ option(
50 value : true,
51 description : 'Enable direct rendering in GLX and EGL for DRI',
52 )
53+option(
54+ 'elf-tls',
55+ type : 'boolean',
56+ value : true,
57+ description : 'Enable TLS support in ELF',
58+)
59 option('egl-lib-suffix',
60 type : 'string',
61 value : '',