summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-04-28 15:10:18 -0500
committerRyan Eatmon <reatmon@ti.com>2023-05-15 11:20:14 -0500
commita164e629c29c4e6f31834b05cccc24dff6cfe57e (patch)
tree5e06fe2bae3b3bc87f5fcb4f31ae479acb2609a8
parent14bc74d7f9538c962df0d0cd67abfa9e4af26cfb (diff)
downloadmeta-ti-a164e629c29c4e6f31834b05cccc24dff6cfe57e.tar.gz
ti-ipc: Stop looking for rpmsg_rpc.h in the kernel
Stop looking for the rpmsg_rpc.h in the kernel. While we are doing the LTS migration for kirkstone, this file is not going to be in the kernel for a bit. This patch works in conjunction with a recipe change that downloads the header and adds a -I to the CFLAGS to pick it up. This will be removed once the 6.1 kernel has been updated. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch35
-rw-r--r--meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb6
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch b/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
new file mode 100644
index 00000000..ef12af88
--- /dev/null
+++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc/0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch
@@ -0,0 +1,35 @@
1From 66ca0e732c2e287814d4fc5082b818554ee42398 Mon Sep 17 00:00:00 2001
2From: Ryan Eatmon <reatmon@ti.com>
3Date: Fri, 28 Apr 2023 14:30:59 -0500
4Subject: [PATCH] MmRpc: Stop looking for rpmsg_rpc.h in the kernel
5
6Stop looking for the rpmsg_rpc.h in the kernel. While we are doing the
7LTS migration for kirkstone, this file is not going to be in the kernel
8for a bit. This patch works in conjunction with a recipe change that
9downloads the header and adds a -I to the CFLAGS to pick it up. This
10will be removed once the 6.1 kernel has been updated.
11
12Signed-off-by: Ryan Eatmon <reatmon@ti.com>
13
14Upstream-Status: Inappropriate [other]
15
16---
17 packages/ti/ipc/mm/MmRpc.c | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/packages/ti/ipc/mm/MmRpc.c b/packages/ti/ipc/mm/MmRpc.c
21index 2df7420..10f496b 100644
22--- a/packages/ti/ipc/mm/MmRpc.c
23+++ b/packages/ti/ipc/mm/MmRpc.c
24@@ -64,7 +64,7 @@
25 #define linux_include(kd,m) <kd/include/uapi/linux/m.h>
26 #endif
27
28-#include linux_include(KERNEL_INSTALL_DIR,rpmsg_rpc)
29+#include "linux/rpmsg_rpc.h"
30
31 #ifdef _linux_
32 #define linux _linux
33--
342.17.1
35
diff --git a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
index 01b857c2..e2db6efd 100644
--- a/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
+++ b/meta-ti-bsp/recipes-ti/ipc/ti-ipc_git.bb
@@ -8,12 +8,18 @@ PR = "${INC_PR}.2"
8 8
9DEPENDS += "virtual/kernel" 9DEPENDS += "virtual/kernel"
10 10
11SRC_URI:append = " https://git.ti.com/cgit/ti-linux-kernel/ti-linux-kernel/plain/include/uapi/linux/rpmsg_rpc.h?h=ti-linux-5.10.y;name=rpmsg_rpc;subdir=linux;downloadfilename=rpmsg_rpc.h"
12SRC_URI[rpmsg_rpc.sha256sum] = "cd237f40a37520a1f2df19fbfeefd00c0a5ad68efeaba9ba0fba60ca16ea09be"
13
11SRC_URI += "file://tiipclad-daemon.sh \ 14SRC_URI += "file://tiipclad-daemon.sh \
12 file://omap_remoteproc.conf \ 15 file://omap_remoteproc.conf \
13 file://tiipclad-daemon.service \ 16 file://tiipclad-daemon.service \
14 file://0001-Add-kernel-build-dir.patch \ 17 file://0001-Add-kernel-build-dir.patch \
18 file://0001-MmRpc-Stop-looking-for-rpmsg_rpc.h-in-the-kernel.patch \
15 " 19 "
16 20
21CFLAGS += "-I${WORKDIR}"
22
17DAEMON = "UNKNOWN" 23DAEMON = "UNKNOWN"
18DAEMON:dra7xx = "lad_dra7xx" 24DAEMON:dra7xx = "lad_dra7xx"
19DAEMON:omapl138 = "lad_omapl138" 25DAEMON:omapl138 = "lad_omapl138"