summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-05-01 19:22:50 +0000
committerRyan Eatmon <reatmon@ti.com>2023-05-02 17:41:01 -0500
commit8ad82f5e69c3ed739bbdd5d1a0afd75ab7608ec8 (patch)
treeb3c6e6194e52430f40003eb8baae05496396faa6
parent35f7613f422be947ea29907d9652e3ebb8221d75 (diff)
downloadmeta-ti-8ad82f5e69c3ed739bbdd5d1a0afd75ab7608ec8.tar.gz
linux-bb.org: add support for config fragments
* Add support for additional config fragments passed via semi-standard KERNEL_CONFIG_FRAGMENTS variable * Also don't build all DTBs, only those specified in the machine config Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-bb.org/defconfig1
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb13
2 files changed, 6 insertions, 8 deletions
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/defconfig b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/defconfig
new file mode 100644
index 00000000..a5de2e24
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org/defconfig
@@ -0,0 +1 @@
use-kernel-config=bb.org_defconfig
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
index 19664ba8..e134fb84 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-bb.org_git.bb
@@ -7,6 +7,7 @@ COMPATIBLE_MACHINE = "beagle.*"
7 7
8inherit kernel 8inherit kernel
9 9
10require recipes-kernel/linux/setup-defconfig.inc
10require recipes-kernel/linux/ti-kernel.inc 11require recipes-kernel/linux/ti-kernel.inc
11 12
12DEPENDS += "gmp-native libmpc-native" 13DEPENDS += "gmp-native libmpc-native"
@@ -25,13 +26,9 @@ SRCREV:aarch64 = "a2f5d5746b6c389e58d20fda0a0fa88403da428b"
25PV:aarch64 = "5.10.162+git${SRCPV}" 26PV:aarch64 = "5.10.162+git${SRCPV}"
26BRANCH:aarch64 = "v5.10.162-ti-arm64-r99" 27BRANCH:aarch64 = "v5.10.162-ti-arm64-r99"
27 28
28SRC_URI = "git://github.com/beagleboard/linux.git;protocol=https;branch=${BRANCH}" 29SRC_URI = " \
30 git://github.com/beagleboard/linux.git;protocol=https;branch=${BRANCH} \
31 file://defconfig \
32"
29 33
30SRC_URI:append:armv7a = " file://0001-defconfig-switch-default-kernel-compression-to-LZMA.patch" 34SRC_URI:append:armv7a = " file://0001-defconfig-switch-default-kernel-compression-to-LZMA.patch"
31
32DEFCONFIG_NAME = "bb.org_defconfig"
33KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}"
34
35kernel_do_compile:append() {
36 oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS}
37}