summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChirag Shilwant <c-shilwant@ti.com>2023-02-13 20:26:14 +0530
committerRyan Eatmon <reatmon@ti.com>2023-02-13 13:10:38 -0600
commit84af651b0682cb71b62ebd94f8ec6495cfa769d1 (patch)
treef070ffd5f05ade6129c53b2997ca6c6fa1b03340
parenta80c06916068456bc6c56c4bf68a3f8d784b819d (diff)
downloadmeta-ti-84af651b0682cb71b62ebd94f8ec6495cfa769d1.tar.gz
am62xx-lp-evm: Add AM62x LP HS-FS evm configuration
Lets add the basic AM62x LP HS-FS configuration - Add machine conf for AM62x LP HS-FS. - The wic images will boot on AM62x LP HS-FS devices by default. The sysfw image for HS-SE will be packaged in the wic image as tiboot3-am62x-hs-evm.bin. - Add ti-sci-firmware overrides. Signed-off-by: Chirag Shilwant <c-shilwant@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf14
-rw-r--r--conf/machine/am62xx-lp-evm-k3r5-hs-se.conf7
-rw-r--r--conf/machine/include/am62xx-lp.inc8
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb1
4 files changed, 29 insertions, 1 deletions
diff --git a/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf b/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf
new file mode 100644
index 00000000..0178fcfc
--- /dev/null
+++ b/conf/machine/am62xx-lp-evm-k3r5-hs-fs.conf
@@ -0,0 +1,14 @@
1#@TYPE: Machine
2#@NAME: AM62xx LPSK HS-FS EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62xx LP HS-FS EVM (R5F core)
4
5# Booting HS-FS requires different SYSFW, the rest is handled at runtime
6
7require conf/machine/include/k3r5.inc
8SOC_FAMILY_append = ":k3r5-hs-fs"
9
10SYSFW_SOC = "am62x"
11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs-fs"
13
14UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
diff --git a/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf b/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
index b752ee7e..b44cbe20 100644
--- a/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
+++ b/conf/machine/am62xx-lp-evm-k3r5-hs-se.conf
@@ -11,4 +11,11 @@ SYSFW_SOC = "am62x"
11SYSFW_CONFIG = "evm" 11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs" 12SYSFW_SUFFIX = "hs"
13 13
14SYSFW_TIBOOT3_SYMLINK = ""
15
14UBOOT_MACHINE = "am62x_lpsk_r5_defconfig" 16UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
17
18SPL_BINARY = ""
19UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
20UBOOT_IMAGE = "u-boot-r5spl-hs-se-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
21UBOOT_SYMLINK = "u-boot-r5spl-hs-se.${UBOOT_SUFFIX}"
diff --git a/conf/machine/include/am62xx-lp.inc b/conf/machine/include/am62xx-lp.inc
index c38de868..02937662 100644
--- a/conf/machine/include/am62xx-lp.inc
+++ b/conf/machine/include/am62xx-lp.inc
@@ -8,8 +8,14 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
8 8
9TFA_K3_SYSTEM_SUSPEND = "1" 9TFA_K3_SYSTEM_SUSPEND = "1"
10 10
11# Default tiboot3.bin on AM62x LP is for HS-SE 11# Default tiboot3.bin on AM62x LP is for HS-FS
12BBMULTICONFIG = "k3r5-hs-fs"
13do_image_wic[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy"
14do_image_tar[mcdepends] = "mc::k3r5-hs-fs:ti-sci-fw:do_deploy"
15
16# Since default tiboot3.bin on AM62x LP is for HS-FS, add a version for HS-SE
12BBMULTICONFIG += "k3r5-hs-se" 17BBMULTICONFIG += "k3r5-hs-se"
18IMAGE_BOOT_FILES += " tiboot3-am62x-hs-evm.bin"
13do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" 19do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
14do_image_tar[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy" 20do_image_tar[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
15 21
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 7d046750..643a2ab3 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -42,6 +42,7 @@ SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs"
42SYSFW_PREFIX_am62xx-evm-k3r5-hs-fs = "fs" 42SYSFW_PREFIX_am62xx-evm-k3r5-hs-fs = "fs"
43SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" 43SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs"
44SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" 44SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs"
45SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-fs = "fs"
45SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" 46SYSFW_PREFIX_am62axx-evm-k3r5 = "fs"
46 47
47SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" 48SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"