summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnrico Butera <ebutera@users.berlios.de>2011-08-06 14:00:29 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-16 09:46:07 +0200
commit1a9b46011d086e5b45a14af807ffd06e1ceecfc1 (patch)
treed0ebf7eb3b60ad29a8ee2cc057b045cf778f0c12
parent61d4676bafb3169947d937a7b74f4b6e9d8c7575 (diff)
downloadmeta-ti-1a9b46011d086e5b45a14af807ffd06e1ceecfc1.tar.gz
xdctools: fix toolchain hardcoded paths
Signed-off-by: Enrico Butera <ebutera@users.berlios.de> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-ti/devtools/ti-xdctools/fix-hardcoded-paths.diff21
-rw-r--r--recipes-ti/devtools/ti-xdctools_3.20.06.81.bb2
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes-ti/devtools/ti-xdctools/fix-hardcoded-paths.diff b/recipes-ti/devtools/ti-xdctools/fix-hardcoded-paths.diff
new file mode 100644
index 00000000..36142c47
--- /dev/null
+++ b/recipes-ti/devtools/ti-xdctools/fix-hardcoded-paths.diff
@@ -0,0 +1,21 @@
1diff -ur a/packages/gnu/targets/ITarget.xs b/packages/gnu/targets/ITarget.xs
2--- a/packages/gnu/targets/ITarget.xs 2011-08-06 13:24:44.000000000 +0200
3+++ b/packages/gnu/targets/ITarget.xs 2011-08-06 13:23:37.000000000 +0200
4@@ -251,7 +251,7 @@
5
6 function askLd(target)
7 {
8- var ldCmd = target.rootDir + "/" + target.GCCTARG + "/bin/ld";
9+ var ldCmd = target.rootDir + "/" + target.GCCTARG + "-ld";
10 /* If the ld executable cannot be found, and the prefix is not used,
11 * it's probably a misspelled directory path.
12 */
13@@ -486,7 +486,7 @@
14 tool2cmd["link"] = cmd;
15
16 /* define the ar command template */
17- cmd = prefix + target.ar.cmd
18+ cmd = prefix + target.GCCTARG + "-ar"
19 + " $(AROPTS_P) " + target.ar.opts
20 + " $@ $(AROPTS_S) $(aropts) $(files)";
21 tool2cmd["ar"] = cmd;
diff --git a/recipes-ti/devtools/ti-xdctools_3.20.06.81.bb b/recipes-ti/devtools/ti-xdctools_3.20.06.81.bb
index 110ee356..45bedaab 100644
--- a/recipes-ti/devtools/ti-xdctools_3.20.06.81.bb
+++ b/recipes-ti/devtools/ti-xdctools_3.20.06.81.bb
@@ -5,6 +5,8 @@ PV = "3_20_06_81"
5# This fixes c6accel, but breaks codec-engine and lpm 5# This fixes c6accel, but breaks codec-engine and lpm
6#SRC_URI += "file://arm-linker-hack.diff" 6#SRC_URI += "file://arm-linker-hack.diff"
7 7
8SRC_URI += "file://fix-hardcoded-paths.diff"
9
8SRC_URI[xdcbin.md5sum] = "65151268d6be6ad6eb940ef7ed03af16" 10SRC_URI[xdcbin.md5sum] = "65151268d6be6ad6eb940ef7ed03af16"
9SRC_URI[xdcbin.sha256sum] = "8ea6b851521ce41fe0b4a349b2d922af7e70f48c50ad9fd21f62627446a834f8" 11SRC_URI[xdcbin.sha256sum] = "8ea6b851521ce41fe0b4a349b2d922af7e70f48c50ad9fd21f62627446a834f8"
10 12