summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-08-04 21:49:32 -0500
committerRyan Eatmon <reatmon@ti.com>2022-08-06 19:04:37 -0500
commit142be8971f67566c8abc137be9ea2f0254b20a90 (patch)
tree56ee7e83853eb629ae5054490c7f22738900045b
parent50c39940b63713932603ef2bc77d36aaf1f4fb46 (diff)
downloadmeta-ti-142be8971f67566c8abc137be9ea2f0254b20a90.tar.gz
ti-sci-fw: Make combined R5 boot the default
Going forward, the combined tiboot3.bin is going to be the standard. Only AM65x and J721e will still use the split boot. Set DEPENDS and EXTRA_OEMAKE for combined boot and override only for the two split boot platforms. This makes it easier to add new platforms and simplifies deployment logic. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--conf/machine/j7-hs-evm.conf1
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb30
2 files changed, 15 insertions, 16 deletions
diff --git a/conf/machine/j7-hs-evm.conf b/conf/machine/j7-hs-evm.conf
index 5cb2a3cd..ff998dc7 100644
--- a/conf/machine/j7-hs-evm.conf
+++ b/conf/machine/j7-hs-evm.conf
@@ -17,6 +17,7 @@ UBOOT_DTBO_OFFSET = "0x00010000"
17SPL_BINARY = "tispl.bin_HS" 17SPL_BINARY = "tispl.bin_HS"
18UBOOT_BINARY = "u-boot.img_HS" 18UBOOT_BINARY = "u-boot.img_HS"
19UBOOT_SYMLINK = "u-boot.img" 19UBOOT_SYMLINK = "u-boot.img"
20SYSFW_SYMLINK = ""
20 21
21BBMULTICONFIG += "k3r5-sr1-1" 22BBMULTICONFIG += "k3r5-sr1-1"
22 23
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 1b2ea184..b06f6abe 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -1,13 +1,12 @@
1require recipes-bsp/ti-linux-fw/ti-linux-fw.inc 1require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
2 2
3DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" 3DEPENDS = "openssl-native u-boot-mkimage-native dtc-native virtual/bootloader"
4DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader" 4DEPENDS_remove_am65xx-evm-k3r5 = " virtual/bootloader"
5DEPENDS_append_j7200-hs-evm-k3r5 = " virtual/bootloader" 5DEPENDS_remove_am65xx-hs-evm-k3r5 = " virtual/bootloader"
6DEPENDS_append_j721s2-evm-k3r5 = " virtual/bootloader" 6DEPENDS_remove_am65xx-hs-evm-k3r5-sr2 = " virtual/bootloader"
7DEPENDS_append_j721s2-hs-evm-k3r5 = " virtual/bootloader" 7DEPENDS_remove_j7-evm-k3r5 = " virtual/bootloader"
8DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader" 8DEPENDS_remove_j7-hs-evm-k3r5 = " virtual/bootloader"
9DEPENDS_append_am64xx-hs-evm-k3r5 = " virtual/bootloader" 9DEPENDS_remove_j7-hs-evm-k3r5-sr1-1 = " virtual/bootloader"
10DEPENDS_append_am62xx-evm-k3r5 = " virtual/bootloader"
11 10
12CLEANBROKEN = "1" 11CLEANBROKEN = "1"
13PR = "${INC_PR}.2" 12PR = "${INC_PR}.2"
@@ -54,15 +53,14 @@ do_configure[noexec] = "1"
54EXTRA_OEMAKE = "\ 53EXTRA_OEMAKE = "\
55 CROSS_COMPILE=${TARGET_PREFIX} SOC=${SYSFW_SOC} SOC_TYPE=${SYSFW_SUFFIX} \ 54 CROSS_COMPILE=${TARGET_PREFIX} SOC=${SYSFW_SOC} SOC_TYPE=${SYSFW_SUFFIX} \
56 CONFIG=${SYSFW_CONFIG} SYSFW_DIR="${S}/ti-sysfw" \ 55 CONFIG=${SYSFW_CONFIG} SYSFW_DIR="${S}/ti-sysfw" \
56 SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin" \
57" 57"
58 58EXTRA_OEMAKE_remove_am65xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
59EXTRA_OEMAKE_append_j7200-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 59EXTRA_OEMAKE_remove_am65xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
60EXTRA_OEMAKE_append_j7200-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 60EXTRA_OEMAKE_remove_am65xx-hs-evm-k3r5-sr2 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
61EXTRA_OEMAKE_append_j721s2-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 61EXTRA_OEMAKE_remove_j7-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
62EXTRA_OEMAKE_append_j721s2-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 62EXTRA_OEMAKE_remove_j7-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
63EXTRA_OEMAKE_append_am64xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin"" 63EXTRA_OEMAKE_remove_j7-hs-evm-k3r5-sr1-1 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
64EXTRA_OEMAKE_append_am64xx-hs-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
65EXTRA_OEMAKE_append_am62xx-evm-k3r5 = " SBL="${STAGING_DIR_HOST}/boot/u-boot-spl.bin""
66 64
67do_compile() { 65do_compile() {
68 cd ${WORKDIR}/imggen/ 66 cd ${WORKDIR}/imggen/