summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-01-11 18:10:33 -0600
committerRyan Eatmon <reatmon@ti.com>2023-01-12 10:05:07 -0600
commitdb3379650da94f37a0e9f9e2e35f77a4fbf48792 (patch)
tree63486c2d07772b5d7483c378d99a2b9f53431b47
parentc3a35c9421bfd23cb8382659fa45bbadadfbbbcf (diff)
downloadmeta-ti-db3379650da94f37a0e9f9e2e35f77a4fbf48792.tar.gz
hs: Deploy the unsigned versions of bl31 and bl32
In addition to releasing the signed versions of the bl31.bin and bl32.bin files, also release the unsigned original versions. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend13
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
2 files changed, 17 insertions, 0 deletions
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index bb969da2..a5eb9ff8 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -50,3 +50,16 @@ do_compile_append_j721s2-hs-evm() {
50do_compile_append_j784s4-hs-evm() { 50do_compile_append_j784s4-hs-evm() {
51 tfa_sign_k3hs 51 tfa_sign_k3hs
52} 52}
53
54do_install_append_k3() {
55 if [ -f $BUILD_PLAT/bl31.bin.unsigned ]; then
56 echo "Install bl31.bin.unsigned"
57 install -m 0644 $BUILD_PLAT/bl31.bin.unsigned \
58 ${D}/firmware/bl31.bin.unsigned
59 else
60 echo "Install bl31.bin.unsigned"
61 install -m 0644 $BUILD_PLAT/bl31.bin \
62 ${D}/firmware/bl31.bin.unsigned
63 fi
64}
65
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index ca2fd42e..db9064de 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -17,6 +17,7 @@ do_compile_prepend_ti-soc() {
17do_compile_append_k3() { 17do_compile_append_k3() {
18 ( cd out/arm-plat-${OPTEEOUTPUTMACHINE}/core/; \ 18 ( cd out/arm-plat-${OPTEEOUTPUTMACHINE}/core/; \
19 cp tee-pager_v2.bin ${B}/bl32.bin; \ 19 cp tee-pager_v2.bin ${B}/bl32.bin; \
20 cp tee-pager_v2.bin ${B}/bl32.bin.unsigned; \
20 cp tee.elf ${B}/bl32.elf; \ 21 cp tee.elf ${B}/bl32.elf; \
21 ) 22 )
22} 23}
@@ -50,6 +51,7 @@ optee_sign_k3hs() {
50 cp tee-pager_v2.bin tee-pager.bin.signed; \ 51 cp tee-pager_v2.bin tee-pager.bin.signed; \
51 fi; \ 52 fi; \
52 mv tee-pager.bin.signed ${B}/bl32.bin; \ 53 mv tee-pager.bin.signed ${B}/bl32.bin; \
54 cp tee-pager_v2.bin bl32.bin.unsigned; \
53 cp tee.elf ${B}/bl32.elf; \ 55 cp tee.elf ${B}/bl32.elf; \
54 ) 56 )
55} 57}
@@ -93,6 +95,7 @@ do_compile_append_j784s4-hs-evm() {
93do_install_append_ti-soc() { 95do_install_append_ti-soc() {
94 install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true 96 install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true
95 install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true 97 install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true
98 install -m 644 ${B}/bl32.bin.unsigned ${D}${nonarch_base_libdir}/firmware/ || true
96 install -m 644 ${B}/bl32.elf ${D}${nonarch_base_libdir}/firmware/ || true 99 install -m 644 ${B}/bl32.elf ${D}${nonarch_base_libdir}/firmware/ || true
97} 100}
98 101
@@ -113,6 +116,7 @@ do_deploy_append_dra7xx() {
113 116
114do_deploy_append_k3() { 117do_deploy_append_k3() {
115 ln -sf optee/bl32.bin ${DEPLOYDIR}/ 118 ln -sf optee/bl32.bin ${DEPLOYDIR}/
119 ln -sf optee/bl32.bin.unsigned ${DEPLOYDIR}/
116 ln -sf optee/bl32.elf ${DEPLOYDIR}/ 120 ln -sf optee/bl32.elf ${DEPLOYDIR}/
117} 121}
118 122