summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChirag Shilwant <c-shilwant@ti.com>2023-01-30 14:22:41 +0530
committerRyan Eatmon <reatmon@ti.com>2023-01-30 10:33:34 -0600
commitca662c2221e890ab856fe2ce5b232985c71af412 (patch)
tree954df857eb378390d19e4df51a3053024b15bec9
parent0988872f39527d28441e91605211b2242646584a (diff)
downloadmeta-ti-ca662c2221e890ab856fe2ce5b232985c71af412.tar.gz
machine: Add AM62x HS-SE evm configuration
Lets add the basic AM62x HS-SE configuration. - Add machine conf for AM62x HS-SE. - The wic images will boot on AM62x GP devices by default. To boot on AM62x HS-SE, simply switch out the SYSFW image: $ cd /mnt/sd-card/boot $ mv tiboot3-am62x-hs-evm.bin tiboot3.bin - Add ti-sci-firmware overrides. - Add support to sign ATF and OPTEE. Signed-off-by: Chirag Shilwant <c-shilwant@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--conf/machine/am62xx-evm-k3r5-gp.conf (renamed from conf/machine/am62xx-evm-k3r5.conf)3
-rw-r--r--conf/machine/am62xx-evm-k3r5-hs-se.conf21
-rw-r--r--conf/machine/am62xx-evm.conf4
-rw-r--r--conf/machine/include/am62xx.inc11
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb3
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend4
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
7 files changed, 47 insertions, 3 deletions
diff --git a/conf/machine/am62xx-evm-k3r5.conf b/conf/machine/am62xx-evm-k3r5-gp.conf
index 724a8d4a..d9867bc7 100644
--- a/conf/machine/am62xx-evm-k3r5.conf
+++ b/conf/machine/am62xx-evm-k3r5-gp.conf
@@ -9,3 +9,6 @@ SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp" 9SYSFW_SUFFIX = "gp"
10 10
11UBOOT_MACHINE = "am62x_evm_r5_defconfig" 11UBOOT_MACHINE = "am62x_evm_r5_defconfig"
12
13UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
14UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
diff --git a/conf/machine/am62xx-evm-k3r5-hs-se.conf b/conf/machine/am62xx-evm-k3r5-hs-se.conf
new file mode 100644
index 00000000..913e69fa
--- /dev/null
+++ b/conf/machine/am62xx-evm-k3r5-hs-se.conf
@@ -0,0 +1,21 @@
1#@TYPE: Machine
2#@NAME: AM62xx HS-SE EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62xx HS-SE EVM (R5F core)
4
5# Booting HS-SE requires different SYSFW, the rest is handled at runtime
6
7require conf/machine/include/k3r5.inc
8SOC_FAMILY_append = ":k3r5-hs-se"
9
10SYSFW_SOC = "am62x"
11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs"
13
14SYSFW_TIBOOT3_SYMLINK = ""
15
16UBOOT_MACHINE = "am62x_evm_r5_defconfig"
17
18SPL_BINARY = ""
19UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
20UBOOT_IMAGE = "u-boot-r5spl-hs-se-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
21UBOOT_SYMLINK = "u-boot-r5spl-hs-se.${UBOOT_SUFFIX}"
diff --git a/conf/machine/am62xx-evm.conf b/conf/machine/am62xx-evm.conf
index 3d9e3b90..b4904eca 100644
--- a/conf/machine/am62xx-evm.conf
+++ b/conf/machine/am62xx-evm.conf
@@ -19,3 +19,7 @@ KERNEL_DEVICETREE = " \
19" 19"
20 20
21UBOOT_MACHINE = "am62x_evm_a53_defconfig" 21UBOOT_MACHINE = "am62x_evm_a53_defconfig"
22
23SPL_BINARY = "tispl.bin_HS"
24UBOOT_BINARY = "u-boot.img_HS"
25UBOOT_SYMLINK = "u-boot.img"
diff --git a/conf/machine/include/am62xx.inc b/conf/machine/include/am62xx.inc
index 0231235f..912318e9 100644
--- a/conf/machine/include/am62xx.inc
+++ b/conf/machine/include/am62xx.inc
@@ -8,8 +8,15 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}"
8 8
9TFA_K3_SYSTEM_SUSPEND = "1" 9TFA_K3_SYSTEM_SUSPEND = "1"
10 10
11do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" 11BBMULTICONFIG = "k3r5-gp"
12do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" 12do_image_wic[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy"
13do_image_tar[mcdepends] = "mc::k3r5-gp:ti-sci-fw:do_deploy"
14
15# Since default tiboot3.bin on AM62x is for GP, add a version for HS-SE
16BBMULTICONFIG += "k3r5-hs-se"
17IMAGE_BOOT_FILES += " tiboot3-am62x-hs-evm.bin"
18do_image_wic[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
19do_image_tar[mcdepends] += "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
13 20
14TFA_BOARD = "lite" 21TFA_BOARD = "lite"
15OPTEEMACHINE = "k3-am62x" 22OPTEEMACHINE = "k3-am62x"
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 0fb3a832..7896c366 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -37,7 +37,8 @@ SYSFW_PREFIX_j721s2-evm-k3r5 = "fs"
37SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs" 37SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
38SYSFW_PREFIX_j784s4-evm-k3r5 = "fs" 38SYSFW_PREFIX_j784s4-evm-k3r5 = "fs"
39SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs" 39SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs"
40SYSFW_PREFIX_am62xx-evm-k3r5 = "fs" 40SYSFW_PREFIX_am62xx-evm-k3r5-gp = "fs"
41SYSFW_PREFIX_am62xx-evm-k3r5-hs-se = "fs"
41SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" 42SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs"
42SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs" 43SYSFW_PREFIX_am62xx-lp-evm-k3r5-hs-se = "fs"
43SYSFW_PREFIX_am62axx-evm-k3r5 = "fs" 44SYSFW_PREFIX_am62axx-evm-k3r5 = "fs"
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index caf27328..41071676 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -31,6 +31,10 @@ do_compile_append_am64xx-evm() {
31 tfa_sign_k3hs 31 tfa_sign_k3hs
32} 32}
33 33
34do_compile_append_am62xx-evm() {
35 tfa_sign_k3hs
36}
37
34do_compile_append_am62xx-lp-evm() { 38do_compile_append_am62xx-lp-evm() {
35 tfa_sign_k3hs 39 tfa_sign_k3hs
36} 40}
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 83eb9c6a..91abbcee 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -72,6 +72,10 @@ do_compile_append_am64xx-evm() {
72 optee_sign_k3hs 72 optee_sign_k3hs
73} 73}
74 74
75do_compile_append_am62xx-evm() {
76 optee_sign_k3hs
77}
78
75do_compile_append_am62xx-lp-evm() { 79do_compile_append_am62xx-lp-evm() {
76 optee_sign_k3hs 80 optee_sign_k3hs
77} 81}