summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanthana Bharathi <santa@ti.com>2019-09-16 11:17:41 +0000
committerDenys Dmytriyenko <denys@ti.com>2019-09-17 04:35:14 +0000
commit19f70740e937bb78a55a25f734329d27a9805d0f (patch)
treeecb8fcd8ebd0e1e2cc29b49b88859f921d1b25a1
parent4c3b6121713b5c2caeedc374fd68044902faccd9 (diff)
downloadmeta-ti-19f70740e937bb78a55a25f734329d27a9805d0f.tar.gz
cpsw9g-eth-fw: Add CPSW 9G support for J7
Signed-off-by: Santhana Bharathi <santa@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb b/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
new file mode 100644
index 00000000..0c86488d
--- /dev/null
+++ b/recipes-bsp/cpsw9g-eth-fw/cpsw9g-eth-fw_git.bb
@@ -0,0 +1,43 @@
1SUMMARY = "R5 PSDK CPSW9G Ethernet Switch Firmware"
2
3LICENSE = "TI-TFL"
4LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=04ad0a015d4bb63c2b9e7b112debf3db"
5
6PV = "1.0+git${SRCPV}"
7PACKAGE_ARCH = "${MACHINE_ARCH}"
8
9inherit deploy
10inherit update-alternatives
11
12PROTOCOL = "git"
13BRANCH = "master"
14SRCREV = "df7f399319ee401dfbda9317878128a0f718507f"
15
16SRC_URI = "git://git.ti.com/glsdk/ti-eth-fw.git;protocol=${PROTOCOL};branch=${BRANCH}"
17
18S = "${WORKDIR}/git"
19
20CPSW9G_FW_DIR = "${S}/ethfw"
21CPSW9G_FW_FILENAME = "app_remoteswitchcfg_server.xer5f"
22
23# make sure that lib/firmware, and all its contents are part of the package
24FILES_${PN} += "${base_libdir}/firmware"
25
26do_install() {
27 install -d ${D}${base_libdir}/firmware
28# Ethernet firmware to be loaded on Main R5 core(needs read permission)
29 install -m 0644 ${CPSW9G_FW_DIR}/${CPSW9G_FW_FILENAME} ${D}${base_libdir}/firmware
30}
31
32TARGET_MAIN_R5FSS0_0 = "j7-main-r5f0_0-fw"
33ALTERNATIVE_${PN} = "j7-main-r5f0_0-fw"
34ALTERNATIVE_LINK_NAME[j7-main-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MAIN_R5FSS0_0}"
35ALTERNATIVE_TARGET[j7-main-r5f0_0-fw] = "${base_libdir}/firmware/${CPSW9G_FW_FILENAME}"
36ALTERNATIVE_PRIORITY = "17"
37
38INHIBIT_PACKAGE_STRIP = "1"
39INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
40INSANE_SKIP_${PN} += "arch"
41
42do_compile[noexec] = "1"
43do_configure[noexec] = "1"