summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorManorit Chawdhry <m-chawdhry@ti.com>2022-11-07 14:50:45 +0530
committerRyan Eatmon <reatmon@ti.com>2022-11-15 11:51:57 -0600
commit95d1f6503c679596e29a4ed5d7a12a9d7c7a818a (patch)
tree71f488d1027cae61293b5aa08591b93e456f4155
parented8e95cbd5c2b22607070235c55d73898c85986a (diff)
downloadmeta-ti-95d1f6503c679596e29a4ed5d7a12a9d7c7a818a.tar.gz
j784s4-hs: changes to support new hs platform
Changes to support new j784s4-hs platform in: 1) ti-sci-fw_git: Update firmware prefix for j784s4-hs 2) atf: sign the image 4) optee: sign the image Signed-off-by: Manorit Chawdhry <m-chawdhry@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb1
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend4
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
3 files changed, 9 insertions, 0 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index e5dcdd61..79c39ee5 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -36,6 +36,7 @@ SYSFW_PREFIX_j7200-hs-evm-k3r5 = "fs"
36SYSFW_PREFIX_j721s2-evm-k3r5 = "fs" 36SYSFW_PREFIX_j721s2-evm-k3r5 = "fs"
37SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs" 37SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
38SYSFW_PREFIX_j784s4-evm-k3r5 = "fs" 38SYSFW_PREFIX_j784s4-evm-k3r5 = "fs"
39SYSFW_PREFIX_j784s4-hs-evm-k3r5 = "fs"
39SYSFW_PREFIX_am62xx-evm-k3r5 = "fs" 40SYSFW_PREFIX_am62xx-evm-k3r5 = "fs"
40SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs" 41SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs"
41 42
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 53e88d7e..e3c171dc 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -42,3 +42,7 @@ do_compile_append_j7200-hs-evm() {
42do_compile_append_j721s2-hs-evm() { 42do_compile_append_j721s2-hs-evm() {
43 tfa_sign_k3hs 43 tfa_sign_k3hs
44} 44}
45
46do_compile_append_j784s4-hs-evm() {
47 tfa_sign_k3hs
48}
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 4a4ebfd7..2b591d58 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -81,6 +81,10 @@ do_compile_append_j721s2-hs-evm() {
81 optee_sign_k3hs 81 optee_sign_k3hs
82} 82}
83 83
84do_compile_append_j784s4-hs-evm() {
85 optee_sign_k3hs
86}
87
84do_install_append_ti-soc() { 88do_install_append_ti-soc() {
85 install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true 89 install -m 644 ${B}/*.optee ${D}${nonarch_base_libdir}/firmware/ || true
86 install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true 90 install -m 644 ${B}/bl32.bin ${D}${nonarch_base_libdir}/firmware/ || true