diff options
author | Denys Dmytriyenko <denys@ti.com> | 2020-05-07 01:20:09 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2020-05-07 01:14:16 +0000 |
commit | 29b8f2d7ce17b085237535a9fbcb02817d065a51 (patch) | |
tree | 323d3d34306a5114e1d61b41b3f9097bae8b691b | |
parent | d0996bea80d7467be120b8efdbf81379ced1c68d (diff) | |
download | meta-ti-29b8f2d7ce17b085237535a9fbcb02817d065a51.tar.gz |
prueth-fw-am65x-sr2: add prebuilt PRU Ethernet FW for AM65x SR2.0
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb | 39 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-ti-staging_5.4.bb | 1 |
2 files changed, 40 insertions, 0 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb new file mode 100644 index 00000000..6e17c4aa --- /dev/null +++ b/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | SUMMARY = "PRU Ethernet firmware for AM65xx SR2.0" | ||
2 | |||
3 | LICENSE = "TI-TFL" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | |||
6 | PV = "2.2.0.1+2.2.0.2-rc1" | ||
7 | |||
8 | CLEANBROKEN = "1" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "am65xx-evm" | ||
11 | |||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
13 | |||
14 | SRCREV = "ea4bf53ba0a4a30bb7e0e8b6138fdb22fe50372a" | ||
15 | BRANCH ?= "ti-linux-firmware" | ||
16 | |||
17 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
18 | |||
19 | S = "${WORKDIR}/git" | ||
20 | |||
21 | TARGET = " \ | ||
22 | am65x-sr2-pru0-prueth-fw.elf \ | ||
23 | am65x-sr2-pru1-prueth-fw.elf \ | ||
24 | am65x-sr2-rtu0-prueth-fw.elf \ | ||
25 | am65x-sr2-rtu1-prueth-fw.elf \ | ||
26 | am65x-sr2-txpru0-prueth-fw.elf \ | ||
27 | am65x-sr2-txpru1-prueth-fw.elf \ | ||
28 | " | ||
29 | |||
30 | do_install() { | ||
31 | install -d ${D}${base_libdir}/firmware/ti-pruss | ||
32 | for f in ${TARGET}; do | ||
33 | install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f | ||
34 | done | ||
35 | } | ||
36 | |||
37 | FILES_${PN} = "${base_libdir}/firmware" | ||
38 | |||
39 | INSANE_SKIP_${PN} = "arch" | ||
diff --git a/recipes-kernel/linux/linux-ti-staging_5.4.bb b/recipes-kernel/linux/linux-ti-staging_5.4.bb index 9f893ccf..7144a955 100644 --- a/recipes-kernel/linux/linux-ti-staging_5.4.bb +++ b/recipes-kernel/linux/linux-ti-staging_5.4.bb | |||
@@ -50,6 +50,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw" | |||
50 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw" | 50 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw" |
51 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " prueth-fw" | 51 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_k2g = " prueth-fw" |
52 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x" | 52 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x" |
53 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2" | ||
53 | 54 | ||
54 | # Add run-time dependency for Cadence MHDP firmware to the rootfs | 55 | # Add run-time dependency for Cadence MHDP firmware to the rootfs |
55 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " cadence-mhdp-fw" | 56 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7 = " cadence-mhdp-fw" |