diff options
author | Karthik Ramanan <a0393906@ti.com> | 2017-04-25 17:26:03 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-04-27 20:18:42 -0400 |
commit | 86dd71f732026b48f0179fd6c40c933ae6421175 (patch) | |
tree | 9801b5300c93c2f536cba007e7e38ee02c3c5320 | |
parent | 9a8a93cb9002161f597bbebb5a15c5a7725a22ef (diff) | |
download | meta-ti-86dd71f732026b48f0179fd6c40c933ae6421175.tar.gz |
Remove CCS dependencies for all components
Signed-off-by: Karthik Ramanan <a0393906@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | classes/ti-pdk.bbclass | 2 | ||||
-rw-r--r-- | recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/ipumm-fw/ipumm-fw_git.bb | 2 | ||||
-rw-r--r-- | recipes-ti/ipc/ti-ipc-rtos.inc | 2 |
4 files changed, 4 insertions, 4 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass index fd7c3e7a..eca3652c 100644 --- a/classes/ti-pdk.bbclass +++ b/classes/ti-pdk.bbclass | |||
@@ -5,7 +5,7 @@ inherit perlnative | |||
5 | 5 | ||
6 | DEPENDS = "ti-xdctools ti-cg-xml-native ti-sysbios common-csl-ip-rtos libxml-simple-perl-native gcc-arm-none-eabi-native ti-cgt6x-native ti-pdk-build-rtos" | 6 | DEPENDS = "ti-xdctools ti-cg-xml-native ti-sysbios common-csl-ip-rtos libxml-simple-perl-native gcc-arm-none-eabi-native ti-cgt6x-native ti-pdk-build-rtos" |
7 | 7 | ||
8 | DEPENDS_append_omap-a15 = " ti-ccsv6-native" | 8 | DEPENDS_append_omap-a15 = " ti-cgt-arm-native" |
9 | DEPENDS_remove_ti33x = "ti-cgt6x-native" | 9 | DEPENDS_remove_ti33x = "ti-cgt6x-native" |
10 | DEPENDS_remove_ti43x = "ti-cgt6x-native" | 10 | DEPENDS_remove_ti43x = "ti-cgt6x-native" |
11 | 11 | ||
diff --git a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb index 6a01d0b8..ce9ef855 100644 --- a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb +++ b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb | |||
@@ -4,7 +4,7 @@ require recipes-ti/includes/ti-staging.inc | |||
4 | 4 | ||
5 | PR = "${INC_PR}.0" | 5 | PR = "${INC_PR}.0" |
6 | 6 | ||
7 | DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-ccsv6-native ti-cgt6x-native" | 7 | DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native" |
8 | 8 | ||
9 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone" | 9 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone" |
10 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 10 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
diff --git a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb index 9b154765..0717b55d 100644 --- a/recipes-bsp/ipumm-fw/ipumm-fw_git.bb +++ b/recipes-bsp/ipumm-fw/ipumm-fw_git.bb | |||
@@ -29,7 +29,7 @@ require recipes-ti/includes/ti-staging.inc | |||
29 | 29 | ||
30 | inherit update-alternatives | 30 | inherit update-alternatives |
31 | 31 | ||
32 | DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-ccsv6-native ti-ipc-rtos" | 32 | DEPENDS = "ti-xdctools ti-sysbios ti-codec-engine ti-framework-components ti-xdais ti-cgt-arm-native ti-ipc-rtos" |
33 | 33 | ||
34 | export HWVERSION="ES10" | 34 | export HWVERSION="ES10" |
35 | export BIOSTOOLSROOT="${STAGING_DIR_TARGET}/usr/share/ti" | 35 | export BIOSTOOLSROOT="${STAGING_DIR_TARGET}/usr/share/ti" |
diff --git a/recipes-ti/ipc/ti-ipc-rtos.inc b/recipes-ti/ipc/ti-ipc-rtos.inc index 0d7e0e6b..2a6cac07 100644 --- a/recipes-ti/ipc/ti-ipc-rtos.inc +++ b/recipes-ti/ipc/ti-ipc-rtos.inc | |||
@@ -43,7 +43,7 @@ DEPENDS_append_keystone = " ti-cgt6x-native \ | |||
43 | gcc-arm-none-eabi-native \ | 43 | gcc-arm-none-eabi-native \ |
44 | " | 44 | " |
45 | DEPENDS_append_omap-a15 = " ti-cgt6x-native \ | 45 | DEPENDS_append_omap-a15 = " ti-cgt6x-native \ |
46 | ti-ccsv6-native \ | 46 | ti-cgt-arm-native \ |
47 | gcc-arm-none-eabi-native \ | 47 | gcc-arm-none-eabi-native \ |
48 | " | 48 | " |
49 | DEPENDS_append_omapl138 = " ti-cgt6x-native \ | 49 | DEPENDS_append_omapl138 = " ti-cgt6x-native \ |