diff options
author | Vignesh Raghavedra <vigneshr@ti.com> | 2021-10-20 14:35:22 +0530 |
---|---|---|
committer | Yogesh Siraswar <yogeshs@ti.com> | 2021-10-20 10:45:08 +0000 |
commit | fafa3ed7d256a53a884a29a33b048c370e43e521 (patch) | |
tree | c97a5f0363edfd769c6fb7c17441869ffedfefc3 | |
parent | dbbec0dd00f745299bd0da06a136c4d36212ce7d (diff) | |
download | meta-ti-fafa3ed7d256a53a884a29a33b048c370e43e521.tar.gz |
prusw-fw-am65x-sr2: Add recipe for ICSSG Switch mode firmware for AM65x SR2.0
Add AM65x SR2.0 ICSSG Switch firmware. Base version is 02.02.09.06
Signed-off-by: Vignesh Raghavendra <vigneshr@ti.com>
Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
-rw-r--r-- | recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb | 34 | ||||
-rw-r--r-- | recipes-kernel/linux/kernel-rdepends.inc | 2 |
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb b/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb new file mode 100644 index 00000000..8cb450ac --- /dev/null +++ b/recipes-bsp/prusw-fw/prusw-fw-am65x-sr2_git.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "PRU Ethernet Switch firmware for AM65xx SR2.0" | ||
2 | |||
3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | ||
4 | |||
5 | PV = "${PRUETH_FW_AM65X_SR2_VERSION}" | ||
6 | PR = "${INC_PR}.0" | ||
7 | |||
8 | CLEANBROKEN = "1" | ||
9 | |||
10 | COMPATIBLE_MACHINE = "am65xx-evm" | ||
11 | |||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
13 | |||
14 | S = "${WORKDIR}/git" | ||
15 | |||
16 | TARGET = " \ | ||
17 | am65x-sr2-pru0-prusw-fw.elf \ | ||
18 | am65x-sr2-pru1-prusw-fw.elf \ | ||
19 | am65x-sr2-rtu0-prusw-fw.elf \ | ||
20 | am65x-sr2-rtu1-prusw-fw.elf \ | ||
21 | am65x-sr2-txpru0-prusw-fw.elf \ | ||
22 | am65x-sr2-txpru1-prusw-fw.elf \ | ||
23 | " | ||
24 | |||
25 | do_install() { | ||
26 | install -d ${D}${base_libdir}/firmware/ti-pruss | ||
27 | for f in ${TARGET}; do | ||
28 | install -m 0644 ${S}/ti-pruss/$f ${D}${base_libdir}/firmware/ti-pruss/$f | ||
29 | done | ||
30 | } | ||
31 | |||
32 | FILES_${PN} = "${base_libdir}/firmware" | ||
33 | |||
34 | INSANE_SKIP_${PN} = "arch" | ||
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc index 743b352c..5e5241c9 100644 --- a/recipes-kernel/linux/kernel-rdepends.inc +++ b/recipes-kernel/linux/kernel-rdepends.inc | |||
@@ -34,7 +34,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am57xx-hs-evm = " prueth-fw prusw-fw | |||
34 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw pruhsr-fw pruprp-fw" | 34 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw pruhsr-fw pruprp-fw" |
35 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw pruhsr-fw pruprp-fw" | 35 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw pruhsr-fw pruprp-fw" |
36 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x" | 36 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x" |
37 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2" | 37 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2 prusw-fw-am65x-sr2" |
38 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am64xx-evm = " prueth-fw-am65x-sr2" | 38 | RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am64xx-evm = " prueth-fw-am65x-sr2" |
39 | 39 | ||
40 | # Add run-time dependency for Cadence MHDP firmware to the rootfs | 40 | # Add run-time dependency for Cadence MHDP firmware to the rootfs |