diff options
author | Yogesh Siraswar <yogeshs@ti.com> | 2021-10-19 13:19:51 +0000 |
---|---|---|
committer | Yogesh Siraswar <yogeshs@ti.com> | 2021-10-20 10:33:40 +0000 |
commit | eb051b4a336fb25572d66d58eb6d9c2a9976b06e (patch) | |
tree | cafc55b7b2c31adced927c8e58b99f7a0b396ad4 | |
parent | 1fe4515cee979923418fdf440a9e379fcf688c79 (diff) | |
download | meta-ti-eb051b4a336fb25572d66d58eb6d9c2a9976b06e.tar.gz |
ti-linux-fw: Support common inc for all firmware
Change to support common INC for all firmware
This will help with:
1) Eliminating requirement to change multiple recipes for firmware
update
2) This will help support AUTOREV
Signed-off-by: Yogesh Siraswar <yogeshs@ti.com>
Reviewed-by: Denys Dmytriyenko <denys@konsulko.com>
-rw-r--r-- | recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb | 11 | ||||
-rw-r--r-- | recipes-bsp/goodix-fw/goodix-fw_git.bb | 11 | ||||
-rw-r--r-- | recipes-bsp/netcp-pa-fw/netcp-pa-fw_git.bb | 12 | ||||
-rw-r--r-- | recipes-bsp/netcp-sa-fw/netcp-sa-fw_git.bb | 12 | ||||
-rw-r--r-- | recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb | 11 | ||||
-rw-r--r-- | recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb | 11 | ||||
-rw-r--r-- | recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb | 10 | ||||
-rw-r--r-- | recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb | 10 | ||||
-rw-r--r-- | recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb | 10 | ||||
-rw-r--r-- | recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb | 10 | ||||
-rw-r--r-- | recipes-bsp/qmss-pdsp-fw/qmss-pdsp-fw_git.bb | 11 | ||||
-rw-r--r-- | recipes-bsp/serdes-fw/serdes-fw_git.bb | 10 | ||||
-rw-r--r-- | recipes-bsp/ti-linux-fw/ti-linux-fw.inc (renamed from recipes-bsp/ti-sci-fw/ti-sci-fw.inc) | 13 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb | 2 | ||||
-rw-r--r-- | recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | 4 | ||||
-rw-r--r-- | recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | 2 |
16 files changed, 51 insertions, 99 deletions
diff --git a/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb b/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb index 6d857f7f..5cbbceb6 100644 --- a/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb +++ b/recipes-bsp/cadence-mhdp-fw/cadence-mhdp-fw_git.bb | |||
@@ -1,10 +1,12 @@ | |||
1 | SUMMARY = "Cadence MHDP DP bridge firmware" | 1 | SUMMARY = "Cadence MHDP DP bridge firmware" |
2 | 2 | ||
3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | ||
4 | |||
3 | LICENSE = "BSD-3-Clause | Apache-2.0" | 5 | LICENSE = "BSD-3-Clause | Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENCE.cadence;md5=009f46816f6956cfb75ede13d3e1cee0" | 6 | LIC_FILES_CHKSUM = "file://LICENCE.cadence;md5=009f46816f6956cfb75ede13d3e1cee0" |
5 | 7 | ||
6 | PV = "1.2.17" | 8 | PV = "${CADENCE_MHDP_FW_VERSION}" |
7 | PR = "r0" | 9 | PR = "${INC_PR}.0" |
8 | 10 | ||
9 | CLEANBROKEN = "1" | 11 | CLEANBROKEN = "1" |
10 | 12 | ||
@@ -12,11 +14,6 @@ COMPATIBLE_MACHINE = "j7" | |||
12 | 14 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 16 | ||
15 | SRCREV = "7bad9a69a343e01056ece5ce6da4d4060c42f6bc" | ||
16 | BRANCH ?= "ti-linux-firmware" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
21 | TARGET = "mhdp8546.bin" | 18 | TARGET = "mhdp8546.bin" |
22 | 19 | ||
diff --git a/recipes-bsp/goodix-fw/goodix-fw_git.bb b/recipes-bsp/goodix-fw/goodix-fw_git.bb index 0a9f3ff9..da3ae6e3 100644 --- a/recipes-bsp/goodix-fw/goodix-fw_git.bb +++ b/recipes-bsp/goodix-fw/goodix-fw_git.bb | |||
@@ -1,10 +1,12 @@ | |||
1 | DESCRIPTION = "Goodix GT9271 config firmware" | 1 | DESCRIPTION = "Goodix GT9271 config firmware" |
2 | 2 | ||
3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | ||
4 | |||
3 | LICENSE = "BSD-3-Clause" | 5 | LICENSE = "BSD-3-Clause" |
4 | LIC_FILES_CHKSUM = "file://LICENCE.Spectrum-GT9271;md5=2a6de6be7af1fe46370c684daf27c852" | 6 | LIC_FILES_CHKSUM = "file://LICENCE.Spectrum-GT9271;md5=2a6de6be7af1fe46370c684daf27c852" |
5 | 7 | ||
6 | PV = "1.0.0.0" | 8 | PV = "${GOODIX_FW_VERSION}" |
7 | PR = "r0" | 9 | PR = "${INC_PR}.0" |
8 | 10 | ||
9 | CLEANBROKEN = "1" | 11 | CLEANBROKEN = "1" |
10 | 12 | ||
@@ -12,11 +14,6 @@ COMPATIBLE_MACHINE = "dra7xx" | |||
12 | 14 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 16 | ||
15 | SRCREV = "f1a8d1d0131f83bd1a775cde7075eb67c070892c" | ||
16 | BRANCH ?= "ti-linux-firmware" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
21 | ORIGIN = "DRA71x-RevA-GT9271_SpecDig_Config.bin" | 18 | ORIGIN = "DRA71x-RevA-GT9271_SpecDig_Config.bin" |
22 | TARGET = "goodix_9271_cfg.bin" | 19 | TARGET = "goodix_9271_cfg.bin" |
diff --git a/recipes-bsp/netcp-pa-fw/netcp-pa-fw_git.bb b/recipes-bsp/netcp-pa-fw/netcp-pa-fw_git.bb index fe7fa2b2..5d4b6d96 100644 --- a/recipes-bsp/netcp-pa-fw/netcp-pa-fw_git.bb +++ b/recipes-bsp/netcp-pa-fw/netcp-pa-fw_git.bb | |||
@@ -1,10 +1,9 @@ | |||
1 | DESCRIPTION = "NETCP PA firmware for Keystone" | 1 | DESCRIPTION = "NETCP PA firmware for Keystone" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
4 | LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c" | ||
5 | 4 | ||
6 | PV = "3.0.2.3" | 5 | PV = "${NETCP_PA_FW_VERSION}" |
7 | PR = "r1" | 6 | PR = "${INC_PR}.1" |
8 | 7 | ||
9 | CLEANBROKEN = "1" | 8 | CLEANBROKEN = "1" |
10 | 9 | ||
@@ -12,11 +11,6 @@ COMPATIBLE_MACHINE = "k2hk|k2l|k2e" | |||
12 | 11 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 12 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 13 | ||
15 | SRCREV = "953ab647b0b6af411965242ecd919b1cb0e570d6" | ||
16 | BRANCH ?= "ti-linux-firmware" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
21 | 15 | ||
22 | FWBASENAME = " \ | 16 | FWBASENAME = " \ |
diff --git a/recipes-bsp/netcp-sa-fw/netcp-sa-fw_git.bb b/recipes-bsp/netcp-sa-fw/netcp-sa-fw_git.bb index 56373a73..c4674505 100644 --- a/recipes-bsp/netcp-sa-fw/netcp-sa-fw_git.bb +++ b/recipes-bsp/netcp-sa-fw/netcp-sa-fw_git.bb | |||
@@ -1,10 +1,9 @@ | |||
1 | DESCRIPTION = "NETCP SA firmware for Keystone" | 1 | DESCRIPTION = "NETCP SA firmware for Keystone" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
4 | LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c" | ||
5 | 4 | ||
6 | PV = "1.0.0" | 5 | PV = "${NETCP_SA_FW_VERSION}" |
7 | PR = "r0" | 6 | PR = "${INC_PR}.0" |
8 | 7 | ||
9 | CLEANBROKEN = "1" | 8 | CLEANBROKEN = "1" |
10 | 9 | ||
@@ -12,11 +11,6 @@ COMPATIBLE_MACHINE = "keystone" | |||
12 | 11 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 12 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 13 | ||
15 | SRCREV = "588f602a21c62f90b1f4318b881c80a1e711317a" | ||
16 | BRANCH ?= "ti-linux-firmware" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
21 | 15 | ||
22 | TARGET = "sa_mci.fw" | 16 | TARGET = "sa_mci.fw" |
diff --git a/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb index 67e8cd07..cf65e09a 100644 --- a/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb +++ b/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb | |||
@@ -1,9 +1,9 @@ | |||
1 | SUMMARY = "PRU Ethernet firmware for AM65xx SR2.0" | 1 | SUMMARY = "PRU Ethernet firmware for AM65xx SR2.0" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | 4 | ||
6 | PV = "02.02.09.03" | 5 | PV = "${PRUETH_FW_AM65X_SR2_VERSION}" |
6 | PR = "${INC_PR}.0" | ||
7 | 7 | ||
8 | CLEANBROKEN = "1" | 8 | CLEANBROKEN = "1" |
9 | 9 | ||
@@ -11,11 +11,6 @@ COMPATIBLE_MACHINE = "am65xx-evm|am64xx-evm" | |||
11 | 11 | ||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 12 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
13 | 13 | ||
14 | SRCREV = "f3d2c7cafc906adc9a2f4543aa2fee556483545d" | ||
15 | BRANCH ?= "ti-linux-firmware" | ||
16 | |||
17 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
18 | |||
19 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
20 | 15 | ||
21 | TARGET = " \ | 16 | TARGET = " \ |
diff --git a/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb b/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb index d447df33..5e362ed9 100644 --- a/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb +++ b/recipes-bsp/prueth-fw/prueth-fw-am65x_git.bb | |||
@@ -1,9 +1,9 @@ | |||
1 | SUMMARY = "PRU Ethernet firmware for AM65x SR1.0" | 1 | SUMMARY = "PRU Ethernet firmware for AM65x SR1.0" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | 4 | ||
6 | PV = "08.00.00.20" | 5 | PV = "${PRUETH_FW_AM65X_VERSION}" |
6 | PR = "${INC_PR}.0" | ||
7 | 7 | ||
8 | CLEANBROKEN = "1" | 8 | CLEANBROKEN = "1" |
9 | 9 | ||
@@ -11,11 +11,6 @@ COMPATIBLE_MACHINE = "am65xx" | |||
11 | 11 | ||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 12 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
13 | 13 | ||
14 | SRCREV = "517b0cd8d8d80e91f1f7d80f035e6af041c39726" | ||
15 | BRANCH ?= "ti-linux-firmware" | ||
16 | |||
17 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
18 | |||
19 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
20 | 15 | ||
21 | TARGET = " \ | 16 | TARGET = " \ |
diff --git a/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb b/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb index c392673e..f7336fb1 100644 --- a/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb +++ b/recipes-bsp/prueth-fw/prueth-fw_5.6.15.bb | |||
@@ -1,9 +1,8 @@ | |||
1 | SUMMARY = "PRU Ethernet firmware for AM57xx, AM437x and AM335x" | 1 | SUMMARY = "PRU Ethernet firmware for AM57xx, AM437x and AM335x" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | 4 | ||
6 | PR = "r0" | 5 | PR = "${INC_PR}.0" |
7 | 6 | ||
8 | CLEANBROKEN = "1" | 7 | CLEANBROKEN = "1" |
9 | 8 | ||
@@ -11,11 +10,6 @@ COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm" | |||
11 | 10 | ||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 11 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
13 | 12 | ||
14 | SRCREV = "11fecaf08eeed27f2a834c9911edb8a5fb2a23b1" | ||
15 | BRANCH ?= "ti-linux-firmware" | ||
16 | |||
17 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
18 | |||
19 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
20 | 14 | ||
21 | TARGET = "" | 15 | TARGET = "" |
diff --git a/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb b/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb index 2616373e..507a500b 100644 --- a/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb +++ b/recipes-bsp/pruhsr-fw/pruhsr-fw_2.17.25.bb | |||
@@ -1,10 +1,9 @@ | |||
1 | SUMMARY = "PRU HSR firmware for AM335x/AM437x/AM57xx" | 1 | SUMMARY = "PRU HSR firmware for AM335x/AM437x/AM57xx" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | 4 | ||
6 | PE = "1" | 5 | PE = "1" |
7 | PR = "r0" | 6 | PR = "${INC_PR}.0" |
8 | 7 | ||
9 | CLEANBROKEN = "1" | 8 | CLEANBROKEN = "1" |
10 | 9 | ||
@@ -12,11 +11,6 @@ COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm" | |||
12 | 11 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 12 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 13 | ||
15 | SRCREV = "0038ff0ecda8dae83c65d454c85776c6a4ef8e63" | ||
16 | BRANCH ?= "ti-linux-firmware" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
21 | 15 | ||
22 | TARGET = "" | 16 | TARGET = "" |
diff --git a/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb b/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb index e71bc00a..ba203948 100644 --- a/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb +++ b/recipes-bsp/pruprp-fw/pruprp-fw_2.17.25.bb | |||
@@ -1,10 +1,9 @@ | |||
1 | SUMMARY = "PRU PRP firmware for AM335x/AM437x/AM57xx" | 1 | SUMMARY = "PRU PRP firmware for AM335x/AM437x/AM57xx" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | 4 | ||
6 | PE = "1" | 5 | PE = "1" |
7 | PR = "r0" | 6 | PR = "${INC_PR}.0" |
8 | 7 | ||
9 | CLEANBROKEN = "1" | 8 | CLEANBROKEN = "1" |
10 | 9 | ||
@@ -12,11 +11,6 @@ COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm" | |||
12 | 11 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 12 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 13 | ||
15 | SRCREV = "0038ff0ecda8dae83c65d454c85776c6a4ef8e63" | ||
16 | BRANCH ?= "ti-linux-firmware" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
21 | 15 | ||
22 | TARGET = "" | 16 | TARGET = "" |
diff --git a/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb b/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb index 3f5ef7e7..ec0a15f4 100644 --- a/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb +++ b/recipes-bsp/prusw-fw/prusw-fw_3.2.9.bb | |||
@@ -1,9 +1,8 @@ | |||
1 | SUMMARY = "PRU Switch firmware for AM57xx, AM437x and AM335x" | 1 | SUMMARY = "PRU Switch firmware for AM57xx, AM437x and AM335x" |
2 | 2 | ||
3 | LICENSE = "TI-TFL" | 3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | ||
5 | 4 | ||
6 | PR = "r0" | 5 | PR = "${INC_PR}.0" |
7 | 6 | ||
8 | CLEANBROKEN = "1" | 7 | CLEANBROKEN = "1" |
9 | 8 | ||
@@ -11,11 +10,6 @@ COMPATIBLE_MACHINE = "ti33x|ti43x|am57xx-evm|am57xx-hs-evm" | |||
11 | 10 | ||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 11 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
13 | 12 | ||
14 | SRCREV = "dccfb2328354be2933a5a179b528ec8a18b92d3a" | ||
15 | BRANCH ?= "ti-linux-firmware" | ||
16 | |||
17 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
18 | |||
19 | S = "${WORKDIR}/git" | 13 | S = "${WORKDIR}/git" |
20 | 14 | ||
21 | TARGET = "" | 15 | TARGET = "" |
diff --git a/recipes-bsp/qmss-pdsp-fw/qmss-pdsp-fw_git.bb b/recipes-bsp/qmss-pdsp-fw/qmss-pdsp-fw_git.bb index cd207826..4ce9a967 100644 --- a/recipes-bsp/qmss-pdsp-fw/qmss-pdsp-fw_git.bb +++ b/recipes-bsp/qmss-pdsp-fw/qmss-pdsp-fw_git.bb | |||
@@ -1,10 +1,12 @@ | |||
1 | DESCRIPTION = "QMSS PDSP firmware" | 1 | DESCRIPTION = "QMSS PDSP firmware" |
2 | 2 | ||
3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | ||
4 | |||
3 | LICENSE = "TI-TFL" | 5 | LICENSE = "TI-TFL" |
4 | LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c" | 6 | LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c" |
5 | 7 | ||
6 | PV = "1.0.0.9" | 8 | PV = "${QMSS_PDSP_FW_VERSION}" |
7 | PR = "r1" | 9 | PR = "${INC_PR}.1" |
8 | 10 | ||
9 | CLEANBROKEN = "1" | 11 | CLEANBROKEN = "1" |
10 | 12 | ||
@@ -12,11 +14,6 @@ COMPATIBLE_MACHINE = "keystone" | |||
12 | 14 | ||
13 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
14 | 16 | ||
15 | SRCREV = "778668c4bb5fe59870e549a4a2820b9f7f90e89e" | ||
16 | BRANCH ?= "ti-linux-firmware" | ||
17 | |||
18 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
19 | |||
20 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
21 | ORIGIN = "ks2_qmss_pdsp_acc48_k2_le_1_0_0_9.bin" | 18 | ORIGIN = "ks2_qmss_pdsp_acc48_k2_le_1_0_0_9.bin" |
22 | TARGET = "ks2_qmss_pdsp_acc48.bin" | 19 | TARGET = "ks2_qmss_pdsp_acc48.bin" |
diff --git a/recipes-bsp/serdes-fw/serdes-fw_git.bb b/recipes-bsp/serdes-fw/serdes-fw_git.bb index 66271788..f9685721 100644 --- a/recipes-bsp/serdes-fw/serdes-fw_git.bb +++ b/recipes-bsp/serdes-fw/serdes-fw_git.bb | |||
@@ -1,9 +1,12 @@ | |||
1 | DESCRIPTION = "SerDes firmware for Keystone PCIe and 1/10GigE" | 1 | DESCRIPTION = "SerDes firmware for Keystone PCIe and 1/10GigE" |
2 | 2 | ||
3 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc | ||
4 | |||
3 | LICENSE = "TI-TFL" | 5 | LICENSE = "TI-TFL" |
4 | LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c" | 6 | LIC_FILES_CHKSUM = "file://LICENCE.ti-keystone;md5=3a86335d32864b0bef996bee26cc0f2c" |
5 | 7 | ||
6 | PV = "3.3.0.2c" | 8 | PV = "${SERDES_FW_VERSION}" |
9 | PR = "${INC_PR}.0" | ||
7 | 10 | ||
8 | CLEANBROKEN = "1" | 11 | CLEANBROKEN = "1" |
9 | 12 | ||
@@ -11,11 +14,6 @@ COMPATIBLE_MACHINE = "keystone" | |||
11 | 14 | ||
12 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 15 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
13 | 16 | ||
14 | SRCREV = "8d861bd8f8f792df60b6873989ff208766fbebae" | ||
15 | BRANCH ?= "ti-linux-firmware" | ||
16 | |||
17 | SRC_URI = "git://git.ti.com/processor-firmware/ti-linux-firmware.git;protocol=git;branch=${BRANCH}" | ||
18 | |||
19 | S = "${WORKDIR}/git" | 17 | S = "${WORKDIR}/git" |
20 | TARGET = "ks2_pcie_serdes.bin ks2_gbe_serdes.bin ks2_xgbe_serdes.bin" | 18 | TARGET = "ks2_pcie_serdes.bin ks2_gbe_serdes.bin ks2_xgbe_serdes.bin" |
21 | 19 | ||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw.inc b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc index 9ce9f6c8..8d827bd1 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw.inc +++ b/recipes-bsp/ti-linux-fw/ti-linux-fw.inc | |||
@@ -4,9 +4,18 @@ LICENSE = "TI-TFL" | |||
4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" | 4 | LIC_FILES_CHKSUM = "file://LICENSE.ti;md5=b5aebf0668bdf95621259288c4a46d76" |
5 | 5 | ||
6 | PV = "2021.05" | 6 | PV = "2021.05" |
7 | INC_PR = "r0" | 7 | INC_PR = "r1" |
8 | # RTOS firmware version | 8 | |
9 | # Firmware versions | ||
9 | CORESDK_RTOS_VERSION = "08.00.00.32" | 10 | CORESDK_RTOS_VERSION = "08.00.00.32" |
11 | SERDES_FW_VERSION = "3.3.0.2c" | ||
12 | NETCP_SA_FW_VERSION = "1.0.0" | ||
13 | NETCP_PA_FW_VERSION = "3.0.2.3" | ||
14 | QMSS_PDSP_FW_VERSION = "1.0.0.9" | ||
15 | PRUETH_FW_AM65X_VERSION = "08.00.00.20" | ||
16 | PRUETH_FW_AM65X_SR2_VERSION = "02.02.09.03" | ||
17 | GOODIX_FW_VERSION = "1.0.0.0" | ||
18 | CADENCE_MHDP_FW_VERSION = "1.2.17" | ||
10 | 19 | ||
11 | SRCREV = "793309716bce2e443f798dd5c5f0d8dd310970c0" | 20 | SRCREV = "793309716bce2e443f798dd5c5f0d8dd310970c0" |
12 | BRANCH ?= "ti-linux-firmware" | 21 | BRANCH ?= "ti-linux-firmware" |
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb index 063e72d7..e539c84f 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw-source_git.bb | |||
@@ -2,7 +2,7 @@ | |||
2 | # Let's take a page from gcc-source as a common recipe for all gcc stages, | 2 | # Let's take a page from gcc-source as a common recipe for all gcc stages, |
3 | # but also to provide a single package for MAINMACHINE of all multiconfigs | 3 | # but also to provide a single package for MAINMACHINE of all multiconfigs |
4 | 4 | ||
5 | require recipes-bsp/ti-sci-fw/ti-sci-fw.inc | 5 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
6 | 6 | ||
7 | SUMMARY += "- sources" | 7 | SUMMARY += "- sources" |
8 | 8 | ||
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb index 87fdec68..ca56e1de 100644 --- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb +++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb | |||
@@ -1,11 +1,11 @@ | |||
1 | require recipes-bsp/ti-sci-fw/ti-sci-fw.inc | 1 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
2 | 2 | ||
3 | DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" | 3 | DEPENDS = "openssl-native u-boot-mkimage-native dtc-native" |
4 | DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader" | 4 | DEPENDS_append_j7200-evm-k3r5 = " virtual/bootloader" |
5 | DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader" | 5 | DEPENDS_append_am64xx-evm-k3r5 = " virtual/bootloader" |
6 | 6 | ||
7 | CLEANBROKEN = "1" | 7 | CLEANBROKEN = "1" |
8 | PR = "r1" | 8 | PR = "${INC_PR}.0" |
9 | 9 | ||
10 | # Loaded by R5F core | 10 | # Loaded by R5F core |
11 | COMPATIBLE_MACHINE = "k3r5" | 11 | COMPATIBLE_MACHINE = "k3r5" |
diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb index 43de1ec2..d8ac2ee0 100644 --- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb +++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb | |||
@@ -19,7 +19,7 @@ PLAT_SFX_am65xx = "am65xx" | |||
19 | PLAT_SFX_am64xx = "am64xx" | 19 | PLAT_SFX_am64xx = "am64xx" |
20 | 20 | ||
21 | FILESEXTRAPATHS_prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:" | 21 | FILESEXTRAPATHS_prepend := "${METATIBASE}/recipes-bsp/ti-sci-fw/files/:" |
22 | require recipes-bsp/ti-sci-fw/ti-sci-fw.inc | 22 | require recipes-bsp/ti-linux-fw/ti-linux-fw.inc |
23 | 23 | ||
24 | CORESDK_RTOS_VERSION ?= "08.00.00.26" | 24 | CORESDK_RTOS_VERSION ?= "08.00.00.26" |
25 | PV = "${CORESDK_RTOS_VERSION}" | 25 | PV = "${CORESDK_RTOS_VERSION}" |