diff options
author | Denys Dmytriyenko <denys@ti.com> | 2016-07-09 05:42:33 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-07-10 15:40:59 -0400 |
commit | 6b81203cf37d7e6778989bb0c3744f0d26f24ff8 (patch) | |
tree | d56b18642ecd0c6e557764c9944c8e6db48a3a15 | |
parent | a94384585b8eedcc01cb26de2a85ab2bbbd34dca (diff) | |
download | meta-ti-6b81203cf37d7e6778989bb0c3744f0d26f24ff8.tar.gz |
u-boot-ti-staging: add HS_X-LOADER images, update to ti2016.02-rc4 tag
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb | 25 |
1 files changed, 23 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb b/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb index 53510c6f..f6377de4 100644 --- a/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb +++ b/recipes-bsp/u-boot/u-boot-ti-staging_2016.05.bb | |||
@@ -7,14 +7,14 @@ DESCRIPTION = "u-boot bootloader for TI devices" | |||
7 | 7 | ||
8 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" | 8 | LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" |
9 | 9 | ||
10 | PR = "r9" | 10 | PR = "r10" |
11 | PV_append = "+git${SRCPV}" | 11 | PV_append = "+git${SRCPV}" |
12 | 12 | ||
13 | SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" | 13 | SRC_URI = "git://git.ti.com/ti-u-boot/ti-u-boot.git;protocol=git;branch=${BRANCH}" |
14 | 14 | ||
15 | BRANCH ?= "ti-u-boot-2016.05" | 15 | BRANCH ?= "ti-u-boot-2016.05" |
16 | 16 | ||
17 | SRCREV = "b43cf45fec75961d196da4563bd32c0215d2fd58" | 17 | SRCREV = "a4560200fc597109328a6454094fa77516434880" |
18 | 18 | ||
19 | # Support for secure devices - detailed info is in doc/README.ti-secure | 19 | # Support for secure devices - detailed info is in doc/README.ti-secure |
20 | TI_SECURE_DEV_PKG ?= "" | 20 | TI_SECURE_DEV_PKG ?= "" |
@@ -43,6 +43,11 @@ UBOOT_SPI_SYMLINK = "u-boot-${MACHINE}.img" | |||
43 | UBOOT_SPI_GPH_IMAGE = "u-boot-spi-${MACHINE}-${PV}-${PR}.gph" | 43 | UBOOT_SPI_GPH_IMAGE = "u-boot-spi-${MACHINE}-${PV}-${PR}.gph" |
44 | UBOOT_SPI_GPH_SYMLINK = "u-boot-spi-${MACHINE}.gph" | 44 | UBOOT_SPI_GPH_SYMLINK = "u-boot-spi-${MACHINE}.gph" |
45 | 45 | ||
46 | # HS XLD | ||
47 | UBOOT_HS_XLD_BINARY = "u-boot-spl_HS_X-LOADER" | ||
48 | UBOOT_HS_XLD_IMAGE = "u-boot-spl_HS_X-LOADER-${MACHINE}-${PV}-${PR}" | ||
49 | UBOOT_HS_XLD_SYMLINK = "u-boot-spl_HS_X-LOADER-${MACHINE}" | ||
50 | |||
46 | do_compile_append_am437x-hs-evm () { | 51 | do_compile_append_am437x-hs-evm () { |
47 | if [ -f ${S}/u-boot-spl_HS_ISSW ]; then | 52 | if [ -f ${S}/u-boot-spl_HS_ISSW ]; then |
48 | rm -rf ${S}/MLO | 53 | rm -rf ${S}/MLO |
@@ -50,6 +55,22 @@ do_compile_append_am437x-hs-evm () { | |||
50 | fi | 55 | fi |
51 | } | 56 | } |
52 | 57 | ||
58 | do_install_append () { | ||
59 | if [ -f ${S}/${UBOOT_HS_XLD_BINARY} ]; then | ||
60 | install ${S}/${UBOOT_HS_XLD_BINARY} ${D}/boot/${UBOOT_HS_XLD_IMAGE} | ||
61 | ln -sf ${UBOOT_HS_XLD_IMAGE} ${D}/boot/${UBOOT_HS_XLD_BINARY} | ||
62 | fi | ||
63 | } | ||
64 | |||
65 | do_deploy_append () { | ||
66 | if [ -f ${S}/${UBOOT_HS_XLD_BINARY} ]; then | ||
67 | install ${S}/${UBOOT_HS_XLD_BINARY} ${DEPLOYDIR}/${UBOOT_HS_XLD_IMAGE} | ||
68 | rm -f ${UBOOT_HS_XLD_BINARY} ${UBOOT_HS_XLD_SYMLINK} | ||
69 | ln -sf ${UBOOT_HS_XLD_IMAGE} ${UBOOT_HS_XLD_SYMLINK} | ||
70 | ln -sf ${UBOOT_HS_XLD_IMAGE} ${UBOOT_HS_XLD_BINARY} | ||
71 | fi | ||
72 | } | ||
73 | |||
53 | do_install_append_keystone () { | 74 | do_install_append_keystone () { |
54 | install ${S}/spl/${UBOOT_SPI_SPL_BINARY} ${D}/boot/${UBOOT_SPI_SPL_IMAGE} | 75 | install ${S}/spl/${UBOOT_SPI_SPL_BINARY} ${D}/boot/${UBOOT_SPI_SPL_IMAGE} |
55 | ln -sf ${UBOOT_SPI_SPL_IMAGE} ${D}/boot/${UBOOT_SPI_SPL_BINARY} | 76 | ln -sf ${UBOOT_SPI_SPL_IMAGE} ${D}/boot/${UBOOT_SPI_SPL_BINARY} |