diff options
author | Sam Nelson <sam.nelson@ti.com> | 2018-08-23 07:14:21 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-08-24 20:08:41 +0000 |
commit | 49ce1f2bd8f520c74048ddf8b709a01dcb452d6c (patch) | |
tree | eb29f51474b140e7fad2e27ef8839cce2580be7a | |
parent | ea70f9188883769f1b9b7ac5343c9ebb6c8f53d2 (diff) | |
download | meta-ti-49ce1f2bd8f520c74048ddf8b709a01dcb452d6c.tar.gz |
ti-pdk-build-rtos: Update to new version 1.0.0.10
Add support for am65xx-evm
Removes doxygen patch
Signed-off-by: Sam Nelson <sam.nelson@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch | 50 | ||||
-rw-r--r-- | recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb | 10 |
2 files changed, 5 insertions, 55 deletions
diff --git a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch deleted file mode 100644 index 2a10d37e..00000000 --- a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos/0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | From e5dfce58161aaee80ca45c3e992a059efac459d7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Joshua Watt <JPEWhacker@gmail.com> | ||
3 | Date: Wed, 21 Feb 2018 13:38:35 -0600 | ||
4 | Subject: [PATCH] comp_mk: Allow doxygen support to be overridden | ||
5 | |||
6 | Support for Doxygen can be globally disabled by setting the | ||
7 | DOXYGEN_SUPPORT environment variable to "no" | ||
8 | |||
9 | Signed-off-by: Joshua Watt <JPEWhacker@gmail.com> | ||
10 | --- | ||
11 | comp_top.mk | 9 +++++++-- | ||
12 | 1 file changed, 7 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/comp_top.mk b/comp_top.mk | ||
15 | index 28700ba..e331132 100644 | ||
16 | --- a/comp_top.mk | ||
17 | +++ b/comp_top.mk | ||
18 | @@ -114,6 +114,11 @@ comp_FIRM_LIST_CLEAN = $(addsuffix _clean, $($(COMP)_FIRM_LIST)) | ||
19 | comp_PKG_LIST_ALL_CLEAN = $(addsuffix _clean, $(comp_PKG_LIST_ALL)) | ||
20 | comp_PKG_LIST_PACKAGE = $(addsuffix _package, $(comp_PKG_LIST_ALL)) | ||
21 | |||
22 | +# If the component enables doxygen, this will evaluate to "yesyes" and doxygen | ||
23 | +# will be built. If this value is overridden by the user to any other value, or | ||
24 | +# $(COMP)_DOXYGEN_SUPPORT is not "yes", doxygen is not built. | ||
25 | +DOXYGEN_SUPPORT ?= yes$($(COMP)_DOXYGEN_SUPPORT) | ||
26 | + | ||
27 | .PHONY : apps appcores app_clean clean_appcores \ | ||
28 | lib libcores lib_allendians lib_clean clean_libcores clean_lib_allendians \ | ||
29 | all comp_libs comp_libs_clean examples examples_clean clean package $(comp_PKG_LIST_ALL) \ | ||
30 | @@ -230,7 +235,7 @@ xdc_meta_clean: | ||
31 | $(XDC) clean XDCBUILDCFG=config_mk.bld | ||
32 | |||
33 | doxygen: | ||
34 | -ifeq ($($(COMP)_DOXYGEN_SUPPORT),yes) | ||
35 | +ifeq ($(DOXYGEN_SUPPORT),yesyes) | ||
36 | $(ECHO) Creating Doxygen API guide ... | ||
37 | @doxygen docs/Doxyfile | ||
38 | else | ||
39 | @@ -238,7 +243,7 @@ else | ||
40 | endif | ||
41 | |||
42 | clean_doxygen: | ||
43 | -ifeq ($($(COMP)_DOXYGEN_SUPPORT),yes) | ||
44 | +ifeq ($(DOXYGEN_SUPPORT),yesyes) | ||
45 | $(ECHO) cleaned Doxygen API guide ... | ||
46 | $(RM) -rf docs/doxygen | ||
47 | else | ||
48 | -- | ||
49 | 2.14.3 | ||
50 | |||
diff --git a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb index c838d715..2ca4bc38 100644 --- a/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb +++ b/recipes-ti/ti-pdk-build/ti-pdk-build-rtos_git.bb | |||
@@ -4,25 +4,24 @@ LIC_FILES_CHKSUM = "file://makerules/env.mk;beginline=1;endline=31;md5=10503e8de | |||
4 | 4 | ||
5 | require recipes-ti/includes/ti-paths.inc | 5 | require recipes-ti/includes/ti-paths.inc |
6 | 6 | ||
7 | PV = "01.00.00.09A" | 7 | PV = "01.00.00.10" |
8 | PR = "r0" | 8 | PR = "r0" |
9 | 9 | ||
10 | PDK_BUILD_GIT_URI = "git://git.ti.com/keystone-rtos/processor-pdk-build.git" | 10 | PDK_BUILD_GIT_URI = "git://git.ti.com/keystone-rtos/processor-pdk-build.git" |
11 | PDK_BUILD_GIT_PROTOCOL = "git" | 11 | PDK_BUILD_GIT_PROTOCOL = "git" |
12 | PDK_BUILD_GIT_BRANCH = "master" | 12 | PDK_BUILD_GIT_BRANCH = "master" |
13 | 13 | ||
14 | # Below Commit ID corresponds to "DEV.PDK_BUILD.01.00.00.09A" | 14 | # Below Commit ID corresponds to "DEV.PDK_BUILD.01.00.00.10" |
15 | PDK_BUILD_SRCREV = "4870d6cfcab92dfedae8ed28054fdc61169e28b1" | 15 | PDK_BUILD_SRCREV = "f06835474e51a5fd63cf23bab0d2f42b0f73f19d" |
16 | 16 | ||
17 | BRANCH = "${PDK_BUILD_GIT_BRANCH}" | 17 | BRANCH = "${PDK_BUILD_GIT_BRANCH}" |
18 | SRC_URI = "\ | 18 | SRC_URI = "\ |
19 | ${PDK_BUILD_GIT_URI};protocol=${PDK_BUILD_GIT_PROTOCOL};branch=${BRANCH} \ | 19 | ${PDK_BUILD_GIT_URI};protocol=${PDK_BUILD_GIT_PROTOCOL};branch=${BRANCH} \ |
20 | file://0001-comp_mk-Allow-doxygen-support-to-be-overridden.patch \ | ||
21 | " | 20 | " |
22 | 21 | ||
23 | SRCREV = "${PDK_BUILD_SRCREV}" | 22 | SRCREV = "${PDK_BUILD_SRCREV}" |
24 | 23 | ||
25 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1|c66x" | 24 | COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|keystone|omapl1|c66x|k3" |
26 | PACKAGE_ARCH = "${MACHINE_ARCH}" | 25 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
27 | 26 | ||
28 | S = "${WORKDIR}/git/" | 27 | S = "${WORKDIR}/git/" |
@@ -41,3 +40,4 @@ do_install() { | |||
41 | } | 40 | } |
42 | 41 | ||
43 | FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages/*" | 42 | FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages/*" |
43 | INSANE_SKIP_${PN} += " file-rdeps" | ||