summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-08-05 17:12:47 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-08-05 17:12:47 +0200
commit3ca3c5e07a1f78c524942a4dc184d9d30fecae64 (patch)
tree9aced6a6937cc300f1f1e6d896be8bc09ce814e3
parent25595ea937fecccfbc83a5a22e2fe9955d753db1 (diff)
downloadmeta-ti-3ca3c5e07a1f78c524942a4dc184d9d30fecae64.tar.gz
linux-3.1rc: update to latest SRCREV
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--recipes-kernel/linux/linux-3.0+3.1rc/fixes/vout.patch79
-rw-r--r--recipes-kernel/linux/linux_3.1.bb5
2 files changed, 82 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-3.0+3.1rc/fixes/vout.patch b/recipes-kernel/linux/linux-3.0+3.1rc/fixes/vout.patch
new file mode 100644
index 00000000..5a145401
--- /dev/null
+++ b/recipes-kernel/linux/linux-3.0+3.1rc/fixes/vout.patch
@@ -0,0 +1,79 @@
1Delivered-To: koen@dominion.thruhere.net
2Received: by 10.236.157.72 with SMTP id n48cs4581yhk;
3 Fri, 5 Aug 2011 00:10:45 -0700 (PDT)
4Received: by 10.147.146.12 with SMTP id y12mr1585882yan.12.1312528245335;
5 Fri, 05 Aug 2011 00:10:45 -0700 (PDT)
6Return-Path: <archit@ti.com>
7Received: from bear.ext.ti.com (bear.ext.ti.com [192.94.94.41])
8 by mx.google.com with ESMTPS id x20si3422127ani.205.2011.08.05.00.10.45
9 (version=TLSv1/SSLv3 cipher=OTHER);
10 Fri, 05 Aug 2011 00:10:45 -0700 (PDT)
11Received-SPF: pass (google.com: domain of archit@ti.com designates 192.94.94.41 as permitted sender) client-ip=192.94.94.41;
12Authentication-Results: mx.google.com; spf=pass (google.com: domain of archit@ti.com designates 192.94.94.41 as permitted sender) smtp.mail=archit@ti.com
13Received: from dlep33.itg.ti.com ([157.170.170.112])
14 by bear.ext.ti.com (8.13.7/8.13.7) with ESMTP id p757AiHb023389
15 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-SHA bits=256 verify=NO);
16 Fri, 5 Aug 2011 02:10:44 -0500
17Received: from dlep26.itg.ti.com (smtp-le.itg.ti.com [157.170.170.27])
18 by dlep33.itg.ti.com (8.13.7/8.13.8) with ESMTP id p757AiWp004418;
19 Fri, 5 Aug 2011 02:10:44 -0500 (CDT)
20Received: from dlee73.ent.ti.com (localhost [127.0.0.1])
21 by dlep26.itg.ti.com (8.13.8/8.13.8) with ESMTP id p757AiBJ012377;
22 Fri, 5 Aug 2011 02:10:44 -0500 (CDT)
23Received: from dlelxv23.itg.ti.com (172.17.1.198) by DLEE73.ent.ti.com
24 (157.170.170.88) with Microsoft SMTP Server id 8.3.106.1; Fri, 5 Aug 2011
25 02:10:44 -0500
26Received: from legion.dal.design.ti.com (legion.dal.design.ti.com
27 [128.247.22.53]) by dlelxv23.itg.ti.com (8.13.8/8.13.8) with ESMTP id
28 p757Ai9V018852; Fri, 5 Aug 2011 02:10:44 -0500
29Received: from localhost (a0393947pc.apr.dhcp.ti.com [172.24.137.144]) by
30 legion.dal.design.ti.com (8.11.7p1+Sun/8.11.7) with ESMTP id p757Aef10060;
31 Fri, 5 Aug 2011 02:10:41 -0500 (CDT)
32From: Archit Taneja <archit@ti.com>
33To: <hvaibhav@ti.com>, <linux-media@vger.kernel.org>
34CC: <koen@dominion.thruhere.net>, <tomi.valkeinen@ti.com>,
35 <linux-omap@vger.kernel.org>, Archit Taneja <archit@ti.com>
36Subject: [PATCH] [media] OMAP_VOUT: Fix build break caused by update_mode removal in DSS2
37Date: Fri, 5 Aug 2011 12:49:21 +0530
38Message-ID: <1312528761-18241-1-git-send-email-archit@ti.com>
39X-Mailer: git-send-email 1.7.1
40MIME-Version: 1.0
41Content-Type: text/plain
42
43The DSS2 driver does not support the configuration of the update_mode of a
44panel anymore. Remove the setting of update_mode done in omap_vout_probe().
45Ignore configuration of TE since omap_vout driver doesn't support manual update
46displays anyway.
47
48Signed-off-by: Archit Taneja <archit@ti.com>
49---
50 drivers/media/video/omap/omap_vout.c | 13 -------------
51 1 files changed, 0 insertions(+), 13 deletions(-)
52
53diff --git a/drivers/media/video/omap/omap_vout.c b/drivers/media/video/omap/omap_vout.c
54index b5ef362..b3a5ecd 100644
55--- a/drivers/media/video/omap/omap_vout.c
56+++ b/drivers/media/video/omap/omap_vout.c
57@@ -2194,19 +2194,6 @@ static int __init omap_vout_probe(struct platform_device *pdev)
58 "'%s' Display already enabled\n",
59 def_display->name);
60 }
61- /* set the update mode */
62- if (def_display->caps &
63- OMAP_DSS_DISPLAY_CAP_MANUAL_UPDATE) {
64- if (dssdrv->enable_te)
65- dssdrv->enable_te(def_display, 0);
66- if (dssdrv->set_update_mode)
67- dssdrv->set_update_mode(def_display,
68- OMAP_DSS_UPDATE_MANUAL);
69- } else {
70- if (dssdrv->set_update_mode)
71- dssdrv->set_update_mode(def_display,
72- OMAP_DSS_UPDATE_AUTO);
73- }
74 }
75 }
76
77--
781.7.1
79
diff --git a/recipes-kernel/linux/linux_3.1.bb b/recipes-kernel/linux/linux_3.1.bb
index d69de904..ca6de373 100644
--- a/recipes-kernel/linux/linux_3.1.bb
+++ b/recipes-kernel/linux/linux_3.1.bb
@@ -6,10 +6,10 @@ KERNEL_IMAGETYPE = "uImage"
6DEFAULT_PREFERENCE = "-99" 6DEFAULT_PREFERENCE = "-99"
7 7
8PV = "3.0+3.1rc" 8PV = "3.0+3.1rc"
9SRCREV_pn-${PN} = "95b6886526bb510b8370b625a49bc0ab3b8ff10f" 9SRCREV_pn-${PN} = "140d0b2108faebc77c6523296e211e509cb9f5f9"
10 10
11# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc 11# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
12MACHINE_KERNEL_PR_append = "h" 12MACHINE_KERNEL_PR_append = "a"
13 13
14SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git \ 14SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;protocol=git \
15 file://beagle/0001-UNFINISHED-OMAP3-beagle-add-support-for-expansionboa.patch \ 15 file://beagle/0001-UNFINISHED-OMAP3-beagle-add-support-for-expansionboa.patch \
@@ -18,6 +18,7 @@ SRC_URI += "git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git;pro
18 file://madc/0001-Enabling-Hwmon-driver-for-twl4030-madc.patch \ 18 file://madc/0001-Enabling-Hwmon-driver-for-twl4030-madc.patch \
19 file://madc/0002-mfd-twl-core-enable-madc-clock.patch \ 19 file://madc/0002-mfd-twl-core-enable-madc-clock.patch \
20 file://sgx/0001-ARM-L2-Add-and-export-outer_clean_all.patch \ 20 file://sgx/0001-ARM-L2-Add-and-export-outer_clean_all.patch \
21 file://fixes/vout.patch \
21 file://defconfig" 22 file://defconfig"
22 23
23SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \ 24SRC_URI_append_beagleboard = " file://logo_linux_clut224.ppm \