diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-18 21:31:27 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-10-18 21:31:27 +0200 |
commit | 851dca2023950cc92ba0892aa23a315e465a52ef (patch) | |
tree | 6ecacd56255293e828323e27970a16e0c8a68389 | |
parent | 5bea125f60d7864d7294313f11f8adacb15490d4 (diff) | |
download | meta-ti-851dca2023950cc92ba0892aa23a315e465a52ef.tar.gz |
linux-ti335x-psp 3.1rc8: add proper machine ID for beaglebone
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
5 files changed, 108 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0001-mach-types-Add-new-machine-type-beaglebone-to-mach-t.patch b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0001-mach-types-Add-new-machine-type-beaglebone-to-mach-t.patch new file mode 100644 index 00000000..923272cd --- /dev/null +++ b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0001-mach-types-Add-new-machine-type-beaglebone-to-mach-t.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | From fff15650c35829def3e07712486850c0947ed255 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 18 Oct 2011 19:27:24 +0200 | ||
4 | Subject: [PATCH 1/3] mach-types: Add new machine type beaglebone to mach-types | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | arch/arm/tools/mach-types | 1 + | ||
9 | 1 files changed, 1 insertions(+), 0 deletions(-) | ||
10 | |||
11 | diff --git a/arch/arm/tools/mach-types b/arch/arm/tools/mach-types | ||
12 | index a0743e1..971612d 100644 | ||
13 | --- a/arch/arm/tools/mach-types | ||
14 | +++ b/arch/arm/tools/mach-types | ||
15 | @@ -1115,3 +1115,4 @@ ubisys_p9d_evp MACH_UBISYS_P9D_EVP UBISYS_P9D_EVP 3493 | ||
16 | atdgp318 MACH_ATDGP318 ATDGP318 3494 | ||
17 | am335xevm MACH_AM335XEVM AM335XEVM 3589 | ||
18 | am335xiaevm MACH_AM335XIAEVM AM335XIAEVM 3684 | ||
19 | +beaglebone MACH_BEAGLEBONE BEAGLEBONE 3808 | ||
20 | -- | ||
21 | 1.6.6.1 | ||
22 | |||
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0002-Kconfig-Add-support-for-beaglebone-machine-id.patch b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0002-Kconfig-Add-support-for-beaglebone-machine-id.patch new file mode 100644 index 00000000..6f0f1455 --- /dev/null +++ b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0002-Kconfig-Add-support-for-beaglebone-machine-id.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 205b782fbc826983ea274dd55642cd6888f1c3df Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 18 Oct 2011 19:30:05 +0200 | ||
4 | Subject: [PATCH 2/3] Kconfig: Add support for beaglebone machine id. | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | --- | ||
8 | arch/arm/mach-omap2/Kconfig | 5 +++++ | ||
9 | 1 files changed, 5 insertions(+), 0 deletions(-) | ||
10 | |||
11 | diff --git a/arch/arm/mach-omap2/Kconfig b/arch/arm/mach-omap2/Kconfig | ||
12 | index b0e1709..9be2982 100644 | ||
13 | --- a/arch/arm/mach-omap2/Kconfig | ||
14 | +++ b/arch/arm/mach-omap2/Kconfig | ||
15 | @@ -331,6 +331,11 @@ config MACH_AM335XIAEVM | ||
16 | depends on SOC_OMAPAM33XX | ||
17 | default y | ||
18 | |||
19 | +config MACH_BEAGLEBONE | ||
20 | + bool "AM335x BeagleBone, the most awesome AM335x board" | ||
21 | + depends on SOC_OMAPAM33XX | ||
22 | + default y | ||
23 | + | ||
24 | config MACH_OMAP_4430SDP | ||
25 | bool "OMAP 4430 SDP board" | ||
26 | default y | ||
27 | -- | ||
28 | 1.6.6.1 | ||
29 | |||
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0003-am335xevm-Use-new-beaglebone-machine-id.patch b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0003-am335xevm-Use-new-beaglebone-machine-id.patch new file mode 100644 index 00000000..91c37b4e --- /dev/null +++ b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/0003-am335xevm-Use-new-beaglebone-machine-id.patch | |||
@@ -0,0 +1,52 @@ | |||
1 | From 66bec8f45fa501f5cb06f760b62882f43c7cfebd Mon Sep 17 00:00:00 2001 | ||
2 | From: Steve Kipisz <s-kipisz2@ti.com> | ||
3 | Date: Thu, 13 Oct 2011 17:08:37 -0500 | ||
4 | Subject: [PATCH 3/3] am335xevm: Use new beaglebone machine id. | ||
5 | |||
6 | Signed-off-by: Steve Kipisz <s-kipisz2@ti.com> | ||
7 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
8 | --- | ||
9 | arch/arm/mach-omap2/board-am335xevm.c | 23 +++++++++++++++++++++++ | ||
10 | 1 files changed, 23 insertions(+), 0 deletions(-) | ||
11 | |||
12 | diff --git a/arch/arm/mach-omap2/board-am335xevm.c b/arch/arm/mach-omap2/board-am335xevm.c | ||
13 | index 572cb87..e363c80 100644 | ||
14 | --- a/arch/arm/mach-omap2/board-am335xevm.c | ||
15 | +++ b/arch/arm/mach-omap2/board-am335xevm.c | ||
16 | @@ -1242,6 +1242,19 @@ static void am335x_evm_setup(struct memory_accessor *mem_acc, void *context) | ||
17 | int ret; | ||
18 | char tmp[10]; | ||
19 | |||
20 | + /* Eventually when we have device tree support, u-boot will | ||
21 | + * read the EEPROMs and pass flattened device trees to the | ||
22 | + * kernel. For beaglebone, u-boot will read the EEPROM and | ||
23 | + * pass the machine type to the kernel. | ||
24 | + */ | ||
25 | + if (machine_is_beaglebone()) { | ||
26 | + pr_info("Board name: AM335BONE\n"); | ||
27 | + daughter_brd_detected = false; | ||
28 | + setup_beaglebone(); | ||
29 | + am33xx_cpsw_init(); | ||
30 | + return; | ||
31 | + } | ||
32 | + | ||
33 | /* get board specific data */ | ||
34 | ret = mem_acc->read(mem_acc, (char *)&config, 0, sizeof(config)); | ||
35 | if (ret != sizeof(config)) { | ||
36 | @@ -1523,3 +1536,13 @@ MACHINE_START(AM335XIAEVM, "am335xiaevm") | ||
37 | .timer = &omap3_am33xx_timer, | ||
38 | .init_machine = am335x_evm_init, | ||
39 | MACHINE_END | ||
40 | + | ||
41 | +MACHINE_START(BEAGLEBONE, "beaglebone") | ||
42 | + /* Maintainer: Texas Instruments */ | ||
43 | + .atag_offset = 0x100, | ||
44 | + .map_io = am335x_evm_map_io, | ||
45 | + .init_irq = ti816x_init_irq, | ||
46 | + .init_early = am335x_init_early, | ||
47 | + .timer = &omap3_am33xx_timer, | ||
48 | + .init_machine = am335x_evm_init, | ||
49 | +MACHINE_END | ||
50 | -- | ||
51 | 1.6.6.1 | ||
52 | |||
diff --git a/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig index 68318650..dcee8500 100644 --- a/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig +++ b/recipes-kernel/linux/linux-ti33x-psp-3.0+3.1rc/beaglebone/defconfig | |||
@@ -345,6 +345,7 @@ CONFIG_MACH_IGEP0020=y | |||
345 | CONFIG_MACH_TI8168EVM=y | 345 | CONFIG_MACH_TI8168EVM=y |
346 | CONFIG_MACH_AM335XEVM=y | 346 | CONFIG_MACH_AM335XEVM=y |
347 | CONFIG_MACH_AM335XIAEVM=y | 347 | CONFIG_MACH_AM335XIAEVM=y |
348 | CONFIG_MACH_BEAGLEBONE=y | ||
348 | # CONFIG_OMAP3_EMU is not set | 349 | # CONFIG_OMAP3_EMU is not set |
349 | # CONFIG_OMAP3_SDRC_AC_TIMING is not set | 350 | # CONFIG_OMAP3_SDRC_AC_TIMING is not set |
350 | CONFIG_OMAP3_EDMA=y | 351 | CONFIG_OMAP3_EDMA=y |
diff --git a/recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb b/recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb index 1526615c..b89fbc59 100644 --- a/recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb +++ b/recipes-kernel/linux/linux-ti33x-psp_3.0+3.1rc.bb | |||
@@ -11,7 +11,7 @@ MULTI_CONFIG_BASE_SUFFIX = "" | |||
11 | 11 | ||
12 | BRANCH = "master" | 12 | BRANCH = "master" |
13 | SRCREV = "10a9c95f6713ce4f7db7088443676808ca79a851" | 13 | SRCREV = "10a9c95f6713ce4f7db7088443676808ca79a851" |
14 | MACHINE_KERNEL_PR_append = "b+gitr${SRCREV}" | 14 | MACHINE_KERNEL_PR_append = "c+gitr${SRCREV}" |
15 | 15 | ||
16 | COMPATIBLE_MACHINE = "(ti33x)" | 16 | COMPATIBLE_MACHINE = "(ti33x)" |
17 | 17 | ||
@@ -27,6 +27,9 @@ SRC_URI += "git://arago-project.org/git/projects/linux-am33x.git;protocol=git;br | |||
27 | PATCHES_OVER_PSP = " \ | 27 | PATCHES_OVER_PSP = " \ |
28 | file://0001-f_rndis-HACK-around-undefined-variables.patch \ | 28 | file://0001-f_rndis-HACK-around-undefined-variables.patch \ |
29 | file://0001-am335x-evm-hack-in-LED-support-for-beaglebone.patch \ | 29 | file://0001-am335x-evm-hack-in-LED-support-for-beaglebone.patch \ |
30 | file://0001-mach-types-Add-new-machine-type-beaglebone-to-mach-t.patch \ | ||
31 | file://0002-Kconfig-Add-support-for-beaglebone-machine-id.patch \ | ||
32 | file://0003-am335xevm-Use-new-beaglebone-machine-id.patch \ | ||
30 | " | 33 | " |
31 | 34 | ||
32 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}" | 35 | SRC_URI += "${@base_contains('DISTRO_FEATURES', 'tipspkernel', "", "${PATCHES_OVER_PSP}", d)}" |