summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJayesh Choudhary <j-choudhary@ti.com>2022-06-07 16:05:26 +0530
committerRyan Eatmon <reatmon@ti.com>2022-06-15 13:47:15 -0500
commitb5a092b49e59ded26055f39b7e849690f11f22eb (patch)
tree54f823d725b8bad79f24fd533cbea5eb7fd30b85
parentb20073dcb275698b47ad5e1f6ea2a16016f96118 (diff)
downloadmeta-ti-b5a092b49e59ded26055f39b7e849690f11f22eb.tar.gz
ti-rtos-firmware: Add j721s2 hs support
Sign the DM firmware for j721s2 similar to j7200 hs. Duplicate all j721s2 entries for j721s2-hs as we cannot use same keyword for match between j721s2-evm and j721s2-hs-evm. Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
index 0f2ba9af..19ea93f1 100644
--- a/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
+++ b/recipes-ti/ti-rtos-bin/ti-rtos-firmware.bb
@@ -17,6 +17,7 @@ PLAT_SFX_j7 = "j721e"
17PLAT_SFX_j7200-evm = "j7200" 17PLAT_SFX_j7200-evm = "j7200"
18PLAT_SFX_j7200-hs-evm = "j7200" 18PLAT_SFX_j7200-hs-evm = "j7200"
19PLAT_SFX_j721s2-evm = "j721s2" 19PLAT_SFX_j721s2-evm = "j721s2"
20PLAT_SFX_j721s2-hs-evm = "j721s2"
20PLAT_SFX_am65xx = "am65xx" 21PLAT_SFX_am65xx = "am65xx"
21PLAT_SFX_am64xx = "am64xx" 22PLAT_SFX_am64xx = "am64xx"
22PLAT_SFX_am62xx = "am62xx" 23PLAT_SFX_am62xx = "am62xx"
@@ -67,6 +68,15 @@ do_install_prepend_j7200-hs-evm() {
67 ) 68 )
68} 69}
69 70
71# J7 HS support
72do_install_prepend_j721s2-hs-evm() {
73 export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG}
74 ( cd ${RTOS_DM_FW_DIR}; \
75 mv ${DM_FIRMWARE} ${DM_FIRMWARE}.unsigned; \
76 ${TI_SECURE_DEV_PKG}/scripts/secure-binary-image.sh ${DM_FIRMWARE}.unsigned ${DM_FIRMWARE}; \
77 )
78}
79
70# Update the am64xx ipc binaries to be consistent with other platforms 80# Update the am64xx ipc binaries to be consistent with other platforms
71do_install_prepend_am64xx() { 81do_install_prepend_am64xx() {
72 ( cd ${RTOS_IPC_FW_DIR}; \ 82 ( cd ${RTOS_IPC_FW_DIR}; \
@@ -147,6 +157,22 @@ do_install_j721s2-evm() {
147 # install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR} 157 # install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR}
148} 158}
149 159
160do_install_j721s2-hs-evm() {
161 install -d ${LEGACY_IPC_FW_DIR}
162 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
163 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
164 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu2_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
165 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu3_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
166 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu3_1_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
167 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_1_release_strip.xe71 ${LEGACY_IPC_FW_DIR}
168 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_c7x_2_release_strip.xe71 ${LEGACY_IPC_FW_DIR}
169 # DM Firmware
170 install -m 0644 ${RTOS_DM_FW_DIR}/ipc_echo_testb_mcu1_0_release_strip.xer5f ${LEGACY_DM_FW_DIR}
171 # ETH firmware
172 # install -d ${LEGACY_ETH_FW_DIR}
173 # install -m 0644 ${RTOS_ETH_FW_DIR}/app_remoteswitchcfg_server_strip.xer5f ${LEGACY_ETH_FW_DIR}
174}
175
150do_install_am65xx() { 176do_install_am65xx() {
151 install -d ${LEGACY_IPC_FW_DIR} 177 install -d ${LEGACY_IPC_FW_DIR}
152 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR} 178 install -m 0644 ${RTOS_IPC_FW_DIR}/ipc_echo_test_mcu1_0_release_strip.xer5f ${LEGACY_IPC_FW_DIR}
@@ -234,6 +260,17 @@ ALTERNATIVE_${PN}_j721s2-evm = "\
234 j721s2-c71_1-fw \ 260 j721s2-c71_1-fw \
235 " 261 "
236 262
263ALTERNATIVE_${PN}_j721s2-hs-evm = "\
264 j721s2-mcu-r5f0_0-fw \
265 j721s2-mcu-r5f0_1-fw \
266 j721s2-main-r5f0_0-fw \
267 j721s2-main-r5f0_1-fw \
268 j721s2-main-r5f1_0-fw \
269 j721s2-main-r5f1_1-fw \
270 j721s2-c71_0-fw \
271 j721s2-c71_1-fw \
272 "
273
237# Set up link names for the firmwares 274# Set up link names for the firmwares
238 275
239TARGET_MCU_R5FSS0_0_am65xx = "am65x-mcu-r5f0_0-fw" 276TARGET_MCU_R5FSS0_0_am65xx = "am65x-mcu-r5f0_0-fw"
@@ -277,6 +314,15 @@ TARGET_MAIN_R5FSS1_1_j721s2-evm = "j721s2-main-r5f1_1-fw"
277TARGET_C7X_0_j721s2-evm = "j721s2-c71_0-fw" 314TARGET_C7X_0_j721s2-evm = "j721s2-c71_0-fw"
278TARGET_C7X_1_j721s2-evm = "j721s2-c71_1-fw" 315TARGET_C7X_1_j721s2-evm = "j721s2-c71_1-fw"
279 316
317TARGET_MCU_R5FSS0_0_j721s2-hs-evm = "j721s2-mcu-r5f0_0-fw"
318TARGET_MCU_R5FSS0_1_j721s2-hs-evm = "j721s2-mcu-r5f0_1-fw"
319TARGET_MAIN_R5FSS0_0_j721s2-hs-evm = "j721s2-main-r5f0_0-fw"
320TARGET_MAIN_R5FSS0_1_j721s2-hs-evm = "j721s2-main-r5f0_1-fw"
321TARGET_MAIN_R5FSS1_0_j721s2-hs-evm = "j721s2-main-r5f1_0-fw"
322TARGET_MAIN_R5FSS1_1_j721s2-hs-evm = "j721s2-main-r5f1_1-fw"
323TARGET_C7X_0_j721s2-hs-evm = "j721s2-c71_0-fw"
324TARGET_C7X_1_j721s2-hs-evm = "j721s2-c71_1-fw"
325
280ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_0}" 326ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_0-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_0}"
281ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_1}" 327ALTERNATIVE_LINK_NAME[am65x-mcu-r5f0_1-fw] = "${base_libdir}/firmware/${TARGET_MCU_R5FSS0_1}"
282 328