summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-08-11 20:41:28 -0500
committerRyan Eatmon <reatmon@ti.com>2022-08-26 14:33:15 -0500
commitdbc88f2d652a08d3f0f9dbb24b7f693dec6f7f2a (patch)
tree16dc07935f2b8c86f1e9c1e8209e8a116f7b24ca
parentb74211a771a489c9e38ad38453e584a0797521d8 (diff)
downloadmeta-ti-dbc88f2d652a08d3f0f9dbb24b7f693dec6f7f2a.tar.gz
conf: machine: am64xx-evm: Make HS-SE the default
The HS-SE AM64xx machine can now be run on GP devices and built without needing the TI_SECURE_DEV_PKG for the same. AM64xx will only be available in the HS-FS type going forward. Make the HS-SE the default and remove the original GP machine. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--conf/machine/am64xx-evm-k3r5-gp.conf (renamed from conf/machine/am64xx-hs-evm-k3r5-gp.conf)6
-rw-r--r--conf/machine/am64xx-evm-k3r5-hs-se.conf14
-rw-r--r--conf/machine/am64xx-evm-k3r5.conf11
-rw-r--r--conf/machine/am64xx-evm.conf6
-rw-r--r--conf/machine/am64xx-hs-evm-k3r5.conf12
-rw-r--r--conf/machine/am64xx-hs-evm.conf25
-rw-r--r--conf/machine/include/am64xx.inc5
-rw-r--r--conf/multiconfig/k3r5-hs-se.conf3
-rw-r--r--recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend2
-rw-r--r--recipes-security/optee/optee-os_%.bbappend2
10 files changed, 33 insertions, 53 deletions
diff --git a/conf/machine/am64xx-hs-evm-k3r5-gp.conf b/conf/machine/am64xx-evm-k3r5-gp.conf
index b255dca8..c599ee47 100644
--- a/conf/machine/am64xx-hs-evm-k3r5-gp.conf
+++ b/conf/machine/am64xx-evm-k3r5-gp.conf
@@ -4,12 +4,16 @@
4 4
5# Booting GP requires different SYSFW, the rest is handled at runtime 5# Booting GP requires different SYSFW, the rest is handled at runtime
6 6
7require conf/machine/am64xx-hs-evm-k3r5.conf 7require conf/machine/include/k3r5.inc
8SOC_FAMILY_append = ":k3r5-gp" 8SOC_FAMILY_append = ":k3r5-gp"
9 9
10SYSFW_SOC = "am64x"
11SYSFW_CONFIG = "evm"
10SYSFW_SUFFIX = "gp" 12SYSFW_SUFFIX = "gp"
11SYSFW_TIBOOT3_SYMLINK = "" 13SYSFW_TIBOOT3_SYMLINK = ""
12 14
15UBOOT_MACHINE = "am64x_evm_r5_defconfig"
16
13SPL_BINARY = "" 17SPL_BINARY = ""
14UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}" 18UBOOT_BINARY = "u-boot-spl.${UBOOT_SUFFIX}"
15UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}" 19UBOOT_IMAGE = "u-boot-r5spl-gp-${MAINMACHINE}-${PV}-${PR}.${UBOOT_SUFFIX}"
diff --git a/conf/machine/am64xx-evm-k3r5-hs-se.conf b/conf/machine/am64xx-evm-k3r5-hs-se.conf
new file mode 100644
index 00000000..7cab7d15
--- /dev/null
+++ b/conf/machine/am64xx-evm-k3r5-hs-se.conf
@@ -0,0 +1,14 @@
1#@TYPE: Machine
2#@NAME: AM64xx HS-SE EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM64xx HS-SE EVM (R5F core)
4
5# Booting HS-SE requires different SYSFW, the rest is handled at runtime
6
7require conf/machine/include/k3r5.inc
8SOC_FAMILY_append = ":k3r5-hs-se"
9
10SYSFW_SOC = "am64x"
11SYSFW_CONFIG = "evm"
12SYSFW_SUFFIX = "hs"
13
14UBOOT_MACHINE = "am64x_evm_r5_defconfig"
diff --git a/conf/machine/am64xx-evm-k3r5.conf b/conf/machine/am64xx-evm-k3r5.conf
deleted file mode 100644
index afd36b72..00000000
--- a/conf/machine/am64xx-evm-k3r5.conf
+++ /dev/null
@@ -1,11 +0,0 @@
1#@TYPE: Machine
2#@NAME: AM64xx EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM64xx EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am64x"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp"
10
11UBOOT_MACHINE = "am64x_evm_r5_defconfig"
diff --git a/conf/machine/am64xx-evm.conf b/conf/machine/am64xx-evm.conf
index 2cb7f55a..d6efdf52 100644
--- a/conf/machine/am64xx-evm.conf
+++ b/conf/machine/am64xx-evm.conf
@@ -9,3 +9,9 @@ UBOOT_MACHINE = "am64x_evm_a53_defconfig"
9SPL_BINARY = "tispl.bin_HS" 9SPL_BINARY = "tispl.bin_HS"
10UBOOT_BINARY = "u-boot.img_HS" 10UBOOT_BINARY = "u-boot.img_HS"
11UBOOT_SYMLINK = "u-boot.img" 11UBOOT_SYMLINK = "u-boot.img"
12
13# Since default tiboot3.bin on AM64x is for HS-SE, add a version for GP
14BBMULTICONFIG += "k3r5-gp"
15IMAGE_BOOT_FILES += " tiboot3-am64x-gp-evm.bin"
16do_image_wic[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
17do_image_tar[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
diff --git a/conf/machine/am64xx-hs-evm-k3r5.conf b/conf/machine/am64xx-hs-evm-k3r5.conf
deleted file mode 100644
index 95e68751..00000000
--- a/conf/machine/am64xx-hs-evm-k3r5.conf
+++ /dev/null
@@ -1,12 +0,0 @@
1#@TYPE: Machine
2#@NAME: AM64xx HS EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM64xx HS EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am64x"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "hs"
10SYSFW_SYMLINK = ""
11
12UBOOT_MACHINE = "am64x_evm_r5_defconfig"
diff --git a/conf/machine/am64xx-hs-evm.conf b/conf/machine/am64xx-hs-evm.conf
deleted file mode 100644
index 1149d4c7..00000000
--- a/conf/machine/am64xx-hs-evm.conf
+++ /dev/null
@@ -1,25 +0,0 @@
1#@TYPE: Machine
2#@NAME: AM64xx HS EVM
3#@DESCRIPTION: Machine configuration for the TI AM64xx HS EVM
4
5require conf/machine/include/am64xx.inc
6
7UBOOT_MACHINE = "am64x_evm_a53_defconfig"
8
9UBOOT_ENTRYPOINT = "0x80080000"
10UBOOT_LOADADDRESS = "0x80080000"
11UBOOT_RD_LOADADDRESS = "0x84000000"
12UBOOT_RD_ENTRYPOINT = "0x84000000"
13UBOOT_DTB_LOADADDRESS = "0x83000000"
14UBOOT_DTBO_LOADADDRESS = "0x83080000"
15UBOOT_DTBO_OFFSET = "0x00010000"
16
17SPL_BINARY = "tispl.bin_HS"
18UBOOT_BINARY = "u-boot.img_HS"
19UBOOT_SYMLINK = "u-boot.img"
20
21# Since default tiboot3.bin on AM64x is for HS, add a version for GP
22BBMULTICONFIG += "k3r5-gp"
23IMAGE_BOOT_FILES += " tiboot3-am64x-gp-evm.bin"
24do_image_wic[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
25do_image_tar[mcdepends] += "mc::k3r5-gp:ti-sci-fw:do_deploy"
diff --git a/conf/machine/include/am64xx.inc b/conf/machine/include/am64xx.inc
index 930fba08..becc79d4 100644
--- a/conf/machine/include/am64xx.inc
+++ b/conf/machine/include/am64xx.inc
@@ -14,8 +14,9 @@ KERNEL_DEVICETREE = " \
14 ti/k3-am642-evm-nand.dtbo \ 14 ti/k3-am642-evm-nand.dtbo \
15" 15"
16 16
17do_image_wic[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" 17BBMULTICONFIG = "k3r5-hs-se"
18do_image_tar[mcdepends] = "mc::k3r5:ti-sci-fw:do_deploy" 18do_image_wic[mcdepends] = "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
19do_image_tar[mcdepends] = "mc::k3r5-hs-se:ti-sci-fw:do_deploy"
19 20
20TFA_BOARD = "lite" 21TFA_BOARD = "lite"
21OPTEEMACHINE = "k3-am64x" 22OPTEEMACHINE = "k3-am64x"
diff --git a/conf/multiconfig/k3r5-hs-se.conf b/conf/multiconfig/k3r5-hs-se.conf
new file mode 100644
index 00000000..701f8e88
--- /dev/null
+++ b/conf/multiconfig/k3r5-hs-se.conf
@@ -0,0 +1,3 @@
1require k3r5.conf
2
3MACHINE_append = "-hs-se"
diff --git a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
index 81edac27..a1df380f 100644
--- a/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
+++ b/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend
@@ -27,7 +27,7 @@ do_compile_append_am65xx-hs-evm() {
27 tfa_sign_k3hs 27 tfa_sign_k3hs
28} 28}
29 29
30do_compile_append_am64xx-hs-evm() { 30do_compile_append_am64xx-evm() {
31 tfa_sign_k3hs 31 tfa_sign_k3hs
32} 32}
33 33
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 5a25bd99..8a429bbc 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -66,7 +66,7 @@ do_compile_append_am65xx-hs-evm() {
66 optee_sign_k3hs 66 optee_sign_k3hs
67} 67}
68 68
69do_compile_append_am64xx-hs-evm() { 69do_compile_append_am64xx-evm() {
70 optee_sign_k3hs 70 optee_sign_k3hs
71} 71}
72 72