summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-08-04 21:49:30 -0500
committerRyan Eatmon <reatmon@ti.com>2022-08-06 19:04:37 -0500
commit9d4dd73c37ae9d08db2bbeec3cee802679632106 (patch)
tree4ed9cd7e6d9051c9726686a1911b5e47169170b6
parent5102d150e78cc1457782d969503dc544b26f55a3 (diff)
downloadmeta-ti-9d4dd73c37ae9d08db2bbeec3cee802679632106.tar.gz
prueth-fw: Deploy for AM64xx based on SoC not EVM
This makes sense but looks like was done wrong to match AM65xx which needed the exact EVM specified due to this only working on SR2. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb2
-rw-r--r--recipes-kernel/linux/kernel-rdepends.inc2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb b/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
index cf65e09a..e5446423 100644
--- a/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
+++ b/recipes-bsp/prueth-fw/prueth-fw-am65x-sr2_git.bb
@@ -7,7 +7,7 @@ PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1" 8CLEANBROKEN = "1"
9 9
10COMPATIBLE_MACHINE = "am65xx-evm|am64xx-evm" 10COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
11 11
12PACKAGE_ARCH = "${MACHINE_ARCH}" 12PACKAGE_ARCH = "${MACHINE_ARCH}"
13 13
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
index 2ac6eac4..143e6545 100644
--- a/recipes-kernel/linux/kernel-rdepends.inc
+++ b/recipes-kernel/linux/kernel-rdepends.inc
@@ -35,7 +35,7 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti43x = " prueth-fw pruhsr-fw pruprp
35RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw pruhsr-fw pruprp-fw" 35RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_ti33x = " prueth-fw pruhsr-fw pruprp-fw"
36RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x" 36RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx = " prueth-fw-am65x"
37RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2 prusw-fw-am65x-sr2" 37RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am65xx-evm = " prueth-fw-am65x-sr2 prusw-fw-am65x-sr2"
38RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am64xx-evm = " prueth-fw-am65x-sr2" 38RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am64xx = " prueth-fw-am65x-sr2"
39 39
40# Add run-time dependency for Cadence MHDP firmware to the rootfs 40# Add run-time dependency for Cadence MHDP firmware to the rootfs
41RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7-evm = " cadence-mhdp-fw" 41RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j7-evm = " cadence-mhdp-fw"