summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-08-05 11:33:10 -0500
committerRyan Eatmon <reatmon@ti.com>2022-08-06 19:06:23 -0500
commit8729e5e6fd0aca0bd10a69cfaafe78b8fa407ead (patch)
tree195aef100d5427585a80acddc5bb2ad511623049
parentb572721c6d6d584e9b9560c881c1e46ae49b14ef (diff)
downloadmeta-ti-8729e5e6fd0aca0bd10a69cfaafe78b8fa407ead.tar.gz
ti-sci-fw: Only deploy the raw SYSFW images for one machine target
This recipe deploys the raw SYSFW unconditionally which causes issues when doing multiconfig builds. What should happen is only one deploys these, select that the same way we select which one deploys the default SYSFW symlink. Move the deploy step there. Signed-off-by: Andrew Davis <afd@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index 72a3120e..841fe16a 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -99,6 +99,7 @@ do_deploy () {
99 ln -sf ${SYSFW_VBINARY} ${DEPLOYDIR}/${SYSFW_IMAGE} 99 ln -sf ${SYSFW_VBINARY} ${DEPLOYDIR}/${SYSFW_IMAGE}
100 if [ ! -z "${SYSFW_SYMLINK}" ]; then 100 if [ ! -z "${SYSFW_SYMLINK}" ]; then
101 ln -sf ${SYSFW_VBINARY} ${DEPLOYDIR}/${SYSFW_SYMLINK} 101 ln -sf ${SYSFW_VBINARY} ${DEPLOYDIR}/${SYSFW_SYMLINK}
102 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
102 fi 103 fi
103 fi 104 fi
104 105
@@ -106,10 +107,9 @@ do_deploy () {
106 install -m 644 ${WORKDIR}/imggen/${SYSFW_TIBOOT3} ${DEPLOYDIR}/${SYSFW_TIBOOT3} 107 install -m 644 ${WORKDIR}/imggen/${SYSFW_TIBOOT3} ${DEPLOYDIR}/${SYSFW_TIBOOT3}
107 if [ ! -z "${SYSFW_TIBOOT3_SYMLINK}" ]; then 108 if [ ! -z "${SYSFW_TIBOOT3_SYMLINK}" ]; then
108 ln -sf ${SYSFW_TIBOOT3} ${DEPLOYDIR}/${SYSFW_TIBOOT3_SYMLINK} 109 ln -sf ${SYSFW_TIBOOT3} ${DEPLOYDIR}/${SYSFW_TIBOOT3_SYMLINK}
110 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
109 fi 111 fi
110 fi 112 fi
111
112 install -m 644 ${SYSFW_TISCI} ${DEPLOYDIR}/
113} 113}
114 114
115addtask deploy before do_build after do_compile 115addtask deploy before do_build after do_compile