summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnand Gadiyar <gadiyar@ti.com>2022-08-29 11:38:05 -0500
committerRyan Eatmon <reatmon@ti.com>2022-08-29 12:15:03 -0500
commit0c7a7de23bab16826deab63f85df92a93ce568f2 (patch)
treef4275dff633ddb2a8c7bf8585ff7c495b7c603b6
parentf59278042b18a280e9bd81f33ac86e4863b30833 (diff)
downloadmeta-ti-0c7a7de23bab16826deab63f85df92a93ce568f2.tar.gz
machine: add am62xx-lp-evm configuration
This platform is similar to the currently supported am62xx-evm, except that we currently need new defconfigs for u-boot and new dtbs in the filesystem. Signed-off-by: Anand Gadiyar <gadiyar@ti.com> Cc: Hari Nagalla <hnagalla@ti.com> Cc: Andrew Davis <afd@ti.com> Cc: Praneeth Bajjuri <praneeth@ti.com> Cc: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--conf/machine/am62xx-lp-evm-k3r5.conf11
-rw-r--r--conf/machine/am62xx-lp-evm.conf16
-rw-r--r--recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb1
-rw-r--r--recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb2
-rw-r--r--recipes-kernel/linux/kernel-rdepends.inc1
-rw-r--r--recipes-security/optee/optee-os_%.bbappend1
6 files changed, 31 insertions, 1 deletions
diff --git a/conf/machine/am62xx-lp-evm-k3r5.conf b/conf/machine/am62xx-lp-evm-k3r5.conf
new file mode 100644
index 00000000..ca4ced5a
--- /dev/null
+++ b/conf/machine/am62xx-lp-evm-k3r5.conf
@@ -0,0 +1,11 @@
1#@TYPE: Machine
2#@NAME: AM62XX LP EVM (R5F)
3#@DESCRIPTION: Machine configuration for the TI AM62xx LP EVM (R5F core)
4
5require conf/machine/include/k3r5.inc
6
7SYSFW_SOC = "am62x"
8SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp"
10
11UBOOT_MACHINE = "am62x_lpsk_r5_defconfig"
diff --git a/conf/machine/am62xx-lp-evm.conf b/conf/machine/am62xx-lp-evm.conf
new file mode 100644
index 00000000..ef8e8692
--- /dev/null
+++ b/conf/machine/am62xx-lp-evm.conf
@@ -0,0 +1,16 @@
1#@TYPE: Machine
2#@NAME: AM62XX LP EVM
3#@DESCRIPTION: Machine configuration for the TI AM62XX LP EVM
4
5require conf/machine/include/am62xx.inc
6
7MACHINE_FEATURES += "gpu"
8
9KERNEL_DEVICETREE = " \
10 ti/k3-am62x-lp-sk.dtb \
11 ti/k3-am625-skeleton.dtb \
12 ti/k3-am625-sk-lpmdemo.dtb \
13 ti/k3-am625-sk-csi2-ov5640.dtbo \
14"
15
16UBOOT_MACHINE = "am62x_lpsk_a53_defconfig"
diff --git a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
index adf73a5e..3986af47 100644
--- a/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
+++ b/recipes-bsp/ti-sci-fw/ti-sci-fw_git.bb
@@ -36,6 +36,7 @@ SYSFW_PREFIX_j7200-hs-evm-k3r5 = "fs"
36SYSFW_PREFIX_j721s2-evm-k3r5 = "fs" 36SYSFW_PREFIX_j721s2-evm-k3r5 = "fs"
37SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs" 37SYSFW_PREFIX_j721s2-hs-evm-k3r5 = "fs"
38SYSFW_PREFIX_am62xx-evm-k3r5 = "fs" 38SYSFW_PREFIX_am62xx-evm-k3r5 = "fs"
39SYSFW_PREFIX_am62xx-lp-evm-k3r5 = "fs"
39 40
40SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin" 41SYSFW_TISCI = "${S}/ti-sysfw/ti-${SYSFW_PREFIX}-firmware-${SYSFW_SOC}-*.bin"
41 42
diff --git a/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb b/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
index 642a8d3a..876036f2 100644
--- a/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
+++ b/recipes-bsp/tifs-lpm-stub/tifs-lpm-stub_git.bb
@@ -7,7 +7,7 @@ PR = "${INC_PR}.0"
7 7
8CLEANBROKEN = "1" 8CLEANBROKEN = "1"
9 9
10COMPATIBLE_MACHINE = "am62xx-evm" 10COMPATIBLE_MACHINE = "am62xx-evm|am62xx-lp-evm"
11 11
12PACKAGE_ARCH = "${MACHINE_ARCH}" 12PACKAGE_ARCH = "${MACHINE_ARCH}"
13 13
diff --git a/recipes-kernel/linux/kernel-rdepends.inc b/recipes-kernel/linux/kernel-rdepends.inc
index 143e6545..c181c893 100644
--- a/recipes-kernel/linux/kernel-rdepends.inc
+++ b/recipes-kernel/linux/kernel-rdepends.inc
@@ -50,4 +50,5 @@ RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_j721s2-hs-evm = " cnm-wave-fw"
50 50
51# Add run-time dependency for TIFS Low Power Module stub 51# Add run-time dependency for TIFS Low Power Module stub
52RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am62xx-evm = " tifs-lpm-stub" 52RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am62xx-evm = " tifs-lpm-stub"
53RDEPENDS_${KERNEL_PACKAGE_NAME}-base_append_am62xx-lp-evm = " tifs-lpm-stub"
53 54
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index 8a429bbc..cc9857e0 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -7,6 +7,7 @@ DEPENDS_append_ti-soc = " python3-cryptography-native"
7EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" 7EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
8 8
9EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y" 9EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y"
10EXTRA_OEMAKE_append_am62xx-lp-evm = " CFG_WITH_SOFTWARE_PRNG=y"
10EXTRA_OEMAKE_append_j721s2-evm = " CFG_WITH_SOFTWARE_PRNG=y" 11EXTRA_OEMAKE_append_j721s2-evm = " CFG_WITH_SOFTWARE_PRNG=y"
11EXTRA_OEMAKE_append_j721s2-hs-evm = " CFG_WITH_SOFTWARE_PRNG=y" 12EXTRA_OEMAKE_append_j721s2-hs-evm = " CFG_WITH_SOFTWARE_PRNG=y"
12 13