summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Davis <afd@ti.com>2022-09-06 13:07:15 -0500
committerRyan Eatmon <reatmon@ti.com>2022-09-07 09:57:34 -0500
commit27641e1f2d7f6696fd7bbd8f24fcac20766b6234 (patch)
tree94d9104df7d6a6aad99dbf3cfb5f80b5315f8a1f
parent6e51469519d0fa3ba1c80f77f38ac206d2ce31a2 (diff)
downloadmeta-ti-27641e1f2d7f6696fd7bbd8f24fcac20766b6234.tar.gz
optee-os: Lower log level for AM62x
During resume from low power mode suspend OP-TEE prints some messages on the UART. It seems this UART is not powered at this point in the sequence breaking suspend/resume. We should track down the exact prints and quiet them. Until we get that fix upstream, lets lower the log level for this platform to unblock the LPM work. Signed-off-by: Andrew Davis <afd@ti.com> Acked-by: Anand Gadiyar <gadiyar@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--recipes-security/optee/optee-os_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-security/optee/optee-os_%.bbappend b/recipes-security/optee/optee-os_%.bbappend
index c715d47d..e7de5157 100644
--- a/recipes-security/optee/optee-os_%.bbappend
+++ b/recipes-security/optee/optee-os_%.bbappend
@@ -6,8 +6,8 @@ DEPENDS_append_ti-soc = " python3-cryptography-native"
6 6
7EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" 7EXTRA_OEMAKE_append_k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}"
8 8
9EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y" 9EXTRA_OEMAKE_append_am62xx-evm = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
10EXTRA_OEMAKE_append_am62xx-lp-evm = " CFG_WITH_SOFTWARE_PRNG=y" 10EXTRA_OEMAKE_append_am62xx-lp-evm = " CFG_WITH_SOFTWARE_PRNG=y CFG_TEE_CORE_LOG_LEVEL=1"
11EXTRA_OEMAKE_append_j721s2-evm = " CFG_WITH_SOFTWARE_PRNG=y" 11EXTRA_OEMAKE_append_j721s2-evm = " CFG_WITH_SOFTWARE_PRNG=y"
12EXTRA_OEMAKE_append_j721s2-hs-evm = " CFG_WITH_SOFTWARE_PRNG=y" 12EXTRA_OEMAKE_append_j721s2-hs-evm = " CFG_WITH_SOFTWARE_PRNG=y"
13 13