summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2024-04-17 09:20:52 -0500
committerRyan Eatmon <reatmon@ti.com>2024-04-17 09:30:19 -0500
commite9a56223ed04f9e0874177c5685db37a5eb6ea82 (patch)
tree6cee9e6bf0f4dfdd7f6b592c485dd81adcba1cff
parent4039d9a24796226b37d9fe5546a3e52cd34251ca (diff)
downloadmeta-ti-e9a56223ed04f9e0874177c5685db37a5eb6ea82.tar.gz
python3-yamllint: Temporarily carry this new recipe
Add recipe for yamllint. There is an upcoming change in u-boot where the binman tool is now configured to call yamllint to verify the configs during compile time. There was a previous patch a year ago from Trevor Woerner that never made it into oe-core. This patch is a reworking of his patch but pointing to a newer version. We are waiting on this patch to be accepted in oe-core. Once it is available on master we will remove this recipe to avoid conflict. Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-extras/recipes-devtools/python-yamllint/python3-yamllint_1.33.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-ti-extras/recipes-devtools/python-yamllint/python3-yamllint_1.33.0.bb b/meta-ti-extras/recipes-devtools/python-yamllint/python3-yamllint_1.33.0.bb
new file mode 100644
index 00000000..4b7bd065
--- /dev/null
+++ b/meta-ti-extras/recipes-devtools/python-yamllint/python3-yamllint_1.33.0.bb
@@ -0,0 +1,15 @@
1SUMMARY = "A linter for YAML files."
2HOMEPAGE = "https://github.com/adrienverge/yamllint"
3LICENSE = "GPL-3.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "yamllint"
9
10SRC_URI[sha256sum] = "2dceab9ef2d99518a2fcf4ffc964d44250ac4459be1ba3ca315118e4a1a81f7d"
11
12DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
13RDEPENDS:${PN} += "${PYTHON_PN}-pyyaml"
14
15BBCLASSEXTEND = "native nativesdk"