diff options
author | Justin Sobota <jsobota@ti.com> | 2016-04-21 02:19:43 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2016-04-26 14:54:42 -0400 |
commit | 701bb5c16f058812604fd2ba87d5675dfdef093a (patch) | |
tree | cc8a3ca915cd72f0d27bc5a44f73fd8a8bbbbf84 | |
parent | 185cbba966f35821d3671739657e28cf98d3cd9f (diff) | |
download | meta-ti-701bb5c16f058812604fd2ba87d5675dfdef093a.tar.gz |
ipc-transport-rtos: Add RTOS packages for IPC transports
Signed-off-by: Justin Sobota <jsobota@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-ti/ipc/ipc-transport-common-rtos_git.bb | 23 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb | 25 | ||||
-rw-r--r-- | recipes-ti/ipc/ipc-transport-srio-rtos_git.bb | 24 |
3 files changed, 72 insertions, 0 deletions
diff --git a/recipes-ti/ipc/ipc-transport-common-rtos_git.bb b/recipes-ti/ipc/ipc-transport-common-rtos_git.bb new file mode 100644 index 00000000..199e84c4 --- /dev/null +++ b/recipes-ti/ipc/ipc-transport-common-rtos_git.bb | |||
@@ -0,0 +1,23 @@ | |||
1 | require recipes-ti/includes/ti-paths.inc | ||
2 | require ipc-transport.inc | ||
3 | |||
4 | PR = "${INC_PR}.1" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://common_src/bench_common.h;beginline=1;endline=31;md5=a6ddfb26d2097041d513e3881f40e4e8" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "k2hk-evm|k2l-evm|k2e-evm" | ||
9 | |||
10 | IPC_TRANSPORT_COMMON_DESTSUFFIX = "git/c66/example" | ||
11 | |||
12 | S = "${WORKDIR}/${IPC_TRANSPORT_COMMON_DESTSUFFIX}" | ||
13 | |||
14 | do_compile() { | ||
15 | : | ||
16 | } | ||
17 | |||
18 | do_install () { | ||
19 | install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66/example | ||
20 | cp -r ${S} ${D}${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66 | ||
21 | } | ||
22 | |||
23 | FILES_${PN} += "${PDK_INSTALL_DIR_RECIPE}/packages/ti/transport/ipc/c66/example/*" | ||
diff --git a/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb b/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb new file mode 100644 index 00000000..0631a92a --- /dev/null +++ b/recipes-ti/ipc/ipc-transport-qmss-rtos_git.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | inherit ti-pdk | ||
2 | require ipc-transport.inc | ||
3 | |||
4 | PR = "${INC_PR}.4" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://TransportQmss.xdc;beginline=1;endline=35;md5=ad783760d74a4cc5b8d4ad3d8a1f28a2" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "k2hk-evm|k2l-evm|k2e-evm" | ||
9 | |||
10 | DEPENDS_append = " qmss-lld-rtos \ | ||
11 | cppi-lld-rtos \ | ||
12 | ti-ipc-rtos \ | ||
13 | ipc-transport-common-rtos \ | ||
14 | " | ||
15 | |||
16 | IPC_TRANSPORT_QMSS_DESTSUFFIX = "git/c66/qmss" | ||
17 | |||
18 | S = "${WORKDIR}/${IPC_TRANSPORT_QMSS_DESTSUFFIX}" | ||
19 | |||
20 | XDCARGS_k2hk-evm = "k2h k2k" | ||
21 | XDCARGS_k2e-evm = "k2e" | ||
22 | XDCARGS_k2l-evm = "k2l" | ||
23 | |||
24 | export IPC_INSTALL_PATH = "${IPC_INSTALL_DIR}" | ||
25 | XDCPATH_append = ";${IPC_INSTALL_DIR}/packages" | ||
diff --git a/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb b/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb new file mode 100644 index 00000000..6ea3fb93 --- /dev/null +++ b/recipes-ti/ipc/ipc-transport-srio-rtos_git.bb | |||
@@ -0,0 +1,24 @@ | |||
1 | inherit ti-pdk | ||
2 | require ipc-transport.inc | ||
3 | |||
4 | PR = "${INC_PR}.2" | ||
5 | |||
6 | LIC_FILES_CHKSUM = "file://TransportSrio.xdc;beginline=1;endline=35;md5=4d466471e4b933a0cc353a46bb546fe7" | ||
7 | |||
8 | COMPATIBLE_MACHINE = "k2hk-evm" | ||
9 | |||
10 | DEPENDS_append = " qmss-lld-rtos \ | ||
11 | cppi-lld-rtos \ | ||
12 | srio-lld-rtos \ | ||
13 | ti-ipc-rtos \ | ||
14 | ipc-transport-common-rtos \ | ||
15 | " | ||
16 | |||
17 | IPC_TRANSPORT_SRIO_DESTSUFFIX = "git/c66/srio" | ||
18 | |||
19 | S = "${WORKDIR}/${IPC_TRANSPORT_SRIO_DESTSUFFIX}" | ||
20 | |||
21 | XDCARGS_k2hk-evm = "k2h k2k" | ||
22 | |||
23 | export IPC_INSTALL_PATH = "${IPC_INSTALL_DIR}" | ||
24 | XDCPATH_append = ";${IPC_INSTALL_DIR}/packages" | ||