diff options
author | Randolph Sapp <rs@ti.com> | 2024-11-04 14:39:08 -0600 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2024-11-06 13:48:46 -0600 |
commit | 57863a821a61d6483d9e4510e90d66504ed37395 (patch) | |
tree | 0166f9ae3405cd3c205a5f00aaf2d0fda12fd8c6 | |
parent | befff0d6051717332a8109c4c89a9289e29710a6 (diff) | |
download | meta-ti-57863a821a61d6483d9e4510e90d66504ed37395.tar.gz |
mesa-pvr: remove dynamic-layer append for llvmpipe
The mesa.inc that we inherit from oe-core now has the required
parameters. This conditional append is no longer required.
This reverts commit dbc6afc46e55b247606dfad5238137c8fa807843.
Signed-off-by: Randolph Sapp <rs@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-bsp/conf/layer.conf | 4 | ||||
-rw-r--r-- | meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend | 14 |
2 files changed, 0 insertions, 18 deletions
diff --git a/meta-ti-bsp/conf/layer.conf b/meta-ti-bsp/conf/layer.conf index 462bf763..251f1fa4 100644 --- a/meta-ti-bsp/conf/layer.conf +++ b/meta-ti-bsp/conf/layer.conf | |||
@@ -18,10 +18,6 @@ LAYERDEPENDS_meta-ti-bsp = " \ | |||
18 | meta-arm \ | 18 | meta-arm \ |
19 | " | 19 | " |
20 | 20 | ||
21 | BBFILES_DYNAMIC += " \ | ||
22 | clang-layer:${LAYERDIR}/dynamic-layers/clang-layer/recipes*/*/*.bbappend \ | ||
23 | " | ||
24 | |||
25 | SIGGEN_EXCLUDERECIPES_ABISAFE += " \ | 21 | SIGGEN_EXCLUDERECIPES_ABISAFE += " \ |
26 | mesa-pvr \ | 22 | mesa-pvr \ |
27 | " | 23 | " |
diff --git a/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend b/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend deleted file mode 100644 index 7e5c36fd..00000000 --- a/meta-ti-bsp/dynamic-layers/clang-layer/recipes-graphics/mesa/mesa-pvr_%.bbappend +++ /dev/null | |||
@@ -1,14 +0,0 @@ | |||
1 | # This is a copy of meta-clang/recipes-graphics/mesa/mesa_%.bbappend required | ||
2 | # for llvmpipe when using pvr-mesa since we aren't caught by that glob. | ||
3 | |||
4 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" | ||
5 | |||
6 | LDFLAGS:append:toolchain-clang = " -latomic -lm" | ||
7 | DEPENDS:append:toolchain-clang = " libatomic-ops" | ||
8 | |||
9 | EXTRA_OEMASON:append:toolchain-clang:x86 = " -Dasm=false" | ||
10 | EXTRA_OEMASON:append:toolchain-clang:x86-64 = " -Dasm=false" | ||
11 | |||
12 | export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_LIBDIR}/llvm-config" | ||
13 | |||
14 | PACKAGECONFIG[gallium-llvm] = "-Dllvm=true -Dshared-llvm=true -Ddraw-use-llvm=true,-Dllvm=false,clang clang-native elfutils" | ||