diff options
author | Ryan Eatmon <reatmon@ti.com> | 2024-01-24 12:30:58 -0600 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2024-01-24 12:30:58 -0600 |
commit | ac3dd6f1811b9b55893f276145fec2a278746b05 (patch) | |
tree | 9e94761fa6a5db3870cb140ff86277bd5961e0be | |
parent | ced46e618bb62b650a98b62c4267e3f385f407d0 (diff) | |
download | meta-ti-ac3dd6f1811b9b55893f276145fec2a278746b05.tar.gz |
u-boot-ti*: Move mainline to 2024.01 and move logo code
Now that 2024.01 is official, the logo that am62xx-evm installs is
available in all versions of the repo that we point to. Move all of
that code out of the .bb files and into the u-boot-ti.inc file.
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb | 4 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb | 10 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | 10 |
3 files changed, 12 insertions, 12 deletions
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb index e98d584a..f497054c 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-mainline_git.bb | |||
@@ -2,7 +2,7 @@ require u-boot-ti.inc | |||
2 | 2 | ||
3 | PR = "r0" | 3 | PR = "r0" |
4 | 4 | ||
5 | PV = "2023.07" | 5 | PV = "2024.01" |
6 | 6 | ||
7 | # For the un-initiated: | 7 | # For the un-initiated: |
8 | # The actual URL you'd use with a git clone for example would be: | 8 | # The actual URL you'd use with a git clone for example would be: |
@@ -13,4 +13,4 @@ PV = "2023.07" | |||
13 | # b) and we want git fetcher to use https protocol, hence GIT_PROTOCOL as https | 13 | # b) and we want git fetcher to use https protocol, hence GIT_PROTOCOL as https |
14 | UBOOT_GIT_URI = "git://source.denx.de/u-boot/u-boot.git" | 14 | UBOOT_GIT_URI = "git://source.denx.de/u-boot/u-boot.git" |
15 | UBOOT_GIT_PROTOCOL = "https" | 15 | UBOOT_GIT_PROTOCOL = "https" |
16 | SRCREV = "83cdab8b2c6ea0fc0860f8444d083353b47f1d5c" | 16 | SRCREV = "866ca972d6c3cabeaf6dbac431e8e08bb30b3c8e" |
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb index 143bcea8..e95c9c76 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb | |||
@@ -7,13 +7,3 @@ PR = "r0" | |||
7 | BRANCH = "ti-u-boot-2023.04" | 7 | BRANCH = "ti-u-boot-2023.04" |
8 | 8 | ||
9 | SRCREV = "a97ca328b3df6abf79c5cc01878290e03131bbba" | 9 | SRCREV = "a97ca328b3df6abf79c5cc01878290e03131bbba" |
10 | |||
11 | do_install:append:am62xx() { | ||
12 | install -d ${D}/boot | ||
13 | install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot | ||
14 | } | ||
15 | |||
16 | do_deploy:append:am62xx() { | ||
17 | install -d ${DEPLOYDIR} | ||
18 | install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR} | ||
19 | } | ||
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc index 7e2e2011..493c1c31 100644 --- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc +++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc | |||
@@ -331,4 +331,14 @@ do_deploy:append () { | |||
331 | rm ${DEPLOYDIR}/${PN}-initial-env-${MACHINE}-${PV}-${PR} || true | 331 | rm ${DEPLOYDIR}/${PN}-initial-env-${MACHINE}-${PV}-${PR} || true |
332 | } | 332 | } |
333 | 333 | ||
334 | do_install:append:am62xx() { | ||
335 | install -d ${D}/boot | ||
336 | install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${D}/boot | ||
337 | } | ||
338 | |||
339 | do_deploy:append:am62xx() { | ||
340 | install -d ${DEPLOYDIR} | ||
341 | install -m 0644 ${S}/tools/logos/ti_logo_414x97_32bpp.bmp.gz ${DEPLOYDIR} | ||
342 | } | ||
343 | |||
334 | TOOLCHAIN = "gcc" | 344 | TOOLCHAIN = "gcc" |