diff options
author | Ryan Eatmon <reatmon@ti.com> | 2023-03-17 10:20:53 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-03-31 09:16:08 -0500 |
commit | aacaba30db61d9199a23513ef6838922d73dcad0 (patch) | |
tree | bfd29c6b75cf1f9ef867340bee5a27464105ce12 | |
parent | 183e6abac6611fea0f52d7ac7303131536516a80 (diff) | |
download | meta-ti-aacaba30db61d9199a23513ef6838922d73dcad0.tar.gz |
linux-ti-*: Add filtering for which dtb/dtbo to include
We often carry more dtbs/dtbos in our kernel than we have upstreamed.
The inclusion of all of the dtb/dtbo in the KERNEL_DEVICETREE has become
problematic as we start testing the linux-next and 6.1 as part of our
LTS migration. To address this issue we are adding in two step method
for managing the KERNEL_DEVICETREE.
Going forward we will only accept dtb/dtbo in KERNEL_DEVICETREE if it is
available in upstream. This way we ensure that the variable is more
accurate for whichever kernel you might be looking at. We have also
added a new variable KERNEL_DEVICETREE_PREFIX which our kernel recipes
will use to auto set KERNEL_DEVICETREE based on what files are in the
kernel and not a fixed list in the conf files.
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
Signed-off-by: Andrew Davis <afd@ti.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
20 files changed, 115 insertions, 189 deletions
diff --git a/meta-ti-bsp/conf/machine/am57xx-evm.conf b/meta-ti-bsp/conf/machine/am57xx-evm.conf index b3525a0b..9b12f383 100644 --- a/meta-ti-bsp/conf/machine/am57xx-evm.conf +++ b/meta-ti-bsp/conf/machine/am57xx-evm.conf | |||
@@ -8,24 +8,26 @@ MACHINE_FEATURES += "touchscreen" | |||
8 | 8 | ||
9 | SERIAL_CONSOLES = "115200;ttyS2" | 9 | SERIAL_CONSOLES = "115200;ttyS2" |
10 | 10 | ||
11 | KERNEL_DEVICETREE_PREFIX = " \ | ||
12 | am57 \ | ||
13 | ti/am57 \ | ||
14 | ti/lcd \ | ||
15 | ti/ov10635 \ | ||
16 | " | ||
17 | |||
18 | KERNEL_DEVICETREE_DTBMERGE = " \ | ||
19 | am57xx-evm.dtb \ | ||
20 | am57xx-evm-reva3.dtb \ | ||
21 | " | ||
22 | |||
11 | KERNEL_DEVICETREE = " \ | 23 | KERNEL_DEVICETREE = " \ |
12 | am57xx-beagle-x15.dtb \ | 24 | am57xx-beagle-x15.dtb \ |
13 | am57xx-beagle-x15-revb1.dtb \ | 25 | am57xx-beagle-x15-revb1.dtb \ |
14 | am57xx-beagle-x15-revc.dtb \ | 26 | am57xx-beagle-x15-revc.dtb \ |
15 | am5729-beagleboneai.dtb \ | 27 | am5729-beagleboneai.dtb \ |
16 | ${@oe.utils.conditional('PREFERRED_PROVIDER_virtual/kernel', 'linux-ti-mainline', '', 'am57xx-evm.dtb', d)} \ | ||
17 | ti/am57xx-evm-common.dtbo \ | ||
18 | ${@oe.utils.conditional('PREFERRED_PROVIDER_virtual/kernel', 'linux-ti-mainline', '', 'am57xx-evm-reva3.dtb', d)} \ | ||
19 | ti/am57xx-evm-reva3.dtbo \ | ||
20 | am571x-idk.dtb \ | 28 | am571x-idk.dtb \ |
21 | ti/am571x-idk-touchscreen.dtbo \ | ||
22 | am572x-idk.dtb \ | 29 | am572x-idk.dtb \ |
23 | am574x-idk.dtb \ | 30 | am574x-idk.dtb \ |
24 | ti/am57xx-idk-osd-lcd-common.dtbo \ | ||
25 | ti/am572x-idk-touchscreen.dtbo \ | ||
26 | ti/lcd-osd101t2587.dtbo \ | ||
27 | ti/lcd-osd101t2045.dtbo \ | ||
28 | ${@oe.utils.conditional('PREFERRED_PROVIDER_virtual/kernel', 'linux-ti-mainline', '', 'ti/ov10635.dtbo', d)} \ | ||
29 | " | 31 | " |
30 | 32 | ||
31 | KERNEL_DEVICETREE += "${@oe.utils.conditional('ENABLE_TI_UIO_DEVICES', '1', 'am574x-idk-pru-excl-uio.dtb am572x-idk-pru-excl-uio.dtb am571x-idk-pru-excl-uio.dtb', '', d)}" | 33 | KERNEL_DEVICETREE += "${@oe.utils.conditional('ENABLE_TI_UIO_DEVICES', '1', 'am574x-idk-pru-excl-uio.dtb am572x-idk-pru-excl-uio.dtb am571x-idk-pru-excl-uio.dtb', '', d)}" |
diff --git a/meta-ti-bsp/conf/machine/am62axx-evm.conf b/meta-ti-bsp/conf/machine/am62axx-evm.conf index 2fd91bd7..691a074b 100644 --- a/meta-ti-bsp/conf/machine/am62axx-evm.conf +++ b/meta-ti-bsp/conf/machine/am62axx-evm.conf | |||
@@ -4,23 +4,13 @@ | |||
4 | 4 | ||
5 | require conf/machine/include/am62axx.inc | 5 | require conf/machine/include/am62axx.inc |
6 | 6 | ||
7 | KERNEL_DEVICETREE_PREFIX = " \ | ||
8 | ti/k3-am62a7 \ | ||
9 | ti/k3-j721e-fpdlink \ | ||
10 | " | ||
11 | |||
7 | KERNEL_DEVICETREE = " \ | 12 | KERNEL_DEVICETREE = " \ |
8 | ti/k3-am62a7-sk.dtb \ | 13 | ti/k3-am62a7-sk.dtb \ |
9 | ti/k3-am62a7-fpdlink-ov2312-0-0.dtbo \ | ||
10 | ti/k3-am62a7-fpdlink-ov2312-0-1.dtbo \ | ||
11 | ti/k3-am62a7-fpdlink-ov2312-0-2.dtbo \ | ||
12 | ti/k3-am62a7-fpdlink-ov2312-0-3.dtbo \ | ||
13 | ti/k3-am62a7-fpdlink-sk-fusion.dtbo \ | ||
14 | ti/k3-am62a7-sk-csi2-imx219.dtbo \ | ||
15 | ti/k3-am62a7-sk-ethernet-dc01.dtbo \ | ||
16 | ti/k3-j721e-fpdlink-imx390-cm-0-0.dtbo \ | ||
17 | ti/k3-j721e-fpdlink-imx390-cm-0-1.dtbo \ | ||
18 | ti/k3-j721e-fpdlink-imx390-cm-0-2.dtbo \ | ||
19 | ti/k3-j721e-fpdlink-imx390-cm-0-3.dtbo \ | ||
20 | ti/k3-j721e-fpdlink-imx390-rcm-0-0.dtbo \ | ||
21 | ti/k3-j721e-fpdlink-imx390-rcm-0-1.dtbo \ | ||
22 | ti/k3-j721e-fpdlink-imx390-rcm-0-2.dtbo \ | ||
23 | ti/k3-j721e-fpdlink-imx390-rcm-0-3.dtbo \ | ||
24 | " | 14 | " |
25 | 15 | ||
26 | UBOOT_MACHINE = "am62ax_evm_a53_defconfig" | 16 | UBOOT_MACHINE = "am62ax_evm_a53_defconfig" |
diff --git a/meta-ti-bsp/conf/machine/am62xx-evm.conf b/meta-ti-bsp/conf/machine/am62xx-evm.conf index 8892a05f..d54213d4 100644 --- a/meta-ti-bsp/conf/machine/am62xx-evm.conf +++ b/meta-ti-bsp/conf/machine/am62xx-evm.conf | |||
@@ -4,16 +4,10 @@ | |||
4 | 4 | ||
5 | require conf/machine/include/am62xx.inc | 5 | require conf/machine/include/am62xx.inc |
6 | 6 | ||
7 | KERNEL_DEVICETREE_PREFIX = "ti/k3-am625" | ||
8 | |||
7 | KERNEL_DEVICETREE = " \ | 9 | KERNEL_DEVICETREE = " \ |
8 | ti/k3-am625-sk.dtb \ | 10 | ti/k3-am625-sk.dtb \ |
9 | ti/k3-am625-skeleton.dtb \ | ||
10 | ti/k3-am625-sk-lpmdemo.dtb \ | ||
11 | ti/k3-am625-sk-csi2-ov5640.dtbo \ | ||
12 | ti/k3-am625-sk-csi2-tevi-ov5640.dtbo \ | ||
13 | ti/k3-am625-sk-ecap-capture.dtbo \ | ||
14 | ti/k3-am625-sk-hdmi-audio.dtbo \ | ||
15 | ti/k3-am625-sk-mcan.dtbo \ | ||
16 | ti/k3-am625-sk-oldi-panel.dtbo \ | ||
17 | " | 11 | " |
18 | 12 | ||
19 | UBOOT_MACHINE = "am62x_evm_a53_defconfig" | 13 | UBOOT_MACHINE = "am62x_evm_a53_defconfig" |
diff --git a/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf b/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf index cba05c4b..ba1a12a7 100644 --- a/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf +++ b/meta-ti-bsp/conf/machine/am62xx-lp-evm.conf | |||
@@ -4,12 +4,13 @@ | |||
4 | 4 | ||
5 | require conf/machine/include/am62xx-lp.inc | 5 | require conf/machine/include/am62xx-lp.inc |
6 | 6 | ||
7 | KERNEL_DEVICETREE_PREFIX = " \ | ||
8 | ti/k3-am62x-lp \ | ||
9 | ti/k3-am625-sk \ | ||
10 | " | ||
11 | |||
7 | KERNEL_DEVICETREE = " \ | 12 | KERNEL_DEVICETREE = " \ |
8 | ti/k3-am62x-lp-sk.dtb \ | 13 | ti/k3-am62x-lp-sk.dtb \ |
9 | ti/k3-am625-skeleton.dtb \ | ||
10 | ti/k3-am625-sk-lpmdemo.dtb \ | ||
11 | ti/k3-am625-sk-csi2-ov5640.dtbo \ | ||
12 | ti/k3-am62x-lp-sk-oldi-panel.dtbo \ | ||
13 | " | 14 | " |
14 | 15 | ||
15 | SPL_BINARY = "tispl.bin_HS" | 16 | SPL_BINARY = "tispl.bin_HS" |
diff --git a/meta-ti-bsp/conf/machine/beagle-x15.conf b/meta-ti-bsp/conf/machine/beagle-x15.conf index b4279ae4..8efd6e60 100644 --- a/meta-ti-bsp/conf/machine/beagle-x15.conf +++ b/meta-ti-bsp/conf/machine/beagle-x15.conf | |||
@@ -4,7 +4,13 @@ | |||
4 | 4 | ||
5 | require conf/machine/include/am57xx.inc | 5 | require conf/machine/include/am57xx.inc |
6 | 6 | ||
7 | KERNEL_DEVICETREE = "am57xx-beagle-x15.dtb am57xx-beagle-x15-revb1.dtb am57xx-beagle-x15-revc.dtb" | 7 | KERNEL_DEVICETREE_PREFIX = "am57xx-beagle-x15" |
8 | |||
9 | KERNEL_DEVICETREE = " \ | ||
10 | am57xx-beagle-x15.dtb \ | ||
11 | am57xx-beagle-x15-revb1.dtb \ | ||
12 | am57xx-beagle-x15-revc.dtb \ | ||
13 | " | ||
8 | 14 | ||
9 | MACHINE_GUI_CLASS = "bigscreen" | 15 | MACHINE_GUI_CLASS = "bigscreen" |
10 | 16 | ||
diff --git a/meta-ti-bsp/conf/machine/beaglebone.conf b/meta-ti-bsp/conf/machine/beaglebone.conf index 413a960d..2a8dc6d7 100644 --- a/meta-ti-bsp/conf/machine/beaglebone.conf +++ b/meta-ti-bsp/conf/machine/beaglebone.conf | |||
@@ -4,9 +4,16 @@ | |||
4 | 4 | ||
5 | require conf/machine/include/ti33x.inc | 5 | require conf/machine/include/ti33x.inc |
6 | 6 | ||
7 | KERNEL_DEVICETREE = "am335x-bone.dtb am335x-boneblue.dtb \ | 7 | KERNEL_DEVICETREE_PREFIX = "am335x-bone" |
8 | am335x-boneblack.dtb am335x-boneblack-wireless.dtb \ | 8 | |
9 | am335x-bonegreen.dtb am335x-bonegreen-wireless.dtb" | 9 | KERNEL_DEVICETREE = " \ |
10 | am335x-bone.dtb \ | ||
11 | am335x-boneblue.dtb \ | ||
12 | am335x-boneblack.dtb \ | ||
13 | am335x-boneblack-wireless.dtb \ | ||
14 | am335x-bonegreen.dtb \ | ||
15 | am335x-bonegreen-wireless.dtb \ | ||
16 | " | ||
10 | 17 | ||
11 | MACHINE_GUI_CLASS = "bigscreen" | 18 | MACHINE_GUI_CLASS = "bigscreen" |
12 | MACHINE_FEATURES += "screen" | 19 | MACHINE_FEATURES += "screen" |
diff --git a/meta-ti-bsp/conf/machine/dra7xx-evm.conf b/meta-ti-bsp/conf/machine/dra7xx-evm.conf index 813e0e06..c47a1e80 100644 --- a/meta-ti-bsp/conf/machine/dra7xx-evm.conf +++ b/meta-ti-bsp/conf/machine/dra7xx-evm.conf | |||
@@ -8,20 +8,18 @@ MACHINE_FEATURES += "touchscreen" | |||
8 | 8 | ||
9 | SERIAL_CONSOLES = "115200;ttyS0" | 9 | SERIAL_CONSOLES = "115200;ttyS0" |
10 | 10 | ||
11 | KERNEL_DEVICETREE_PREFIX = " \ | ||
12 | dra7 \ | ||
13 | ti/dra7 \ | ||
14 | ti/lcd \ | ||
15 | " | ||
16 | |||
11 | KERNEL_DEVICETREE = " \ | 17 | KERNEL_DEVICETREE = " \ |
12 | dra7-evm.dtb \ | 18 | dra7-evm.dtb \ |
13 | ti/dra7x-evm-osd-lcd-common.dtbo \ | ||
14 | dra71-evm.dtb \ | 19 | dra71-evm.dtb \ |
15 | ${@oe.utils.conditional('PREFERRED_PROVIDER_virtual/kernel', 'linux-ti-mainline', '', 'dra71-evm-nand.dtb', d)} \ | ||
16 | ti/dra71-evm-lcd-auo-g101evn01.0.dtbo \ | ||
17 | dra72-evm.dtb \ | 20 | dra72-evm.dtb \ |
18 | dra72-evm-revc.dtb \ | 21 | dra72-evm-revc.dtb \ |
19 | ti/dra72-evm-touchscreen.dtbo \ | ||
20 | ti/dra74-evm-touchscreen.dtbo \ | ||
21 | dra76-evm.dtb \ | 22 | dra76-evm.dtb \ |
22 | ti/dra76-evm-tfp410.dtbo \ | ||
23 | ti/lcd-osd101t2045.dtbo \ | ||
24 | ti/lcd-osd101t2587.dtbo \ | ||
25 | " | 23 | " |
26 | 24 | ||
27 | UBOOT_MACHINE = "dra7xx_evm_config" | 25 | UBOOT_MACHINE = "dra7xx_evm_config" |
diff --git a/meta-ti-bsp/conf/machine/include/am64xx.inc b/meta-ti-bsp/conf/machine/include/am64xx.inc index a2e5d673..157bf5d5 100644 --- a/meta-ti-bsp/conf/machine/include/am64xx.inc +++ b/meta-ti-bsp/conf/machine/include/am64xx.inc | |||
@@ -4,12 +4,11 @@ SOC_FAMILY:append = ":am64xx" | |||
4 | SERIAL_CONSOLES = "115200;ttyS2 115200;ttyS1" | 4 | SERIAL_CONSOLES = "115200;ttyS2 115200;ttyS1" |
5 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | 5 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" |
6 | 6 | ||
7 | KERNEL_DEVICETREE_PREFIX = "ti/k3-am642" | ||
8 | |||
7 | KERNEL_DEVICETREE = " \ | 9 | KERNEL_DEVICETREE = " \ |
8 | ti/k3-am642-evm.dtb \ | 10 | ti/k3-am642-evm.dtb \ |
9 | ti/k3-am642-sk.dtb \ | 11 | ti/k3-am642-sk.dtb \ |
10 | ti/k3-am642-evm-icssg1-dualemac.dtbo \ | ||
11 | ti/k3-am642-evm-icssg1-dualemac-mii.dtbo \ | ||
12 | ti/k3-am642-evm-nand.dtbo \ | ||
13 | " | 12 | " |
14 | 13 | ||
15 | # Default tiboot3.bin on AM64x is for SR2.0 HS-FS | 14 | # Default tiboot3.bin on AM64x is for SR2.0 HS-FS |
diff --git a/meta-ti-bsp/conf/machine/include/am65xx.inc b/meta-ti-bsp/conf/machine/include/am65xx.inc index 0ae00761..564d61b0 100644 --- a/meta-ti-bsp/conf/machine/include/am65xx.inc +++ b/meta-ti-bsp/conf/machine/include/am65xx.inc | |||
@@ -8,18 +8,10 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | |||
8 | 8 | ||
9 | PREFERRED_PROVIDER_virtual/gpudriver ?= "" | 9 | PREFERRED_PROVIDER_virtual/gpudriver ?= "" |
10 | 10 | ||
11 | KERNEL_DEVICETREE_PREFIX = "ti/k3-am654" | ||
12 | |||
11 | KERNEL_DEVICETREE = " \ | 13 | KERNEL_DEVICETREE = " \ |
12 | ti/k3-am654-base-board.dtb \ | 14 | ti/k3-am654-base-board.dtb \ |
13 | ti/k3-am654-base-board-sr1.dtbo \ | ||
14 | ti/k3-am654-gp.dtbo \ | ||
15 | ti/k3-am654-idk.dtbo \ | ||
16 | ti/k3-am654-idk-sr1.dtbo \ | ||
17 | ti/k3-am654-sr1.dtbo \ | ||
18 | ti/k3-am654-pcie-usb2.dtbo \ | ||
19 | ti/k3-am654-pcie-usb3.dtbo \ | ||
20 | ti/k3-am654-evm-tc358876.dtbo \ | ||
21 | ti/k3-am654-evm-oldi-lcd1evm.dtbo \ | ||
22 | ti/k3-am654-evm-ov5640.dtbo \ | ||
23 | " | 15 | " |
24 | 16 | ||
25 | # On AM65x the file tiboot3.bin comes from the bootloader not ti-sci-fw | 17 | # On AM65x the file tiboot3.bin comes from the bootloader not ti-sci-fw |
diff --git a/meta-ti-bsp/conf/machine/include/ti33x.inc b/meta-ti-bsp/conf/machine/include/ti33x.inc index 95499552..4f6d90bf 100644 --- a/meta-ti-bsp/conf/machine/include/ti33x.inc +++ b/meta-ti-bsp/conf/machine/include/ti33x.inc | |||
@@ -18,12 +18,19 @@ PVR_DISPLAY_CONTROLLER_ALIAS ?= "tilcdc" | |||
18 | 18 | ||
19 | KERNEL_IMAGETYPE = "zImage" | 19 | KERNEL_IMAGETYPE = "zImage" |
20 | 20 | ||
21 | KERNEL_DEVICETREE_PREFIX = "am335x" | ||
22 | |||
21 | KERNEL_DEVICETREE = " \ | 23 | KERNEL_DEVICETREE = " \ |
22 | am335x-evm.dtb am335x-evmsk.dtb \ | 24 | am335x-evm.dtb \ |
25 | am335x-evmsk.dtb \ | ||
23 | am335x-icev2.dtb \ | 26 | am335x-icev2.dtb \ |
24 | am335x-pocketbeagle.dtb am335x-bone.dtb am335x-boneblue.dtb \ | 27 | am335x-pocketbeagle.dtb \ |
25 | am335x-bonegreen.dtb am335x-bonegreen-wireless.dtb \ | 28 | am335x-bone.dtb \ |
26 | am335x-boneblack.dtb am335x-boneblack-wireless.dtb \ | 29 | am335x-boneblue.dtb \ |
30 | am335x-bonegreen.dtb \ | ||
31 | am335x-bonegreen-wireless.dtb \ | ||
32 | am335x-boneblack.dtb \ | ||
33 | am335x-boneblack-wireless.dtb \ | ||
27 | am335x-sancloud-bbe.dtb \ | 34 | am335x-sancloud-bbe.dtb \ |
28 | " | 35 | " |
29 | 36 | ||
diff --git a/meta-ti-bsp/conf/machine/include/ti43x.inc b/meta-ti-bsp/conf/machine/include/ti43x.inc index ec6d9c07..5b40925e 100644 --- a/meta-ti-bsp/conf/machine/include/ti43x.inc +++ b/meta-ti-bsp/conf/machine/include/ti43x.inc | |||
@@ -18,12 +18,16 @@ PVR_DISPLAY_CONTROLLER_ALIAS ?= "omapdrm" | |||
18 | 18 | ||
19 | KERNEL_IMAGETYPE = "zImage" | 19 | KERNEL_IMAGETYPE = "zImage" |
20 | 20 | ||
21 | KERNEL_DEVICETREE_PREFIX = " \ | ||
22 | am437x \ | ||
23 | am43x \ | ||
24 | " | ||
25 | |||
21 | KERNEL_DEVICETREE = " \ | 26 | KERNEL_DEVICETREE = " \ |
22 | am437x-gp-evm.dtb \ | 27 | am437x-gp-evm.dtb \ |
23 | ${@oe.utils.conditional('PREFERRED_PROVIDER_virtual/kernel', 'linux-ti-mainline', '', 'am437x-gp-evm-hdmi.dtb', d)} \ | 28 | am437x-sk-evm.dtb \ |
24 | am437x-sk-evm.dtb am437x-idk-evm.dtb \ | 29 | am437x-idk-evm.dtb \ |
25 | am43x-epos-evm.dtb \ | 30 | am43x-epos-evm.dtb \ |
26 | ${@oe.utils.conditional('PREFERRED_PROVIDER_virtual/kernel', 'linux-ti-mainline', '', 'am43x-epos-evm-hdmi.dtb', d)} \ | ||
27 | " | 31 | " |
28 | 32 | ||
29 | KERNEL_DEVICETREE += "${@oe.utils.conditional('ENABLE_TI_UIO_DEVICES', '1', 'am437x-idk-pru-excl-uio.dtb', '', d)}" | 33 | KERNEL_DEVICETREE += "${@oe.utils.conditional('ENABLE_TI_UIO_DEVICES', '1', 'am437x-idk-pru-excl-uio.dtb', '', d)}" |
diff --git a/meta-ti-bsp/conf/machine/j7200-evm.conf b/meta-ti-bsp/conf/machine/j7200-evm.conf index c01b318b..b17b65b7 100644 --- a/meta-ti-bsp/conf/machine/j7200-evm.conf +++ b/meta-ti-bsp/conf/machine/j7200-evm.conf | |||
@@ -7,10 +7,10 @@ require conf/machine/include/j7200.inc | |||
7 | SERIAL_CONSOLES = "115200;ttyS2 115200;ttyS3" | 7 | SERIAL_CONSOLES = "115200;ttyS2 115200;ttyS3" |
8 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | 8 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" |
9 | 9 | ||
10 | KERNEL_DEVICETREE_PREFIX = "ti/k3-j7200" | ||
11 | |||
10 | KERNEL_DEVICETREE = " \ | 12 | KERNEL_DEVICETREE = " \ |
11 | ti/k3-j7200-common-proc-board.dtb \ | 13 | ti/k3-j7200-common-proc-board.dtb \ |
12 | ti/k3-j7200-mcspi-loopback.dtbo \ | ||
13 | ti/k3-j7200-common-proc-board-uarts.dtbo \ | ||
14 | " | 14 | " |
15 | 15 | ||
16 | UBOOT_MACHINE = "j7200_evm_a72_config" | 16 | UBOOT_MACHINE = "j7200_evm_a72_config" |
diff --git a/meta-ti-bsp/conf/machine/j721e-evm.conf b/meta-ti-bsp/conf/machine/j721e-evm.conf index 029b1fe7..f602a77b 100644 --- a/meta-ti-bsp/conf/machine/j721e-evm.conf +++ b/meta-ti-bsp/conf/machine/j721e-evm.conf | |||
@@ -7,33 +7,14 @@ require conf/machine/include/j721e.inc | |||
7 | SERIAL_CONSOLES = "115200;ttyS2 115200;ttyS3" | 7 | SERIAL_CONSOLES = "115200;ttyS2 115200;ttyS3" |
8 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | 8 | SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" |
9 | 9 | ||
10 | KERNEL_DEVICETREE_PREFIX = " \ | ||
11 | ti/k3-j721e \ | ||
12 | ti/k3-j7200-mcspi-loopback \ | ||
13 | " | ||
14 | |||
10 | KERNEL_DEVICETREE = " \ | 15 | KERNEL_DEVICETREE = " \ |
11 | ti/k3-j721e-common-proc-board.dtb \ | 16 | ti/k3-j721e-common-proc-board.dtb \ |
12 | ti/k3-j721e-common-proc-board-infotainment.dtbo \ | ||
13 | ti/k3-j721e-cpb-csi2-ov5640.dtbo \ | ||
14 | ti/k3-j721e-fpdlink-cpb-fusion.dtbo \ | ||
15 | ti/k3-j721e-fpdlink-imx390-cm-0-0.dtbo \ | ||
16 | ti/k3-j721e-fpdlink-imx390-cm-0-1.dtbo \ | ||
17 | ti/k3-j721e-fpdlink-imx390-cm-0-2.dtbo \ | ||
18 | ti/k3-j721e-fpdlink-imx390-cm-0-3.dtbo \ | ||
19 | ti/k3-j721e-fpdlink-imx390-cm-1-0.dtbo \ | ||
20 | ti/k3-j721e-fpdlink-imx390-cm-1-1.dtbo \ | ||
21 | ti/k3-j721e-fpdlink-imx390-cm-1-2.dtbo \ | ||
22 | ti/k3-j721e-fpdlink-imx390-cm-1-3.dtbo \ | ||
23 | ti/k3-j721e-fpdlink-imx390-rcm-0-0.dtbo \ | ||
24 | ti/k3-j721e-fpdlink-imx390-rcm-0-1.dtbo \ | ||
25 | ti/k3-j721e-fpdlink-imx390-rcm-0-2.dtbo \ | ||
26 | ti/k3-j721e-fpdlink-imx390-rcm-0-3.dtbo \ | ||
27 | ti/k3-j721e-fpdlink-imx390-rcm-1-0.dtbo \ | ||
28 | ti/k3-j721e-fpdlink-imx390-rcm-1-1.dtbo \ | ||
29 | ti/k3-j721e-fpdlink-imx390-rcm-1-2.dtbo \ | ||
30 | ti/k3-j721e-fpdlink-imx390-rcm-1-3.dtbo \ | ||
31 | ti/k3-j721e-sk.dtb \ | 17 | ti/k3-j721e-sk.dtb \ |
32 | ti/k3-j721e-fpdlink-sk-fusion.dtbo \ | ||
33 | ti/k3-j721e-sk-csi2-ov5640.dtbo \ | ||
34 | ti/k3-j721e-sk-rpi-cam-imx219.dtbo \ | ||
35 | ti/k3-j721e-common-proc-board-uarts.dtbo \ | ||
36 | ti/k3-j7200-mcspi-loopback.dtbo \ | ||
37 | " | 18 | " |
38 | 19 | ||
39 | UBOOT_MACHINE = "j721e_evm_a72_config" | 20 | UBOOT_MACHINE = "j721e_evm_a72_config" |
diff --git a/meta-ti-bsp/conf/machine/j721s2-evm.conf b/meta-ti-bsp/conf/machine/j721s2-evm.conf index 5a32e1b3..1f54c7b1 100644 --- a/meta-ti-bsp/conf/machine/j721s2-evm.conf +++ b/meta-ti-bsp/conf/machine/j721s2-evm.conf | |||
@@ -9,35 +9,13 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | |||
9 | TFA_K3_USART = "0x8" | 9 | TFA_K3_USART = "0x8" |
10 | OPTEE_K3_USART = "0x8" | 10 | OPTEE_K3_USART = "0x8" |
11 | 11 | ||
12 | KERNEL_DEVICETREE_PREFIX = " \ | ||
13 | ti/k3-j721s2 \ | ||
14 | ti/k3-j7200-mcspi-loopback \ | ||
15 | " | ||
16 | |||
12 | KERNEL_DEVICETREE = " \ | 17 | KERNEL_DEVICETREE = " \ |
13 | ti/k3-am68-sk-base-board.dtb \ | ||
14 | ti/k3-am68-sk-bb-csi2-ov5640.dtbo \ | ||
15 | ti/k3-am68-sk-bb-rpi-cam-imx219.dtbo \ | ||
16 | ti/k3-am68-sk-fpdlink-fusion.dtbo \ | ||
17 | ti/k3-am68-sk-rpi-hdr-ehrpwm.dtbo \ | ||
18 | ti/k3-am68-sk-som-ddr_mem_carveout.dtbo \ | ||
19 | ti/k3-j721e-fpdlink-imx390-cm-0-0.dtbo \ | ||
20 | ti/k3-j721e-fpdlink-imx390-cm-0-1.dtbo \ | ||
21 | ti/k3-j721e-fpdlink-imx390-cm-0-2.dtbo \ | ||
22 | ti/k3-j721e-fpdlink-imx390-cm-0-3.dtbo \ | ||
23 | ti/k3-j721e-fpdlink-imx390-cm-1-0.dtbo \ | ||
24 | ti/k3-j721e-fpdlink-imx390-cm-1-1.dtbo \ | ||
25 | ti/k3-j721e-fpdlink-imx390-cm-1-2.dtbo \ | ||
26 | ti/k3-j721e-fpdlink-imx390-cm-1-3.dtbo \ | ||
27 | ti/k3-j721e-fpdlink-imx390-rcm-0-0.dtbo \ | ||
28 | ti/k3-j721e-fpdlink-imx390-rcm-0-1.dtbo \ | ||
29 | ti/k3-j721e-fpdlink-imx390-rcm-0-2.dtbo \ | ||
30 | ti/k3-j721e-fpdlink-imx390-rcm-0-3.dtbo \ | ||
31 | ti/k3-j721e-fpdlink-imx390-rcm-1-0.dtbo \ | ||
32 | ti/k3-j721e-fpdlink-imx390-rcm-1-1.dtbo \ | ||
33 | ti/k3-j721e-fpdlink-imx390-rcm-1-2.dtbo \ | ||
34 | ti/k3-j721e-fpdlink-imx390-rcm-1-3.dtbo \ | ||
35 | ti/k3-j721s2-common-proc-board.dtb \ | 18 | ti/k3-j721s2-common-proc-board.dtb \ |
36 | ti/k3-j721s2-cpb-csi2-ov5640.dtbo \ | ||
37 | ti/k3-j721s2-fpdlink-cpb-fusion.dtbo \ | ||
38 | ti/k3-j721s2-gesi-exp-board.dtbo \ | ||
39 | ti/k3-j721s2-common-proc-board-uarts.dtbo \ | ||
40 | ti/k3-j7200-mcspi-loopback.dtbo \ | ||
41 | " | 19 | " |
42 | 20 | ||
43 | UBOOT_MACHINE = "j721s2_evm_a72_defconfig" | 21 | UBOOT_MACHINE = "j721s2_evm_a72_defconfig" |
diff --git a/meta-ti-bsp/conf/machine/j784s4-evm.conf b/meta-ti-bsp/conf/machine/j784s4-evm.conf index 84fd4996..53bb4e4f 100644 --- a/meta-ti-bsp/conf/machine/j784s4-evm.conf +++ b/meta-ti-bsp/conf/machine/j784s4-evm.conf | |||
@@ -9,36 +9,13 @@ SERIAL_CONSOLES_CHECK = "${SERIAL_CONSOLES}" | |||
9 | TFA_K3_USART = "0x8" | 9 | TFA_K3_USART = "0x8" |
10 | OPTEE_K3_USART = "0x8" | 10 | OPTEE_K3_USART = "0x8" |
11 | 11 | ||
12 | KERNEL_DEVICETREE = " \ | 12 | KERNEL_DEVICETREE_PREFIX = " \ |
13 | ti/k3-am69-sk.dtb \ | 13 | ti/k3-j784s4 \ |
14 | ti/k3-am69-sk-csi2-ov5640.dtbo \ | 14 | ti/k3-j7200-mcspi-loopback \ |
15 | ti/k3-am69-sk-ddr-mem-carveout.dtbo \ | ||
16 | ti/k3-am69-sk-fpdlink-fusion.dtbo \ | ||
17 | ti/k3-am69-sk-rpi-hdr-ehrpwm.dtbo \ | ||
18 | ti/k3-am69-sk-rpi-cam-imx219.dtbo \ | ||
19 | ti/k3-j721e-fpdlink-imx390-cm-0-0.dtbo \ | ||
20 | ti/k3-j721e-fpdlink-imx390-cm-0-1.dtbo \ | ||
21 | ti/k3-j721e-fpdlink-imx390-cm-0-2.dtbo \ | ||
22 | ti/k3-j721e-fpdlink-imx390-cm-0-3.dtbo \ | ||
23 | ti/k3-j721e-fpdlink-imx390-cm-1-0.dtbo \ | ||
24 | ti/k3-j721e-fpdlink-imx390-cm-1-1.dtbo \ | ||
25 | ti/k3-j721e-fpdlink-imx390-cm-1-2.dtbo \ | ||
26 | ti/k3-j721e-fpdlink-imx390-cm-1-3.dtbo \ | ||
27 | ti/k3-j721e-fpdlink-imx390-rcm-0-0.dtbo \ | ||
28 | ti/k3-j721e-fpdlink-imx390-rcm-0-1.dtbo \ | ||
29 | ti/k3-j721e-fpdlink-imx390-rcm-0-2.dtbo \ | ||
30 | ti/k3-j721e-fpdlink-imx390-rcm-0-3.dtbo \ | ||
31 | ti/k3-j721e-fpdlink-imx390-rcm-1-0.dtbo \ | ||
32 | ti/k3-j721e-fpdlink-imx390-rcm-1-1.dtbo \ | ||
33 | ti/k3-j721e-fpdlink-imx390-rcm-1-2.dtbo \ | ||
34 | ti/k3-j721e-fpdlink-imx390-rcm-1-3.dtbo \ | ||
35 | ti/k3-j784s4-evm.dtb \ | ||
36 | ti/k3-j784s4-evm-csi2-ov5640.dtbo \ | ||
37 | ti/k3-j784s4-fpdlink-fusion.dtbo \ | ||
38 | ti/k3-j784s4-evm-uarts.dtbo \ | ||
39 | ti/k3-j7200-mcspi-loopback.dtbo \ | ||
40 | " | 15 | " |
41 | 16 | ||
17 | KERNEL_DEVICETREE = "" | ||
18 | |||
42 | UBOOT_MACHINE = "j784s4_evm_a72_defconfig" | 19 | UBOOT_MACHINE = "j784s4_evm_a72_defconfig" |
43 | 20 | ||
44 | # Default tiboot3.bin on J784S4 is for GP | 21 | # Default tiboot3.bin on J784S4 is for GP |
diff --git a/meta-ti-bsp/conf/machine/omapl138-lcdk.conf b/meta-ti-bsp/conf/machine/omapl138-lcdk.conf index b318f82d..a8b08964 100644 --- a/meta-ti-bsp/conf/machine/omapl138-lcdk.conf +++ b/meta-ti-bsp/conf/machine/omapl138-lcdk.conf | |||
@@ -15,4 +15,9 @@ IMAGE_FSTYPES += "tar.xz" | |||
15 | 15 | ||
16 | SERIAL_CONSOLES = "115200;ttyS2" | 16 | SERIAL_CONSOLES = "115200;ttyS2" |
17 | 17 | ||
18 | KERNEL_DEVICETREE = "da850-evm.dtb da850-lcdk.dtb" | 18 | KERNEL_DEVICETREE_PREFIX = "da850" |
19 | |||
20 | KERNEL_DEVICETREE = " \ | ||
21 | da850-evm.dtb \ | ||
22 | da850-lcdk.dtb \ | ||
23 | " | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb index 6c1b1825..be278d73 100644 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-mainline_git.bb | |||
@@ -39,34 +39,11 @@ SRC_URI += " \ | |||
39 | SRCREV_ti-upstream-tools = "0f60697843bba6f8d721b14da92b1652563ccb95" | 39 | SRCREV_ti-upstream-tools = "0f60697843bba6f8d721b14da92b1652563ccb95" |
40 | SRCREV_FORMAT = "linux" | 40 | SRCREV_FORMAT = "linux" |
41 | 41 | ||
42 | KERNEL_DEVICETREE = "" | ||
43 | |||
44 | kernel_do_compile:append() { | 42 | kernel_do_compile:append() { |
45 | oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} | 43 | oe_runmake dtbs CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} |
46 | oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} | 44 | oe_runmake -C ${S}/ti-upstream-tools LINUX=${S} DTC=${B}/scripts/dtc/dtc O=${B} CC="${KERNEL_CC} $cc_extra " LD="${KERNEL_LD}" ${KERNEL_EXTRA_ARGS} |
47 | } | 45 | } |
48 | 46 | ||
49 | do_install:append() { | ||
50 | for dtbf in `find arch/${ARCH}/boot/dts/ \( -name '*.dtb' -or -name '*.dtbo' \)`; do | ||
51 | dtb="$dtbf" | ||
52 | dtb_ext=${dtb##*.} | ||
53 | dtb_base_name=`basename $dtb .$dtb_ext` | ||
54 | dtb_path=`get_real_dtb_path_in_kernel "$dtb"` | ||
55 | install -m 0644 $dtbf ${D}/${KERNEL_IMAGEDEST}/$dtb_base_name.$dtb_ext | ||
56 | done | ||
57 | } | ||
58 | |||
59 | do_deploy:append() { | ||
60 | for dtbf in `find arch/${ARCH}/boot/dts/ \( -name '*.dtb' -or -name '*.dtbo' \) -printf '%P\n'`; do | ||
61 | dtb="$dtbf" | ||
62 | dtb_ext=${dtb##*.} | ||
63 | dtb_base_name=`basename $dtb .$dtb_ext` | ||
64 | dtb_dir=`dirname $dtb` | ||
65 | install -d ${DEPLOYDIR} | ||
66 | install -m 0644 ${D}/${KERNEL_IMAGEDEST}/$dtb_base_name.$dtb_ext ${DEPLOYDIR}/$dtb_base_name.$dtb_ext | ||
67 | done | ||
68 | } | ||
69 | |||
70 | do_shared_workdir:prepend() { | 47 | do_shared_workdir:prepend() { |
71 | cd ${B} | 48 | cd ${B} |
72 | echo >> Module.symvers | 49 | echo >> Module.symvers |
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb index e2908951..b540e508 100644 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb | |||
@@ -19,21 +19,6 @@ PV = "6.1.0-rc1+git${SRCPV}" | |||
19 | 19 | ||
20 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git;protocol=https;branch=master" | 20 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git;protocol=https;branch=master" |
21 | 21 | ||
22 | def list_dtbs(dts_dir, dts_subdir): | ||
23 | import os | ||
24 | import fnmatch | ||
25 | matches = [] | ||
26 | |||
27 | for root,dirnames,filenames in os.walk(os.path.join(dts_dir, dts_subdir)): | ||
28 | for filename in fnmatch.filter(filenames, '*.dtb'): | ||
29 | matches.append(os.path.join(dts_subdir, filename)) | ||
30 | for filename in fnmatch.filter(filenames, '*.dtbo'): | ||
31 | matches.append(os.path.join(dts_subdir, filename)) | ||
32 | return ' '.join(matches) | ||
33 | |||
34 | DTS_SUBDIR = "" | ||
35 | DTS_SUBDIR:k3 = "ti" | ||
36 | KERNEL_DEVICETREE = "${@list_dtbs('${B}/arch/${ARCH}/boot/dts', '${DTS_SUBDIR}')}" | ||
37 | DEFCONFIG_NAME = "multi_v7_defconfig" | 22 | DEFCONFIG_NAME = "multi_v7_defconfig" |
38 | DEFCONFIG_NAME:k3 = "defconfig" | 23 | DEFCONFIG_NAME:k3 = "defconfig" |
39 | KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}" | 24 | KERNEL_CONFIG_COMMAND = "oe_runmake -C ${S} O=${B} ${DEFCONFIG_NAME}" |
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb index f3793baf..2da66b67 100644 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_5.10.bb | |||
@@ -11,6 +11,7 @@ DEFCONFIG_BUILDER = "${S}/ti_config_fragments/defconfig_builder.sh" | |||
11 | require recipes-kernel/linux/setup-defconfig.inc | 11 | require recipes-kernel/linux/setup-defconfig.inc |
12 | require recipes-kernel/linux/kernel-rdepends.inc | 12 | require recipes-kernel/linux/kernel-rdepends.inc |
13 | require recipes-kernel/linux/ti-kernel.inc | 13 | require recipes-kernel/linux/ti-kernel.inc |
14 | include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} | ||
14 | 15 | ||
15 | DEPENDS += "gmp-native libmpc-native" | 16 | DEPENDS += "gmp-native libmpc-native" |
16 | 17 | ||
diff --git a/meta-ti-bsp/recipes-kernel/linux/ti-kernel-devicetree-prefix.inc b/meta-ti-bsp/recipes-kernel/linux/ti-kernel-devicetree-prefix.inc new file mode 100644 index 00000000..1496a749 --- /dev/null +++ b/meta-ti-bsp/recipes-kernel/linux/ti-kernel-devicetree-prefix.inc | |||
@@ -0,0 +1,22 @@ | |||
1 | |||
2 | def get_dtbs_from_kernel(dts_dir, dts_prefix): | ||
3 | import os | ||
4 | import glob | ||
5 | matches = [] | ||
6 | |||
7 | for prefix in dts_prefix.split(): | ||
8 | filenames = glob.glob(dts_dir + prefix + '*.dts') | ||
9 | filenames += glob.glob(dts_dir + prefix + '*.dtso') | ||
10 | for filename in filenames: | ||
11 | # Before v6.2 kernels DTB Overlays shared the same name as DTB files | ||
12 | # so we need to search the file to find the type | ||
13 | with open(filename) as f: | ||
14 | file_postfix = '.dtbo' if '/plugin/;' in f.read() else '.dtb' | ||
15 | filename = os.path.split(filename)[1] | ||
16 | filename = os.path.splitext(filename)[0] + file_postfix | ||
17 | filename = os.path.join(os.path.split(prefix)[0], filename) | ||
18 | matches.append(filename) | ||
19 | return ' '.join(matches) | ||
20 | |||
21 | KERNEL_DEVICETREE = "${@get_dtbs_from_kernel('${S}/arch/${ARCH}/boot/dts/', '${KERNEL_DEVICETREE_PREFIX}')} ${KERNEL_DEVICETREE_DTBMERGE}" | ||
22 | |||