diff options
author | Denys Dmytriyenko <denys@konsulko.com> | 2022-05-04 19:41:18 +0000 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2022-05-05 14:24:13 -0500 |
commit | aedd163c79fe4f11b9bc28924fc01dde04123e56 (patch) | |
tree | 35e08501fd445e2d2d003a4636e57b55b4ad178a | |
parent | 0547c442d2e1a816a947bdab8163565986fe0f73 (diff) | |
download | meta-ti-aedd163c79fe4f11b9bc28924fc01dde04123e56.tar.gz |
optee-os, trusted-firmware-a: add leading whitespace when using append override
As append override does not add any whitespaces, it could lead to potential
issues when two items in space-separated list get concatenated. It is always
recommended to add a leading whitespace in such cases, like EXTRA_OEMAKE.
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend | 2 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend | 2 |
2 files changed, 2 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend index 35cb9c95..5a2b4510 100644 --- a/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend +++ b/meta-ti-bsp/recipes-bsp/trusted-firmware-a/trusted-firmware-a_%.bbappend | |||
@@ -8,7 +8,7 @@ TFA_BUILD_TARGET:k3 = "all" | |||
8 | TFA_INSTALL_TARGET:k3 = "bl31" | 8 | TFA_INSTALL_TARGET:k3 = "bl31" |
9 | TFA_SPD:k3 = "opteed" | 9 | TFA_SPD:k3 = "opteed" |
10 | 10 | ||
11 | EXTRA_OEMAKE:append:k3 = "${@ 'K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}" | 11 | EXTRA_OEMAKE:append:k3 = "${@ ' K3_USART=' + d.getVar('TFA_K3_USART') if d.getVar('TFA_K3_USART') else ''}" |
12 | 12 | ||
13 | do_compile:append:am65xx-hs-evm() { | 13 | do_compile:append:am65xx-hs-evm() { |
14 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | 14 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} |
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend index 5af57e16..6097580f 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend +++ b/meta-ti-bsp/recipes-security/optee/optee-os_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | EXTRA_OEMAKE:append:k3 = "${@ 'CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" | 1 | EXTRA_OEMAKE:append:k3 = "${@ ' CFG_CONSOLE_UART='+ d.getVar('OPTEE_K3_USART') if d.getVar('OPTEE_K3_USART') else ''}" |
2 | 2 | ||
3 | do_compile:prepend:ti-soc() { | 3 | do_compile:prepend:ti-soc() { |
4 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} | 4 | export TI_SECURE_DEV_PKG=${TI_SECURE_DEV_PKG} |