diff options
author | Ryan Eatmon <reatmon@ti.com> | 2023-11-07 09:20:15 -0600 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-11-07 09:20:15 -0600 |
commit | 3963101e67de04d5efe162d30a57631e9c6f193c (patch) | |
tree | 64670322dd39822484a7a3a3627373e14d17c2a8 | |
parent | a12149c56d7305656a491e0596583b1c05be9fc4 (diff) | |
download | meta-ti-3963101e67de04d5efe162d30a57631e9c6f193c.tar.gz |
optee: Rework include files
Minor rework of the TI include files used to override both SRCREV and
other settings in the optee recipes for TI SOC parts. The intent is to
make it more clear when we are changing SRCREVs versus changing other
items, and allow for sharing the SRCREV changes for optee-os-tadevkit
which should track the optee-os SRCREV.
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
12 files changed, 34 insertions, 26 deletions
diff --git a/meta-ti-bsp/recipes-security/optee/optee-client-ti.inc b/meta-ti-bsp/recipes-security/optee/optee-client-ti-overrides.inc index f64a90c3..90fc70aa 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-client-ti.inc +++ b/meta-ti-bsp/recipes-security/optee/optee-client-ti-overrides.inc | |||
@@ -1,6 +1,3 @@ | |||
1 | PV = "4.0.0+git${SRCPV}" | ||
2 | SRCREV = "acb0885c117e73cb6c5c9b1dd9054cb3f93507ee" | ||
3 | |||
4 | inherit pkgconfig | 1 | inherit pkgconfig |
5 | DEPENDS += "util-linux" | 2 | DEPENDS += "util-linux" |
6 | 3 | ||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-client-ti-version.inc b/meta-ti-bsp/recipes-security/optee/optee-client-ti-version.inc new file mode 100644 index 00000000..0da37acf --- /dev/null +++ b/meta-ti-bsp/recipes-security/optee/optee-client-ti-version.inc | |||
@@ -0,0 +1,2 @@ | |||
1 | PV = "4.0.0+git${SRCPV}" | ||
2 | SRCREV = "acb0885c117e73cb6c5c9b1dd9054cb3f93507ee" | ||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-client_3.16%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-client_3.16%.bbappend index 08c5256b..0cee127f 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-client_3.16%.bbappend +++ b/meta-ti-bsp/recipes-security/optee/optee-client_3.16%.bbappend | |||
@@ -1,4 +1,9 @@ | |||
1 | OPTEE_TI = "" | 1 | OPTEE_TI_VERSION = "" |
2 | OPTEE_TI:ti-soc = "${BPN}-ti.inc" | 2 | OPTEE_TI_VERSION:ti-soc = "${BPN}-ti-version.inc" |
3 | 3 | ||
4 | require ${OPTEE_TI} | 4 | require ${OPTEE_TI_VERSION} |
5 | |||
6 | OPTEE_TI_OVERRIDES = "" | ||
7 | OPTEE_TI_OVERRIDES:ti-soc = "${BPN}-ti-overrides.inc" | ||
8 | |||
9 | require ${OPTEE_TI_OVERRIDES} | ||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-examples-ti.inc b/meta-ti-bsp/recipes-security/optee/optee-examples-ti-version.inc index 7a733f53..7a733f53 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-examples-ti.inc +++ b/meta-ti-bsp/recipes-security/optee/optee-examples-ti-version.inc | |||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend index 08c5256b..f193e78b 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend +++ b/meta-ti-bsp/recipes-security/optee/optee-examples_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | OPTEE_TI = "" | 1 | OPTEE_TI_VERSION = "" |
2 | OPTEE_TI:ti-soc = "${BPN}-ti.inc" | 2 | OPTEE_TI_VERSION:ti-soc = "${BPN}-ti-version.inc" |
3 | 3 | ||
4 | require ${OPTEE_TI} | 4 | require ${OPTEE_TI_VERSION} |
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend index 08c5256b..17856dc3 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend +++ b/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit_%.bbappend | |||
@@ -1,4 +1,4 @@ | |||
1 | OPTEE_TI = "" | 1 | OPTEE_TI_VERSION = "" |
2 | OPTEE_TI:ti-soc = "${BPN}-ti.inc" | 2 | OPTEE_TI_VERSION:ti-soc = "optee-os-ti-version.inc" |
3 | 3 | ||
4 | require ${OPTEE_TI} | 4 | require ${OPTEE_TI_VERSION} |
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc b/meta-ti-bsp/recipes-security/optee/optee-os-ti-overrides.inc index 91b66a36..b1846cad 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-os-ti.inc +++ b/meta-ti-bsp/recipes-security/optee/optee-os-ti-overrides.inc | |||
@@ -1,6 +1,3 @@ | |||
1 | PV = "4.0.0+git${SRCPV}" | ||
2 | SRCREV = "2a5b1d1232f582056184367fb58a425ac7478ec6" | ||
3 | |||
4 | # Use TI SECDEV for signing | 1 | # Use TI SECDEV for signing |
5 | inherit ti-secdev | 2 | inherit ti-secdev |
6 | 3 | ||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit-ti.inc b/meta-ti-bsp/recipes-security/optee/optee-os-ti-version.inc index c1354539..2e4e53b7 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-os-tadevkit-ti.inc +++ b/meta-ti-bsp/recipes-security/optee/optee-os-ti-version.inc | |||
@@ -1,3 +1,2 @@ | |||
1 | PV = "4.0.0+git${SRCPV}" | 1 | PV = "4.0.0+git${SRCPV}" |
2 | SRCREV = "2a5b1d1232f582056184367fb58a425ac7478ec6" | 2 | SRCREV = "2a5b1d1232f582056184367fb58a425ac7478ec6" |
3 | |||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend index 08c5256b..0cee127f 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend +++ b/meta-ti-bsp/recipes-security/optee/optee-os_3.16%.bbappend | |||
@@ -1,4 +1,9 @@ | |||
1 | OPTEE_TI = "" | 1 | OPTEE_TI_VERSION = "" |
2 | OPTEE_TI:ti-soc = "${BPN}-ti.inc" | 2 | OPTEE_TI_VERSION:ti-soc = "${BPN}-ti-version.inc" |
3 | 3 | ||
4 | require ${OPTEE_TI} | 4 | require ${OPTEE_TI_VERSION} |
5 | |||
6 | OPTEE_TI_OVERRIDES = "" | ||
7 | OPTEE_TI_OVERRIDES:ti-soc = "${BPN}-ti-overrides.inc" | ||
8 | |||
9 | require ${OPTEE_TI_OVERRIDES} | ||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-test-ti.inc b/meta-ti-bsp/recipes-security/optee/optee-test-ti-overrides.inc index b68caf0c..6bbb0bfa 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-test-ti.inc +++ b/meta-ti-bsp/recipes-security/optee/optee-test-ti-overrides.inc | |||
@@ -1,6 +1,2 @@ | |||
1 | PV = "4.0.0+git${SRCPV}" | ||
2 | SRCREV = "1c3d6be5eaa6174e3dbabf60928d15628e39b994" | ||
3 | |||
4 | EXTRA_OEMAKE:append = " OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}" | 1 | EXTRA_OEMAKE:append = " OPTEE_OPENSSL_EXPORT=${STAGING_INCDIR}" |
5 | DEPENDS:append = " openssl" | 2 | DEPENDS:append = " openssl" |
6 | |||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-test-ti-version.inc b/meta-ti-bsp/recipes-security/optee/optee-test-ti-version.inc new file mode 100644 index 00000000..48231a66 --- /dev/null +++ b/meta-ti-bsp/recipes-security/optee/optee-test-ti-version.inc | |||
@@ -0,0 +1,2 @@ | |||
1 | PV = "4.0.0+git${SRCPV}" | ||
2 | SRCREV = "1c3d6be5eaa6174e3dbabf60928d15628e39b994" | ||
diff --git a/meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend b/meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend index 08c5256b..0cee127f 100644 --- a/meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend +++ b/meta-ti-bsp/recipes-security/optee/optee-test_%.bbappend | |||
@@ -1,4 +1,9 @@ | |||
1 | OPTEE_TI = "" | 1 | OPTEE_TI_VERSION = "" |
2 | OPTEE_TI:ti-soc = "${BPN}-ti.inc" | 2 | OPTEE_TI_VERSION:ti-soc = "${BPN}-ti-version.inc" |
3 | 3 | ||
4 | require ${OPTEE_TI} | 4 | require ${OPTEE_TI_VERSION} |
5 | |||
6 | OPTEE_TI_OVERRIDES = "" | ||
7 | OPTEE_TI_OVERRIDES:ti-soc = "${BPN}-ti-overrides.inc" | ||
8 | |||
9 | require ${OPTEE_TI_OVERRIDES} | ||