summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@konsulko.com>2023-10-20 20:44:57 +0000
committerRyan Eatmon <reatmon@ti.com>2023-10-20 17:34:11 -0500
commitacd8ab87dfe9f3afdd20db207e7ea65556fcd502 (patch)
treee446e92f621f2256b804ffabf905e3f2915d92be
parentbbd550a8e5fa209c2daeb50f28864767c77f95e8 (diff)
downloadmeta-ti-acd8ab87dfe9f3afdd20db207e7ea65556fcd502.tar.gz
u-boot-bb.org: add back Beagle-specific U-boot 2023.04
Majority of Beagle devices use ti-u-boot repo from u-boot-ti-staging directly. But some latest devices may need to point to own tree with additional support added that is not yet upstream, e.g. BeaglePlay. Add the Beagle-specific recipe and point beagleplay to use it. Other devices can switch to using it as well, if desired, but right now the code base is the same for other Beagle devices. Signed-off-by: Denys Dmytriyenko <denys@konsulko.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/beagleplay-k3r5.conf3
-rw-r--r--meta-ti-bsp/conf/machine/beagleplay.conf2
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-bb.org_git.bb17
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-ti-bsp/conf/machine/beagleplay-k3r5.conf b/meta-ti-bsp/conf/machine/beagleplay-k3r5.conf
index f8f08d63..c40615c9 100644
--- a/meta-ti-bsp/conf/machine/beagleplay-k3r5.conf
+++ b/meta-ti-bsp/conf/machine/beagleplay-k3r5.conf
@@ -4,6 +4,9 @@
4 4
5require conf/machine/include/k3r5.inc 5require conf/machine/include/k3r5.inc
6 6
7PREFERRED_PROVIDER_virtual/bootloader = "u-boot-bb.org"
8PREFERRED_PROVIDER_u-boot = "u-boot-bb.org"
9
7SYSFW_SOC = "am62x" 10SYSFW_SOC = "am62x"
8SYSFW_CONFIG = "evm" 11SYSFW_CONFIG = "evm"
9SYSFW_SUFFIX = "gp" 12SYSFW_SUFFIX = "gp"
diff --git a/meta-ti-bsp/conf/machine/beagleplay.conf b/meta-ti-bsp/conf/machine/beagleplay.conf
index 106019c4..6a0f697f 100644
--- a/meta-ti-bsp/conf/machine/beagleplay.conf
+++ b/meta-ti-bsp/conf/machine/beagleplay.conf
@@ -21,6 +21,8 @@ OPTEEMACHINE = "k3-am62x"
21UBOOT_MACHINE = "am62x_evm_a53_defconfig" 21UBOOT_MACHINE = "am62x_evm_a53_defconfig"
22 22
23PREFERRED_PROVIDER_virtual/kernel = "linux-bb.org" 23PREFERRED_PROVIDER_virtual/kernel = "linux-bb.org"
24PREFERRED_PROVIDER_virtual/bootloader = "u-boot-bb.org"
25PREFERRED_PROVIDER_u-boot = "u-boot-bb.org"
24 26
25KERNEL_DEVICETREE = " \ 27KERNEL_DEVICETREE = " \
26ti/k3-am625-beagleplay.dtb \ 28ti/k3-am625-beagleplay.dtb \
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-bb.org_git.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-bb.org_git.bb
new file mode 100644
index 00000000..5bb20213
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-bb.org_git.bb
@@ -0,0 +1,17 @@
1require u-boot-ti.inc
2
3SUMMARY = "BeagleBoard.org U-Boot"
4
5COMPATIBLE_MACHINE = "beagle.*"
6
7PV = "2023.04"
8
9UBOOT_GIT_URI = "git://github.com/beagleboard/u-boot.git"
10UBOOT_GIT_PROTOCOL = "https"
11BRANCH = "v2023.04-ti-09.00.00.011"
12SRCREV = "4b8f8be8870f03d92a2b01d0d30ab912118adc82"
13
14BRANCH:beagleplay = "v2023.04-ti-09.00.00.011-BeaglePlay"
15BRANCH:beagleplay-k3r5 = "v2023.04-ti-09.00.00.011-BeaglePlay"
16SRCREV:beagleplay = "10afea462ea1113701f6f0f8853fdff985aa275d"
17SRCREV:beagleplay-k3r5 = "10afea462ea1113701f6f0f8853fdff985aa275d"