diff options
author | Ryan Eatmon <reatmon@ti.com> | 2023-07-27 10:12:16 -0500 |
---|---|---|
committer | Ryan Eatmon <reatmon@ti.com> | 2023-07-31 22:18:51 -0500 |
commit | 929868924784d7897bdb954e6a49b2063ee526f6 (patch) | |
tree | 443dc6b644a99e3f2512cde4a122b38cac842beb | |
parent | 57b7b11a503754b433b156918c9ce9bbb858b09f (diff) | |
download | meta-ti-929868924784d7897bdb954e6a49b2063ee526f6.tar.gz |
linux-ti-next,conf/machine: Add support for new vendored dts dir
The latest kernel has made the change to add vendor subdirectories into
the arch/arm/boot/dts directory. This effectively breaks the
KERNEL_DEVICETREE settings in the machine configs for 32bit platforms,
so switch them over to using the PREFIX variable. Also change the
linux-ti-next to use the PREFIX setting for KERNEL_DEVICETREE.
Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r-- | meta-ti-bsp/conf/machine/am57xx-evm.conf | 3 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/dra7xx-evm.conf | 1 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/include/ti33x.inc | 5 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/include/ti43x.inc | 2 | ||||
-rw-r--r-- | meta-ti-bsp/conf/machine/omapl138-lcdk.conf | 5 | ||||
-rw-r--r-- | meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb | 1 |
6 files changed, 15 insertions, 2 deletions
diff --git a/meta-ti-bsp/conf/machine/am57xx-evm.conf b/meta-ti-bsp/conf/machine/am57xx-evm.conf index 26b7f78c..43a6a833 100644 --- a/meta-ti-bsp/conf/machine/am57xx-evm.conf +++ b/meta-ti-bsp/conf/machine/am57xx-evm.conf | |||
@@ -13,11 +13,14 @@ KERNEL_DEVICETREE_PREFIX = " \ | |||
13 | ti/am57 \ | 13 | ti/am57 \ |
14 | ti/lcd \ | 14 | ti/lcd \ |
15 | ti/ov10635 \ | 15 | ti/ov10635 \ |
16 | ti/omap/am57 \ | ||
16 | " | 17 | " |
17 | 18 | ||
18 | KERNEL_DEVICETREE_DTBMERGE = " \ | 19 | KERNEL_DEVICETREE_DTBMERGE = " \ |
19 | am57xx-evm.dtb \ | 20 | am57xx-evm.dtb \ |
20 | am57xx-evm-reva3.dtb \ | 21 | am57xx-evm-reva3.dtb \ |
22 | ti/omap/am57xx-evm.dtb \ | ||
23 | ti/omap/am57xx-evm-reva3.dtb \ | ||
21 | " | 24 | " |
22 | 25 | ||
23 | KERNEL_DEVICETREE = " \ | 26 | KERNEL_DEVICETREE = " \ |
diff --git a/meta-ti-bsp/conf/machine/dra7xx-evm.conf b/meta-ti-bsp/conf/machine/dra7xx-evm.conf index c47a1e80..30884ae1 100644 --- a/meta-ti-bsp/conf/machine/dra7xx-evm.conf +++ b/meta-ti-bsp/conf/machine/dra7xx-evm.conf | |||
@@ -12,6 +12,7 @@ KERNEL_DEVICETREE_PREFIX = " \ | |||
12 | dra7 \ | 12 | dra7 \ |
13 | ti/dra7 \ | 13 | ti/dra7 \ |
14 | ti/lcd \ | 14 | ti/lcd \ |
15 | ti/omap/dra7 \ | ||
15 | " | 16 | " |
16 | 17 | ||
17 | KERNEL_DEVICETREE = " \ | 18 | KERNEL_DEVICETREE = " \ |
diff --git a/meta-ti-bsp/conf/machine/include/ti33x.inc b/meta-ti-bsp/conf/machine/include/ti33x.inc index f7f126f4..bc61a773 100644 --- a/meta-ti-bsp/conf/machine/include/ti33x.inc +++ b/meta-ti-bsp/conf/machine/include/ti33x.inc | |||
@@ -19,7 +19,10 @@ PVR_DISPLAY_CONTROLLER_ALIAS ?= "tilcdc" | |||
19 | 19 | ||
20 | KERNEL_IMAGETYPE = "zImage" | 20 | KERNEL_IMAGETYPE = "zImage" |
21 | 21 | ||
22 | KERNEL_DEVICETREE_PREFIX = "am335x" | 22 | KERNEL_DEVICETREE_PREFIX = " \ |
23 | am335x \ | ||
24 | ti/omap/am335x \ | ||
25 | " | ||
23 | 26 | ||
24 | KERNEL_DEVICETREE = " \ | 27 | KERNEL_DEVICETREE = " \ |
25 | am335x-evm.dtb \ | 28 | am335x-evm.dtb \ |
diff --git a/meta-ti-bsp/conf/machine/include/ti43x.inc b/meta-ti-bsp/conf/machine/include/ti43x.inc index a6af56e3..ea5d1505 100644 --- a/meta-ti-bsp/conf/machine/include/ti43x.inc +++ b/meta-ti-bsp/conf/machine/include/ti43x.inc | |||
@@ -22,6 +22,8 @@ KERNEL_IMAGETYPE = "zImage" | |||
22 | KERNEL_DEVICETREE_PREFIX = " \ | 22 | KERNEL_DEVICETREE_PREFIX = " \ |
23 | am437x \ | 23 | am437x \ |
24 | am43x \ | 24 | am43x \ |
25 | ti/omap/am437x \ | ||
26 | ti/omap/am43x \ | ||
25 | " | 27 | " |
26 | 28 | ||
27 | KERNEL_DEVICETREE = " \ | 29 | KERNEL_DEVICETREE = " \ |
diff --git a/meta-ti-bsp/conf/machine/omapl138-lcdk.conf b/meta-ti-bsp/conf/machine/omapl138-lcdk.conf index a8b08964..fdbaffae 100644 --- a/meta-ti-bsp/conf/machine/omapl138-lcdk.conf +++ b/meta-ti-bsp/conf/machine/omapl138-lcdk.conf | |||
@@ -15,7 +15,10 @@ IMAGE_FSTYPES += "tar.xz" | |||
15 | 15 | ||
16 | SERIAL_CONSOLES = "115200;ttyS2" | 16 | SERIAL_CONSOLES = "115200;ttyS2" |
17 | 17 | ||
18 | KERNEL_DEVICETREE_PREFIX = "da850" | 18 | KERNEL_DEVICETREE_PREFIX = " \ |
19 | da850 \ | ||
20 | ti/davinci/da850 \ | ||
21 | " | ||
19 | 22 | ||
20 | KERNEL_DEVICETREE = " \ | 23 | KERNEL_DEVICETREE = " \ |
21 | da850-evm.dtb \ | 24 | da850-evm.dtb \ |
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb index 9138c7c5..8228f4ff 100644 --- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb +++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-next_git.bb | |||
@@ -6,6 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=6bc538ed5bd9a7fc9398086aedcd7e46" | |||
6 | inherit kernel | 6 | inherit kernel |
7 | 7 | ||
8 | require recipes-kernel/linux/ti-kernel.inc | 8 | require recipes-kernel/linux/ti-kernel.inc |
9 | include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} | ||
9 | 10 | ||
10 | DEPENDS += "gmp-native libmpc-native" | 11 | DEPENDS += "gmp-native libmpc-native" |
11 | 12 | ||