summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAniket Limaye <a-limaye@ti.com>2023-10-04 12:04:30 +0530
committerRyan Eatmon <reatmon@ti.com>2023-10-05 12:08:25 -0500
commit6fe2ea45e66f481faf99ddc113cc946531cd0783 (patch)
treef6b14f0b3308d3a557351c21879af779b74b83e4
parent01bd31052e132b43e1445f1fb0fc91920728c7cd (diff)
downloadmeta-ti-6fe2ea45e66f481faf99ddc113cc946531cd0783.tar.gz
ti-dm-dw: Preserve structure of the deployed ti-dm-fw binaries
Preserve the directory structure of the deployed dm firmware so that one can directly specify the deploy directory for binman based u-boot build. Additionally, this makes it easier to preserve the same structure inside the prebuilt-images directory of the tisdk-core-bundle for the same reason. Signed-off-by: Aniket Limaye <a-limaye@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
index f635565d..49638ee9 100644
--- a/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
+++ b/meta-ti-bsp/recipes-bsp/ti-dm-fw/ti-dm-fw.bb
@@ -67,11 +67,11 @@ do_install() {
67 67
68do_deploy() { 68do_deploy() {
69 # DM Firmware is needed for rebuilding U-Boot 69 # DM Firmware is needed for rebuilding U-Boot
70 install -d ${DEPLOYDIR} 70 install -d ${DEPLOYDIR}/${DM_FW_DIR}
71 for FW_NAME in ${DM_FW_LIST} 71 for FW_NAME in ${DM_FW_LIST}
72 do 72 do
73 install -m 0644 ${S}/${DM_FW_DIR}/${FW_NAME} ${DEPLOYDIR}/ 73 install -m 0644 ${S}/${DM_FW_DIR}/${FW_NAME} ${DEPLOYDIR}/${DM_FW_DIR}
74 install -m 0644 ${S}/${DM_FW_DIR}/${FW_NAME}.signed ${DEPLOYDIR}/ 74 install -m 0644 ${S}/${DM_FW_DIR}/${FW_NAME}.signed ${DEPLOYDIR}/${DM_FW_DIR}
75 done 75 done
76} 76}
77 77