summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRandolph Sapp <rs@ti.com>2023-10-16 21:29:49 -0500
committerRyan Eatmon <reatmon@ti.com>2023-10-17 21:58:11 -0500
commit213928ec15ff35d92a7bc9f7f36ae64a3f50dd5d (patch)
tree12725a9c0d07b13dc970d1a96c4b18b8f3dc34b8
parentfdc7c0a03bf80570fa8692dfad48eca533617206 (diff)
downloadmeta-ti-213928ec15ff35d92a7bc9f7f36ae64a3f50dd5d.tar.gz
ti-sgx-ddk-*: version bump to support kirkstone
Bump ti-sgx-ddk-um and ti-sgx-ddk-km to the new branch for Kirkstone and mesa independent builds. This also sets up SGX to use the latest mesa revision rogue uses. Changelog: - IMG Support has officially ended. This repo will not be getting regular updates after this unless things are really broken. - The Mesa patches which were previously being relicensed internally were opened and combined with the unofficial rogue efforts on freedesktop. - Toolchains were upgraded and multiple warnings and issues were addressed. Hardware recoveries work now, but there are still some longstanding issues with SGX that remain to be addressed if further resources are set aside for that. - We moved to an lws-generic build target to avoid rebuilding external components. As such, these external components must be patched as needed. Libdrm is an example of this and the required patches can be found in meta-ti. Known bugs: - Buffer allocations under Weston may misbehave - GLSL macro redefinitions will cause errors regardless of whether or not they are identical Signed-off-by: Randolph Sapp <rs@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb27
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um/pvrsrvkm.rules1
-rw-r--r--meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb53
3 files changed, 32 insertions, 49 deletions
diff --git a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
index bf4fa98a..ca28ae76 100644
--- a/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
+++ b/meta-ti-bsp/recipes-bsp/powervr-drivers/ti-sgx-ddk-km_1.17.4948957.bb
@@ -1,7 +1,7 @@
1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the TI SoCs" 1DESCRIPTION = "Kernel drivers for the PowerVR SGX chipset found in the TI SoCs"
2HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux" 2HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-linux"
3LICENSE = "MIT | GPL-2.0-only" 3LICENSE = "MIT | GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://eurasia_km/README;beginline=13;endline=22;md5=74506d9b8e5edbce66c2747c50fcef12" 4LIC_FILES_CHKSUM = "file://GPL-COPYING;md5=60422928ba677faaa13d6ab5f5baaa1e"
5 5
6inherit module 6inherit module
7 7
@@ -16,33 +16,30 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
16 16
17DEPENDS = "virtual/kernel" 17DEPENDS = "virtual/kernel"
18 18
19BRANCH = "ti-img-sgx/${PV}/k5.10" 19BRANCH = "${PV}/mesa/k6.1"
20 20
21SRC_URI = "git://git.ti.com/git/graphics/omap5-sgx-ddk-linux.git;protocol=https;branch=${BRANCH}" 21SRC_URI = "git://git.ti.com/git/graphics/omap5-sgx-ddk-linux.git;protocol=https;branch=${BRANCH}"
22 22
23S = "${WORKDIR}/git" 23S = "${WORKDIR}/git"
24 24
25SRCREV = "eda7780bfd5277e16913c9bc0b0e6892b4e79063" 25SRCREV = "2cb2c9609b7740cb2c348e669a96f26e1cc858da"
26 26
27TARGET_PRODUCT:omap-a15 = "jacinto6evm" 27TARGET_PRODUCT:omap-a15 = "ti572x_linux"
28TARGET_PRODUCT:ti33x = "ti335x" 28TARGET_PRODUCT:ti33x = "ti335x_linux"
29TARGET_PRODUCT:ti43x = "ti437x" 29TARGET_PRODUCT:ti43x = "ti437x_linux"
30TARGET_PRODUCT:am65xx = "ti654x" 30TARGET_PRODUCT:am65xx = "ti654x_linux"
31PVR_BUILD = "release" 31PVR_BUILD = "release"
32PVR_WS = "nulldrmws" 32PVR_WS = "lws-generic"
33 33
34EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" BUILD=${PVR_BUILD} TARGET_PRODUCT=${TARGET_PRODUCT} WINDOW_SYSTEM=${PVR_WS}' 34EXTRA_OEMAKE += 'KERNELDIR="${STAGING_KERNEL_DIR}" BUILD=${PVR_BUILD} \
35 35WINDOW_SYSTEM=${PVR_WS} PVR_BUILD_DIR=${TARGET_PRODUCT}'
36do_compile:prepend() {
37 cd ${S}/eurasia_km/eurasiacon/build/linux2/omap_linux
38}
39 36
40do_install() { 37do_install() {
41 make -C ${STAGING_KERNEL_DIR} M=${B}/eurasia_km/eurasiacon/binary_omap_linux_${PVR_WS}_${PVR_BUILD}/target_armhf/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install 38 make -C ${STAGING_KERNEL_DIR} M=${B}/eurasiacon/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_armhf/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
42} 39}
43 40
44do_install:am65xx() { 41do_install:am65xx() {
45 make -C ${STAGING_KERNEL_DIR} M=${B}/eurasia_km/eurasiacon/binary_omap_linux_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install 42 make -C ${STAGING_KERNEL_DIR} M=${B}/eurasiacon/binary_${TARGET_PRODUCT}_${PVR_WS}_${PVR_BUILD}/target_aarch64/kbuild INSTALL_MOD_PATH=${D}${root_prefix} PREFIX=${STAGING_DIR_HOST} modules_install
46} 43}
47 44
48RRECOMMENDS:${PN} += "ti-sgx-ddk-um" 45RRECOMMENDS:${PN} += "ti-sgx-ddk-um"
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um/pvrsrvkm.rules b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um/pvrsrvkm.rules
deleted file mode 100644
index e49fd9b8..00000000
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um/pvrsrvkm.rules
+++ /dev/null
@@ -1 +0,0 @@
1SUBSYSTEM=="platform", ACTION=="bind", ENV{DRIVER}=="pvrsrvkm", RUN+="/usr/bin/pvrsrvctl --start --no-module"
diff --git a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb
index 755cc4f5..d2565318 100644
--- a/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb
+++ b/meta-ti-bsp/recipes-graphics/powervr-umlibs/ti-sgx-ddk-um_1.17.4948957.bb
@@ -1,38 +1,35 @@
1DESCRIPTION = "Userspace libraries for PowerVR SGX chipset on TI SoCs" 1DESCRIPTION = "Userspace libraries for PowerVR SGX chipset on TI SoCs"
2HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-um-linux" 2HOMEPAGE = "https://git.ti.com/graphics/omap5-sgx-ddk-um-linux"
3LICENSE = "TI-TSPA" 3LICENSE = "TI-TSPA"
4LIC_FILES_CHKSUM = "file://TI-Linux-Graphics-DDK-UM-Manifest.doc;md5=b17390502bc89535c86cfbbae961a2a8" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=7232b98c1c58f99e3baa03de5207e76f"
5 5
6PACKAGE_ARCH = "${MACHINE_ARCH}" 6PACKAGE_ARCH = "${MACHINE_ARCH}"
7COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|am65xx" 7COMPATIBLE_MACHINE = "ti33x|ti43x|omap-a15|am65xx"
8 8
9PR = "r38" 9PR = "r38"
10 10
11BRANCH = "ti-img-sgx/kirkstone-mesa/${PV}" 11BRANCH = "${PV}/mesa/glibc-2.35"
12 12
13SRC_URI = " \ 13SRC_URI = " \
14 git://git.ti.com/git/graphics/omap5-sgx-ddk-um-linux.git;protocol=https;branch=${BRANCH} \ 14 git://git.ti.com/git/graphics/omap5-sgx-ddk-um-linux.git;protocol=https;branch=${BRANCH} \
15 file://pvrsrvkm.rules \
16" 15"
17SRCREV = "bbae7217051341f515515ec190e165119102f45a" 16SRCREV = "70364424dd496833fad5b243c9e6cc8b077f04ac"
18
19TARGET_PRODUCT:ti33x = "ti335x"
20TARGET_PRODUCT:ti43x = "ti437x"
21TARGET_PRODUCT:omap-a15 = "ti572x"
22TARGET_PRODUCT:am65xx = "ti654x"
23 17
24INITSCRIPT_NAME = "rc.pvr" 18INITSCRIPT_NAME = "rc.pvr"
25INITSCRIPT_PARAMS = "defaults 8" 19INITSCRIPT_PARAMS = "defaults 8"
26 20
27PACKAGECONFIG ??= "udev" 21PACKAGECONFIG ??= "udev"
28PACKAGECONFIG[udev] = ",,,udev" 22PACKAGECONFIG[udev] = "UDEV=true,,,udev"
23
24def use_sysvinit(d):
25 return d.getVar('VIRTUAL-RUNTIME_init_manager') == 'sysvinit'
29 26
30def use_initscript(d): 27inherit ${@oe.utils.ifelse(use_sysvinit(d), 'update-rc.d', '')}
31 sysvinit = bb.utils.contains('DISTRO_FEATURES', 'sysvinit', True, False, d)
32 udev = bb.utils.contains('PACKAGECONFIG', 'udev', True, False, d)
33 return sysvinit and not udev
34 28
35inherit ${@oe.utils.ifelse(use_initscript(d), 'update-rc.d', '')} 29TARGET_PRODUCT:ti33x = "ti335x_linux"
30TARGET_PRODUCT:ti43x = "ti437x_linux"
31TARGET_PRODUCT:omap-a15 = "ti572x_linux"
32TARGET_PRODUCT:am65xx = "ti654x_linux"
36 33
37RDEPENDS:${PN} += "libdrm" 34RDEPENDS:${PN} += "libdrm"
38 35
@@ -40,24 +37,10 @@ RRECOMMENDS:${PN} += "ti-sgx-ddk-km"
40 37
41S = "${WORKDIR}/git" 38S = "${WORKDIR}/git"
42 39
43do_install () { 40EXTRA_OEMAKE += "DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT} ${PACKAGECONFIG_CONFARGS}"
44 oe_runmake install DESTDIR=${D} TARGET_PRODUCT=${TARGET_PRODUCT}
45
46 without_sysvinit=${@bb.utils.contains('DISTRO_FEATURES', 'sysvinit', 'false', 'true', d)}
47 with_udev=${@bb.utils.contains('PACKAGECONFIG', 'udev', 'true', 'false', d)}
48 41
49 # Delete initscript if it is not needed or would conflict with the udev rules 42do_install() {
50 if ${@oe.utils.ifelse(use_initscript(d), 'false', 'true')}; then 43 oe_runmake install
51 rm -rf ${D}${sysconfdir}/init.d
52 rmdir --ignore-fail-on-non-empty ${D}${sysconfdir}
53 fi
54
55 if $with_udev; then
56 install -m644 -D ${WORKDIR}/pvrsrvkm.rules \
57 ${D}${nonarch_base_libdir}/udev/rules.d/80-pvrsrvkm.rules
58 fi
59
60 chown -R root:root ${D}
61} 44}
62 45
63FILES:${PN} = "${bindir}/*" 46FILES:${PN} = "${bindir}/*"
@@ -66,6 +49,10 @@ FILES:${PN} += "${includedir}/*"
66FILES:${PN} += "${sysconfdir}/*" 49FILES:${PN} += "${sysconfdir}/*"
67FILES:${PN} += "${datadir}/*" 50FILES:${PN} += "${datadir}/*"
68FILES:${PN} += "${nonarch_base_libdir}/udev/rules.d" 51FILES:${PN} += "${nonarch_base_libdir}/udev/rules.d"
52FILES:${PN} += "${nonarch_base_libdir}/systemd/system"
53
54# No debug or dev packages for this recipe
55PACKAGES = "${PN}"
69 56
70INSANE_SKIP:${PN} += "ldflags" 57INSANE_SKIP:${PN} += "ldflags"
71INSANE_SKIP:${PN} += "already-stripped" 58INSANE_SKIP:${PN} += "already-stripped dev-so"