summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRyan Eatmon <reatmon@ti.com>2023-06-22 12:33:36 +0530
committerRyan Eatmon <reatmon@ti.com>2023-06-22 07:15:53 -0500
commit6c80d4efe2227857a2822f2c6fd87269eef1cd2e (patch)
treecaf896f79c3b3761293673348d2f7dd33f1b3b6f
parent1705f6d3c41302c6dae04e93bba84e203624e6c5 (diff)
downloadmeta-ti-6c80d4efe2227857a2822f2c6fd87269eef1cd2e.tar.gz
pruhsr-fw: SR2.0: Add new firmware
We need to package up new HSR firmware for am65x-sr2. Add dependencies for them on the correct platforms. Signed-off-by: Ryan Eatmon <reatmon@ti.com> Signed-off-by: Ravi Gunasekaran <r-gunasekaran@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb34
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc4
2 files changed, 36 insertions, 2 deletions
diff --git a/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
new file mode 100644
index 00000000..c31af832
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/pruhsr-fw/pruhsr-fw-am65x-sr2_git.bb
@@ -0,0 +1,34 @@
1SUMMARY = "PRU HSR firmware for AM65xx SR2.0"
2
3require recipes-bsp/ti-linux-fw/ti-linux-fw.inc
4
5PV = "${PRUETH_FW_AM65X_SR2_VERSION}"
6PR = "${INC_PR}.0"
7
8CLEANBROKEN = "1"
9
10COMPATIBLE_MACHINE = "am65xx-evm|am64xx"
11
12PACKAGE_ARCH = "${MACHINE_ARCH}"
13
14S = "${WORKDIR}/git"
15
16TARGET = " \
17 am65x-sr2-pru0-pruhsr-fw.elf \
18 am65x-sr2-pru1-pruhsr-fw.elf \
19 am65x-sr2-rtu0-pruhsr-fw.elf \
20 am65x-sr2-rtu1-pruhsr-fw.elf \
21 am65x-sr2-txpru0-pruhsr-fw.elf \
22 am65x-sr2-txpru1-pruhsr-fw.elf \
23"
24
25do_install() {
26 install -d ${D}${nonarch_base_libdir}/firmware/ti-pruss
27 for f in ${TARGET}; do
28 install -m 0644 ${S}/ti-pruss/$f ${D}${nonarch_base_libdir}/firmware/ti-pruss/$f
29 done
30}
31
32FILES:${PN} = "${nonarch_base_libdir}/firmware"
33
34INSANE_SKIP:${PN} = "arch"
diff --git a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
index d2dcc3e5..7c8f3171 100644
--- a/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
+++ b/meta-ti-bsp/recipes-kernel/linux/kernel-rdepends.inc
@@ -16,8 +16,8 @@ RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am57xx = " prueth-fw prusw-fw pruhsr
16RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " prueth-fw pruhsr-fw pruprp-fw" 16RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti43x = " prueth-fw pruhsr-fw pruprp-fw"
17RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " prueth-fw pruhsr-fw pruprp-fw" 17RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:ti33x = " prueth-fw pruhsr-fw pruprp-fw"
18RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx = " prueth-fw-am65x" 18RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx = " prueth-fw-am65x"
19RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx-evm = " prueth-fw-am65x-sr2 prusw-fw-am65x-sr2" 19RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am65xx-evm = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2 prusw-fw-am65x-sr2"
20RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2" 20RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:am64xx = " prueth-fw-am65x-sr2 pruhsr-fw-am65x-sr2"
21 21
22# Add run-time dependency for Cadence MHDP firmware to the rootfs 22# Add run-time dependency for Cadence MHDP firmware to the rootfs
23RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " cadence-mhdp-fw" 23RDEPENDS:${KERNEL_PACKAGE_NAME}-base:append:j721e = " cadence-mhdp-fw"