summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorParesh Bhagat <p-bhagat@ti.com>2023-06-11 14:54:44 -0500
committerRyan Eatmon <reatmon@ti.com>2023-06-14 12:34:38 -0500
commit3e3b625c8100ebaedd749acf9cb48d18f04b9c6a (patch)
treefc74921ea577dddf9308f6a205208e81ee064608
parente4dcd602af118630d684ab06dd7aa13f9deb6773 (diff)
downloadmeta-ti-3e3b625c8100ebaedd749acf9cb48d18f04b9c6a.tar.gz
ti-extras: Add support for extra kernel/u-boot features
There are some features that will either never be accepted into the upstream kernel, or are not ready to be accepted. ti-extras allows for controlling the kernel and u-boot repos, breanches, and srcrevs to gain access to those features via the TI_EXTRAS variable in the local.conf file. Initial support for TI_EXTRAS=tie-jailhouse is being added by this patch. Signed-off-by: Paresh Bhagat <p-bhagat@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com> Acked-by: Paresh Bhagat <p-bhagat@ti.com> Signed-off-by: Ryan Eatmon <reatmon@ti.com>
-rw-r--r--meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf1
-rw-r--r--meta-ti-bsp/conf/machine/am62xx-evm.conf1
-rw-r--r--meta-ti-bsp/conf/machine/include/ti-extras.inc5
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc12
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb2
-rw-r--r--meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc2
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb7
-rw-r--r--meta-ti-bsp/recipes-kernel/linux/ti-extras.inc14
-rw-r--r--meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb2
9 files changed, 42 insertions, 4 deletions
diff --git a/meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf b/meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf
index 9889ae38..548369ca 100644
--- a/meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf
+++ b/meta-ti-bsp/conf/machine/am62xx-evm-k3r5.conf
@@ -3,6 +3,7 @@
3#@DESCRIPTION: Machine configuration for the TI AM62xx EVM (R5F core) 3#@DESCRIPTION: Machine configuration for the TI AM62xx EVM (R5F core)
4 4
5require conf/machine/include/k3r5.inc 5require conf/machine/include/k3r5.inc
6require conf/machine/include/ti-extras.inc
6 7
7SYSFW_SOC = "am62x" 8SYSFW_SOC = "am62x"
8SYSFW_CONFIG = "evm" 9SYSFW_CONFIG = "evm"
diff --git a/meta-ti-bsp/conf/machine/am62xx-evm.conf b/meta-ti-bsp/conf/machine/am62xx-evm.conf
index c4357be3..082a1ae7 100644
--- a/meta-ti-bsp/conf/machine/am62xx-evm.conf
+++ b/meta-ti-bsp/conf/machine/am62xx-evm.conf
@@ -3,6 +3,7 @@
3#@DESCRIPTION: Machine configuration for the TI AM62XX EVM 3#@DESCRIPTION: Machine configuration for the TI AM62XX EVM
4 4
5require conf/machine/include/am62xx.inc 5require conf/machine/include/am62xx.inc
6require conf/machine/include/ti-extras.inc
6 7
7KERNEL_DEVICETREE_PREFIX = "ti/k3-am625" 8KERNEL_DEVICETREE_PREFIX = "ti/k3-am625"
8 9
diff --git a/meta-ti-bsp/conf/machine/include/ti-extras.inc b/meta-ti-bsp/conf/machine/include/ti-extras.inc
new file mode 100644
index 00000000..db9d0826
--- /dev/null
+++ b/meta-ti-bsp/conf/machine/include/ti-extras.inc
@@ -0,0 +1,5 @@
1# Add TI_EXTRAS to machine overrides so we get access to e.g. 'jailhouse'
2
3TI_EXTRAS ??= ""
4MACHINEOVERRIDES =. "${@ '${TI_EXTRAS}:' if d.getVar('TI_EXTRAS').startswith('tie-') else ''}"
5
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc b/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc
new file mode 100644
index 00000000..3a016c6c
--- /dev/null
+++ b/meta-ti-bsp/recipes-bsp/u-boot/ti-extras.inc
@@ -0,0 +1,12 @@
1
2# This will have priority over generic uboot path
3
4COMPATIBLE_MACHINE = "am62xx"
5
6BRANCH = "ti-u-boot-2023.04"
7BRANCH:tie-jailhouse = "ti-u-boot-2023.04-jailhouse"
8
9SRCREV = "010afc1fe7a1412f92363c8af69c848d76a53e42"
10SRCREV:tie-jailhouse = "79615e1c99b9aa73948f811f5f866cff2e34dc37"
11
12UBOOT_GIT_URI = "git://git.ti.com/git/processor-sdk/u-boot.git"
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
index f4c5e88c..4bde0256 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti-staging_2023.04.bb
@@ -1,5 +1,7 @@
1require u-boot-ti.inc 1require u-boot-ti.inc
2 2
3include ${@ 'recipes-bsp/u-boot/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''}
4
3LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1" 5LIC_FILES_CHKSUM = "file://Licenses/README;md5=2ca5f2c35c8cc335f0a19756634782f1"
4 6
5PR = "r0" 7PR = "r0"
diff --git a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
index f29b089e..f3285c23 100644
--- a/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
+++ b/meta-ti-bsp/recipes-bsp/u-boot/u-boot-ti.inc
@@ -16,7 +16,7 @@ LICENSE = "GPL-2.0-or-later"
16LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e" 16LIC_FILES_CHKSUM = "file://Licenses/README;md5=30503fd321432fc713238f582193b78e"
17 17
18BRANCH ?= "master" 18BRANCH ?= "master"
19UBOOT_GIT_URI = "git://git.ti.com/git/ti-u-boot/ti-u-boot.git" 19UBOOT_GIT_URI ?= "git://git.ti.com/git/ti-u-boot/ti-u-boot.git"
20UBOOT_GIT_PROTOCOL = "https" 20UBOOT_GIT_PROTOCOL = "https"
21SRC_URI = "${UBOOT_GIT_URI};protocol=${UBOOT_GIT_PROTOCOL};branch=${BRANCH}" 21SRC_URI = "${UBOOT_GIT_URI};protocol=${UBOOT_GIT_PROTOCOL};branch=${BRANCH}"
22 22
diff --git a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
index 0b36575b..688b8690 100644
--- a/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
+++ b/meta-ti-bsp/recipes-kernel/linux/linux-ti-staging_6.1.bb
@@ -9,6 +9,7 @@ require recipes-kernel/linux/setup-defconfig.inc
9require recipes-kernel/linux/kernel-rdepends.inc 9require recipes-kernel/linux/kernel-rdepends.inc
10require recipes-kernel/linux/ti-kernel.inc 10require recipes-kernel/linux/ti-kernel.inc
11include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''} 11include ${@ 'recipes-kernel/linux/ti-kernel-devicetree-prefix.inc' if d.getVar('KERNEL_DEVICETREE_PREFIX') else ''}
12include ${@ 'recipes-kernel/linux/ti-extras.inc' if d.getVar('TI_EXTRAS') else ''}
12 13
13DEPENDS += "gmp-native libmpc-native" 14DEPENDS += "gmp-native libmpc-native"
14 15
@@ -20,16 +21,16 @@ KERNEL_EXTRA_ARGS += "LOADADDR=${UBOOT_ENTRYPOINT} \
20 21
21S = "${WORKDIR}/git" 22S = "${WORKDIR}/git"
22 23
23BRANCH = "ti-linux-6.1.y" 24BRANCH ?= "ti-linux-6.1.y"
24 25
25SRCREV = "7124dee9779a40c52c52331c3ba6ccc84f357380" 26SRCREV ?= "7124dee9779a40c52c52331c3ba6ccc84f357380"
26PV = "6.1.26+git${SRCPV}" 27PV = "6.1.26+git${SRCPV}"
27 28
28# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild 29# Append to the MACHINE_KERNEL_PR so that a new SRCREV will cause a rebuild
29MACHINE_KERNEL_PR:append = "b" 30MACHINE_KERNEL_PR:append = "b"
30PR = "${MACHINE_KERNEL_PR}" 31PR = "${MACHINE_KERNEL_PR}"
31 32
32KERNEL_GIT_URI = "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git" 33KERNEL_GIT_URI ?= "git://git.ti.com/git/ti-linux-kernel/ti-linux-kernel.git"
33KERNEL_GIT_PROTOCOL = "https" 34KERNEL_GIT_PROTOCOL = "https"
34SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \ 35SRC_URI += "${KERNEL_GIT_URI};protocol=${KERNEL_GIT_PROTOCOL};branch=${BRANCH} \
35 file://defconfig" 36 file://defconfig"
diff --git a/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc b/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc
new file mode 100644
index 00000000..2bb88b13
--- /dev/null
+++ b/meta-ti-bsp/recipes-kernel/linux/ti-extras.inc
@@ -0,0 +1,14 @@
1
2# Use different commit, repo and branch for TI extras build
3# This will have priority over generic rt path
4
5COMPATIBLE_MACHINE = "am62xx"
6
7BRANCH = "ti-linux-6.1.y"
8BRANCH:tie-jailhouse = "ti-linux-6.1.y-jailhouse"
9
10SRCREV = "30bcc25e7cb1b25667db88d61828728f0f0b5f4b"
11SRCREV:tie-jailhouse = "0ed0dec2462b805b0188fe080895adc437871549"
12
13KERNEL_GIT_URI = "git://git.ti.com/git/processor-sdk/linux.git"
14
diff --git a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
index 05cc21b3..1c63b400 100644
--- a/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
+++ b/meta-ti-extras/recipes-ti/jailhouse/jailhouse_git.bb
@@ -10,6 +10,8 @@ LIC_FILES_CHKSUM = " \
10 file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \ 10 file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \
11" 11"
12 12
13COMPATIBLE_MACHINE = "am62xx"
14
13TARGET_CC_ARCH += "${LDFLAGS}" 15TARGET_CC_ARCH += "${LDFLAGS}"
14 16
15PV = "0.12+git${SRCPV}" 17PV = "0.12+git${SRCPV}"