diff options
author | Justin Sobota <jsobota@ti.com> | 2017-04-28 04:10:34 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2017-05-01 18:29:50 -0400 |
commit | e12f3832d1582207e5d45e6f43f7d12bb64bd9d7 (patch) | |
tree | e64a86bd7c7a55025bcc4c82f57867c4eeea0c4a | |
parent | 262b851a31bdcf2e167e568662540f3585ad28d6 (diff) | |
download | meta-ti-e12f3832d1582207e5d45e6f43f7d12bb64bd9d7.tar.gz |
Resolve host contamination warnings
Signed-off-by: Justin Sobota <jsobota@ti.com>
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | classes/ti-pdk.bbclass | 2 | ||||
-rw-r--r-- | recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb | 5 | ||||
-rw-r--r-- | recipes-ti/bios/ti-sysbios.inc | 3 | ||||
-rw-r--r-- | recipes-ti/devtools/ti-cg-xml_2.41.00.bb | 3 | ||||
-rw-r--r-- | recipes-ti/dsplib/dsplib-c66x.inc | 3 | ||||
-rw-r--r-- | recipes-ti/framework-components/ti-framework-components.inc | 3 | ||||
-rw-r--r-- | recipes-ti/imglib/imglib-c66x.inc | 3 | ||||
-rw-r--r-- | recipes-ti/mathlib/mathlib-c66x.inc | 3 | ||||
-rw-r--r-- | recipes-ti/xdais/ti-xdais.inc | 3 |
9 files changed, 18 insertions, 10 deletions
diff --git a/classes/ti-pdk.bbclass b/classes/ti-pdk.bbclass index eca3652c..981ec12e 100644 --- a/classes/ti-pdk.bbclass +++ b/classes/ti-pdk.bbclass | |||
@@ -89,7 +89,7 @@ do_compile() { | |||
89 | 89 | ||
90 | do_install () { | 90 | do_install () { |
91 | install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages | 91 | install -d ${D}${PDK_INSTALL_DIR_RECIPE}/packages |
92 | find -name "*.tar" -exec tar xf {} -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \; | 92 | find -name "*.tar" -exec tar xf {} --no-same-owner -C ${D}${PDK_INSTALL_DIR_RECIPE}/packages \; |
93 | 93 | ||
94 | if [ "${PDK_COMP_LINK_TEXT}" != "" ] | 94 | if [ "${PDK_COMP_LINK_TEXT}" != "" ] |
95 | then | 95 | then |
diff --git a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb index ce9ef855..7fd778a4 100644 --- a/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb +++ b/recipes-bsp/edma3-lld/edma3-lld-rtos_git.bb | |||
@@ -2,7 +2,7 @@ require edma3-lld.inc | |||
2 | require recipes-ti/includes/ti-paths.inc | 2 | require recipes-ti/includes/ti-paths.inc |
3 | require recipes-ti/includes/ti-staging.inc | 3 | require recipes-ti/includes/ti-staging.inc |
4 | 4 | ||
5 | PR = "${INC_PR}.0" | 5 | PR = "${INC_PR}.1" |
6 | 6 | ||
7 | DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native" | 7 | DEPENDS = "ti-sysbios ti-xdctools gcc-arm-none-eabi-native ti-cgt-arm-native ti-cgt6x-native" |
8 | 8 | ||
@@ -106,8 +106,9 @@ do_compile () { | |||
106 | } | 106 | } |
107 | 107 | ||
108 | do_install () { | 108 | do_install () { |
109 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
109 | install -d ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE} | 110 | install -d ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE} |
110 | cp -pPrf ${S}/* ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE} | 111 | cp ${CP_ARGS} ${S}/* ${D}${EDMA3_LLD_INSTALL_DIR_RECIPE} |
111 | } | 112 | } |
112 | 113 | ||
113 | INSANE_SKIP_${PN}-dev = "arch ldflags" | 114 | INSANE_SKIP_${PN}-dev = "arch ldflags" |
diff --git a/recipes-ti/bios/ti-sysbios.inc b/recipes-ti/bios/ti-sysbios.inc index 408be783..53b55a52 100644 --- a/recipes-ti/bios/ti-sysbios.inc +++ b/recipes-ti/bios/ti-sysbios.inc | |||
@@ -15,8 +15,9 @@ BINFILE="bios_setuplinux_${PV}.bin" | |||
15 | TI_BIN_UNPK_CMDS="Y: q:workdir:Y" | 15 | TI_BIN_UNPK_CMDS="Y: q:workdir:Y" |
16 | 16 | ||
17 | do_install() { | 17 | do_install() { |
18 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
18 | install -d ${D}${SYSBIOS_INSTALL_DIR_RECIPE} | 19 | install -d ${D}${SYSBIOS_INSTALL_DIR_RECIPE} |
19 | cp -pPrf ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE} | 20 | cp ${CP_ARGS} ${S}/* ${D}${SYSBIOS_INSTALL_DIR_RECIPE} |
20 | } | 21 | } |
21 | 22 | ||
22 | ALLOW_EMPTY_${PN} = "1" | 23 | ALLOW_EMPTY_${PN} = "1" |
diff --git a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb index 115254eb..a0387b7b 100644 --- a/recipes-ti/devtools/ti-cg-xml_2.41.00.bb +++ b/recipes-ti/devtools/ti-cg-xml_2.41.00.bb | |||
@@ -25,8 +25,9 @@ TI_BIN_UNPK_CMDS="" | |||
25 | TI_BIN_UNPK_ARGS="--prefix ${S} --mode silent" | 25 | TI_BIN_UNPK_ARGS="--prefix ${S} --mode silent" |
26 | 26 | ||
27 | do_install() { | 27 | do_install() { |
28 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
28 | install -d ${D}${CG_XML_INSTALL_DIR_RECIPE} | 29 | install -d ${D}${CG_XML_INSTALL_DIR_RECIPE} |
29 | cp -pPrf ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE} | 30 | cp ${CP_ARGS} ${S}/* ${D}${CG_XML_INSTALL_DIR_RECIPE} |
30 | } | 31 | } |
31 | 32 | ||
32 | FILES_${PN} += "${CG_XML_INSTALL_DIR_RECIPE}" | 33 | FILES_${PN} += "${CG_XML_INSTALL_DIR_RECIPE}" |
diff --git a/recipes-ti/dsplib/dsplib-c66x.inc b/recipes-ti/dsplib/dsplib-c66x.inc index 31acc1e8..ce978dbd 100644 --- a/recipes-ti/dsplib/dsplib-c66x.inc +++ b/recipes-ti/dsplib/dsplib-c66x.inc | |||
@@ -16,8 +16,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}" | |||
16 | TI_BIN_UNPK_CMDS = "" | 16 | TI_BIN_UNPK_CMDS = "" |
17 | 17 | ||
18 | do_install() { | 18 | do_install() { |
19 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
19 | install -d ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE} | 20 | install -d ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE} |
20 | cp -pPrf ${S}/* ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE} | 21 | cp ${CP_ARGS} ${S}/* ${D}${DSPLIB_C66_INSTALL_DIR_RECIPE} |
21 | } | 22 | } |
22 | 23 | ||
23 | ALLOW_EMPTY_${PN} = "1" | 24 | ALLOW_EMPTY_${PN} = "1" |
diff --git a/recipes-ti/framework-components/ti-framework-components.inc b/recipes-ti/framework-components/ti-framework-components.inc index e111ec45..d3a1d758 100644 --- a/recipes-ti/framework-components/ti-framework-components.inc +++ b/recipes-ti/framework-components/ti-framework-components.inc | |||
@@ -11,8 +11,9 @@ S = "${WORKDIR}/framework_components_${PV}" | |||
11 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc/${PV}/exports/framework_components_${PV},lite.tar.gz;name=fctarball" | 11 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/fc/${PV}/exports/framework_components_${PV},lite.tar.gz;name=fctarball" |
12 | 12 | ||
13 | do_install() { | 13 | do_install() { |
14 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
14 | install -d ${D}${FC_INSTALL_DIR_RECIPE} | 15 | install -d ${D}${FC_INSTALL_DIR_RECIPE} |
15 | cp -pPrf ${S}/* ${D}${FC_INSTALL_DIR_RECIPE} | 16 | cp ${CP_ARGS} ${S}/* ${D}${FC_INSTALL_DIR_RECIPE} |
16 | } | 17 | } |
17 | 18 | ||
18 | INSANE_SKIP_${PN} = "ldflags" | 19 | INSANE_SKIP_${PN} = "ldflags" |
diff --git a/recipes-ti/imglib/imglib-c66x.inc b/recipes-ti/imglib/imglib-c66x.inc index 3c76ad5e..eb575985 100644 --- a/recipes-ti/imglib/imglib-c66x.inc +++ b/recipes-ti/imglib/imglib-c66x.inc | |||
@@ -18,8 +18,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}" | |||
18 | TI_BIN_UNPK_CMDS = "" | 18 | TI_BIN_UNPK_CMDS = "" |
19 | 19 | ||
20 | do_install() { | 20 | do_install() { |
21 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
21 | install -d ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE} | 22 | install -d ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE} |
22 | cp -pPrf ${S}/* ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE} | 23 | cp ${CP_ARGS} ${S}/* ${D}${IMGLIB_C66_INSTALL_DIR_RECIPE} |
23 | } | 24 | } |
24 | 25 | ||
25 | ALLOW_EMPTY_${PN} = "1" | 26 | ALLOW_EMPTY_${PN} = "1" |
diff --git a/recipes-ti/mathlib/mathlib-c66x.inc b/recipes-ti/mathlib/mathlib-c66x.inc index 1511337e..7951e6ca 100644 --- a/recipes-ti/mathlib/mathlib-c66x.inc +++ b/recipes-ti/mathlib/mathlib-c66x.inc | |||
@@ -18,8 +18,9 @@ TI_BIN_UNPK_ARGS = "--mode silent --prefix ${S}" | |||
18 | TI_BIN_UNPK_CMDS = "" | 18 | TI_BIN_UNPK_CMDS = "" |
19 | 19 | ||
20 | do_install() { | 20 | do_install() { |
21 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
21 | install -d ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE} | 22 | install -d ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE} |
22 | cp -pPrf ${S}/* ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE} | 23 | cp ${CP_ARGS} ${S}/* ${D}${MATHLIB_C66_INSTALL_DIR_RECIPE} |
23 | } | 24 | } |
24 | 25 | ||
25 | ALLOW_EMPTY_${PN} = "1" | 26 | ALLOW_EMPTY_${PN} = "1" |
diff --git a/recipes-ti/xdais/ti-xdais.inc b/recipes-ti/xdais/ti-xdais.inc index a12ad640..24268b3a 100644 --- a/recipes-ti/xdais/ti-xdais.inc +++ b/recipes-ti/xdais/ti-xdais.inc | |||
@@ -11,8 +11,9 @@ S = "${WORKDIR}/xdais_${PV}" | |||
11 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/xdais/${PV}/exports/xdais_${PV}.tar.gz;name=xdaistarball" | 11 | SRC_URI = "http://software-dl.ti.com/dsps/dsps_public_sw/sdo_sb/targetcontent/xdais/${PV}/exports/xdais_${PV}.tar.gz;name=xdaistarball" |
12 | 12 | ||
13 | do_install() { | 13 | do_install() { |
14 | CP_ARGS="-Prf --preserve=mode,timestamps --no-preserve=ownership" | ||
14 | install -d ${D}${XDAIS_INSTALL_DIR_RECIPE} | 15 | install -d ${D}${XDAIS_INSTALL_DIR_RECIPE} |
15 | cp -pPrf ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE} | 16 | cp ${CP_ARGS} ${S}/* ${D}${XDAIS_INSTALL_DIR_RECIPE} |
16 | } | 17 | } |
17 | 18 | ||
18 | INHIBIT_PACKAGE_STRIP = "1" | 19 | INHIBIT_PACKAGE_STRIP = "1" |