diff options
author | Denys Dmytriyenko <denys@ti.com> | 2018-03-01 06:09:45 +0000 |
---|---|---|
committer | Denys Dmytriyenko <denys@ti.com> | 2018-03-01 13:51:54 -0500 |
commit | 1de61d5e03beda26e9707b0d28e27f78b4d2ac51 (patch) | |
tree | 4fe9850a232909b58fc272091b1a5face1db5f05 | |
parent | 2499f8265cc4fdcd2c051e44417b06a735ad0400 (diff) | |
download | meta-ti-1de61d5e03beda26e9707b0d28e27f78b4d2ac51.tar.gz |
recipes: remove outdated recipes, some deps are no longer satisfied
Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r-- | recipes-core/packagegroups/packagegroup-ti-test.bb | 26 | ||||
-rw-r--r-- | recipes-ti/beagleboard/beaglebone-tester.bb | 56 | ||||
-rw-r--r-- | recipes-ti/beagleboard/bonescript.bb | 38 | ||||
-rw-r--r-- | recipes-ti/beagleboard/bonescript/bone101.service | 11 | ||||
-rw-r--r-- | recipes-ti/beagleboard/bonescript/bonescript-git | 11 | ||||
-rw-r--r-- | recipes-ti/msp430/ti-msp430-chronos_1.05.00.00.bb | 55 |
6 files changed, 0 insertions, 197 deletions
diff --git a/recipes-core/packagegroups/packagegroup-ti-test.bb b/recipes-core/packagegroups/packagegroup-ti-test.bb deleted file mode 100644 index 6971f07d..00000000 --- a/recipes-core/packagegroups/packagegroup-ti-test.bb +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | DESCRIPTION = "Extended task to get System Test specific apps" | ||
2 | LICENSE = "MIT" | ||
3 | PR = "r1" | ||
4 | |||
5 | inherit packagegroup | ||
6 | |||
7 | TEST = "\ | ||
8 | bonnie++ \ | ||
9 | hdparm \ | ||
10 | iozone3 \ | ||
11 | iperf \ | ||
12 | lmbench \ | ||
13 | rt-tests \ | ||
14 | evtest \ | ||
15 | bc \ | ||
16 | memtester \ | ||
17 | " | ||
18 | |||
19 | TI_TEST = "\ | ||
20 | ltp-ddt \ | ||
21 | " | ||
22 | |||
23 | RDEPENDS_${PN} = "\ | ||
24 | ${TEST} \ | ||
25 | ${TI_TEST} \ | ||
26 | " | ||
diff --git a/recipes-ti/beagleboard/beaglebone-tester.bb b/recipes-ti/beagleboard/beaglebone-tester.bb deleted file mode 100644 index 66b98a4c..00000000 --- a/recipes-ti/beagleboard/beaglebone-tester.bb +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | DESCRIPTION = "BeagleBone tester scripts" | ||
2 | HOMEPAGE = "http://beagleboard.org/support" | ||
3 | |||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM="file://gpl.txt;md5=5b122a36d0f6dc55279a0ebc69f3c60b" | ||
6 | |||
7 | # only scripts and data | ||
8 | inherit allarch | ||
9 | |||
10 | PR = "r20" | ||
11 | |||
12 | SRC_URI = "git://github.com/koenkooi/validation-scripts.git;protocol=git \ | ||
13 | " | ||
14 | SRCREV = "487a13e2e4faaafa40ba5430600e6aeecf9581a8" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | do_install() { | ||
19 | install -d ${D}${localstatedir}/lib/bone-tester/component/data/ | ||
20 | install -d ${D}${localstatedir}/lib/bone-tester/init-scripts/ | ||
21 | install -d ${D}${localstatedir}/lib/bone-tester/lib | ||
22 | install -d ${D}${base_libdir}/systemd/system/multi-user.target.wants/ | ||
23 | install -d ${D}/boot/ | ||
24 | install -m 0755 ${S}/bone-tester/init-scripts/uEnv.txt ${D}/boot/uEnv.txt | ||
25 | |||
26 | # systemd configuration | ||
27 | ln -s ../bone-tester.service ${D}${base_libdir}/systemd/system/multi-user.target.wants/bone-tester.service | ||
28 | install -m 0755 ${S}/bone-tester/init-scripts/bone-tester.service ${D}${base_libdir}/systemd/system/bone-tester.service | ||
29 | install -m 0755 ${S}/bone-tester/init-scripts/init.sh ${D}${localstatedir}/lib/bone-tester/init-scripts/init.sh | ||
30 | |||
31 | for i in $(find ${S}/bone-tester/component/ -maxdepth 1 -type f) ; do | ||
32 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/component/ | ||
33 | done | ||
34 | for i in ${S}/bone-tester/component/data/* ; do | ||
35 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/component/data/ | ||
36 | done | ||
37 | for i in ${S}/bone-tester/lib/* ; do | ||
38 | install -m 0755 ${i} ${D}${localstatedir}/lib/bone-tester/lib/ | ||
39 | done | ||
40 | |||
41 | install -d ${D}${bindir} | ||
42 | install -m 0755 ${S}/testaudio ${D}${bindir} | ||
43 | |||
44 | } | ||
45 | |||
46 | |||
47 | FILES_${PN} += "${base_libdir}/systemd \ | ||
48 | /boot \ | ||
49 | " | ||
50 | |||
51 | RDEPENDS_${PN} = "alsa-utils-aplay sox iputils memtester" | ||
52 | RRECOMMENDS_${PN} = "kernel-module-g-zero \ | ||
53 | kernel-module-g-mass-storage \ | ||
54 | kernel-module-g-file-storage \ | ||
55 | kernel-module-smsc95xx" | ||
56 | |||
diff --git a/recipes-ti/beagleboard/bonescript.bb b/recipes-ti/beagleboard/bonescript.bb deleted file mode 100644 index b9dfbe63..00000000 --- a/recipes-ti/beagleboard/bonescript.bb +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | DESCRIPTION = "Scripting tools for the BeagleBoard and BeagleBone" | ||
2 | |||
3 | PR = "r15" | ||
4 | |||
5 | inherit systemd | ||
6 | |||
7 | LICENSE = "MIT" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=659ee0c98db2664403c769d6b9ab50eb" | ||
9 | |||
10 | SRC_URI = "http://dominion.thruhere.net/koen/angstrom/beaglebone/bonescript-6af82b41178c37644399b19039ea7e80c1dbf8ee.tar.bz2 \ | ||
11 | file://bonescript-git \ | ||
12 | file://bone101.service \ | ||
13 | " | ||
14 | SRC_URI[md5sum] = "e5e214857afbd2e59b52171e60810be2" | ||
15 | SRC_URI[sha256sum] = "e703416a63406c8b6c89fb1079406833ce6a9eb0ae1ba0a55fe3802b83186c50" | ||
16 | |||
17 | S = "${WORKDIR}/bonescript" | ||
18 | |||
19 | do_install() { | ||
20 | install -d ${D}${localstatedir}/lib/cloud9/ | ||
21 | cp -a ${S}/* ${D}${localstatedir}/lib/cloud9/ | ||
22 | cp -a ${S}/.git ${D}${localstatedir}/lib/cloud9/ | ||
23 | |||
24 | install -d ${D}${base_libdir}/systemd/system | ||
25 | install -m 0644 ${WORKDIR}/bone101.service ${D}${base_libdir}/systemd/system | ||
26 | |||
27 | rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/itof | ||
28 | rm -f ${D}${localstatedir}/lib/cloud9/node_modules/binary/node_modules/put/test/c/ftoi | ||
29 | } | ||
30 | |||
31 | NATIVE_SYSTEMD_SUPPORT = "1" | ||
32 | SYSTEMD_PACKAGES = "${PN}" | ||
33 | SYSTEMD_SERVICE_${PN} = "bone101.service" | ||
34 | |||
35 | FILES_${PN} += "${localstatedir} ${base_libdir}/systemd/system" | ||
36 | CONFFILES_${PN} += "${localstatedir}/lib/cloud9/.git/config" | ||
37 | RDEPENDS_${PN} = "nodejs cloud9" | ||
38 | RRECOMMENDS_${PN} = "git" | ||
diff --git a/recipes-ti/beagleboard/bonescript/bone101.service b/recipes-ti/beagleboard/bonescript/bone101.service deleted file mode 100644 index 49562ba4..00000000 --- a/recipes-ti/beagleboard/bonescript/bone101.service +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Beaglebone 101 presentation | ||
3 | ConditionPathExists=|/var/lib/cloud9 | ||
4 | |||
5 | [Service] | ||
6 | WorkingDirectory=/var/lib/cloud9 | ||
7 | ExecStart=/usr/bin/node bone101.js | ||
8 | |||
9 | [Install] | ||
10 | WantedBy=multi-user.target | ||
11 | |||
diff --git a/recipes-ti/beagleboard/bonescript/bonescript-git b/recipes-ti/beagleboard/bonescript/bonescript-git deleted file mode 100644 index d9e66cfb..00000000 --- a/recipes-ti/beagleboard/bonescript/bonescript-git +++ /dev/null | |||
@@ -1,11 +0,0 @@ | |||
1 | [core] | ||
2 | repositoryformatversion = 0 | ||
3 | filemode = true | ||
4 | bare = false | ||
5 | logallrefupdates = true | ||
6 | [remote "origin"] | ||
7 | fetch = +refs/heads/*:refs/remotes/origin/* | ||
8 | url = git://github.com/jadonk/bonescript.git | ||
9 | [branch "master"] | ||
10 | remote = origin | ||
11 | merge = refs/heads/master | ||
diff --git a/recipes-ti/msp430/ti-msp430-chronos_1.05.00.00.bb b/recipes-ti/msp430/ti-msp430-chronos_1.05.00.00.bb deleted file mode 100644 index dd493f8e..00000000 --- a/recipes-ti/msp430/ti-msp430-chronos_1.05.00.00.bb +++ /dev/null | |||
@@ -1,55 +0,0 @@ | |||
1 | DESCRIPTION = "eZ430 Chronos Tools - MSP430 Development Kit/Watch" | ||
2 | HOMEPAGE = "http://processors.wiki.ti.com/index.php/EZ430-Chronos" | ||
3 | LICENSE = "BSD-3-Clause" | ||
4 | # We can't use the actualy source file, since it has space in its name :( | ||
5 | LIC_FILES_CHKSUM = "file://eZ430-Chronos_CC_1_1.tcl;md5=59ba6ee0a26650ec660a4e65a9462806" | ||
6 | |||
7 | SECTION = "multimedia" | ||
8 | |||
9 | inherit allarch | ||
10 | |||
11 | PV = "1_05_00_00" | ||
12 | |||
13 | SRC_URI = "http://focus.ti.com/lit/sw/slac388/slac388.zip;name=slac388zip" | ||
14 | |||
15 | SRC_URI[slac388zip.md5sum] = "22d4104a07af584222828fb377793796" | ||
16 | SRC_URI[slac388zip.sha256sum] = "1c9cd1e36015e8db3b36c98be41907628144b76002b3f76b27fd310f4bd35ad7" | ||
17 | |||
18 | require ../includes/ti-paths.inc | ||
19 | require ../includes/ti-staging.inc | ||
20 | require ../includes/ti-eula-unpack.inc | ||
21 | |||
22 | S = "${WORKDIR}/ti/eZ430-Chronos" | ||
23 | |||
24 | BINFILE="Chronos-Setup" | ||
25 | TI_BIN_UNPK_CMDS="Y:workdir:" | ||
26 | |||
27 | do_unpack_append() { | ||
28 | os.system('mv "Texas Instruments" ti') | ||
29 | } | ||
30 | |||
31 | do_configure() { | ||
32 | cp Control\ Center/Chronos\ Control\ Center/eZ430-Chronos_CC_1_1.tcl ${S} | ||
33 | } | ||
34 | |||
35 | do_compile() { | ||
36 | echo "Do Nothing for Now" | ||
37 | } | ||
38 | |||
39 | do_install() { | ||
40 | |||
41 | install -d ${D}/${installdir}/ti-msp430-chronos-apps | ||
42 | cp -pPrf "${S}"/"Control Center"/* ${D}/${installdir}/ti-msp430-chronos-apps | ||
43 | |||
44 | # Remove dos formatting | ||
45 | dos2unix "${D}/${installdir}/ti-msp430-chronos-apps/Chronos Data Logger"/* | ||
46 | dos2unix "${D}/${installdir}/ti-msp430-chronos-apps/Chronos Control Center"/* | ||
47 | |||
48 | # Should probably also remove hardcoded script reference to tcl8.5 | ||
49 | } | ||
50 | |||
51 | PACKAGES += "ti-msp430-chronos-apps" | ||
52 | FILES_ti-msp430-chronos-apps = "${installdir}/ti-msp430-chronos-apps/*" | ||
53 | |||
54 | RDEPENDS_ti-msp430-chronos-apps += " tcl tk xdotool" | ||
55 | RRECOMMENDS_ti-msp430-chronos-apps = "kernel-module-cdc-acm" | ||